]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- rel .3
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2
3 # Conditional build:
4 %bcond_with     x               # Use the X Windows System
5 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
6 %bcond_with     lzma            # Enable lzma support
7 %bcond_with     python          # Enable Python scripting support
8 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
9 %bcond_with     verbose         # verbose build (V=1)
10 %bcond_without  256             # Disable 256 colors support
11 %bcond_without  bittorrent      # Disable BitTorrent support
12 %bcond_without  cgi             # Disable Local CGI support
13 %bcond_without  fsp             # Disable FSP support
14 %bcond_without  guile           # Disable Guile scripting
15 %bcond_without  idn             # Disable Internation Domain Names support
16 %bcond_without  ipv6            # Disable IPv6 support
17 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
18 %bcond_without  led             # Disable LEDs
19 %bcond_without  lua             # Disable Lua scripting
20 %bcond_without  openssl         # Disable OpenSSL support
21 %bcond_without  perl            # Disable Perl scripting
22 %bcond_without  smb             # Disable smb protocol support (smb requires libsmbclient)
23
24 %if %{with gnutls}
25 %undefine       with_openssl
26 %endif
27 #
28 %define         pre     pre1
29 Summary:        Experimantal Links (text WWW browser)
30 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
31 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
32 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
33 Name:           elinks
34 Version:        0.12
35 Release:        0.%{pre}.3
36 Epoch:          1
37 License:        GPL
38 Group:          Applications/Networking
39 Source0:        http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
40 # Source0-md5:  23f745c33ea91f91ef5b2db385efdfff
41 Source1:        %{name}.desktop
42 Source2:        links.png
43 Patch0:         %{name}-home_etc.patch
44 Patch1:         %{name}-lua40.patch
45 Patch2:         %{name}-date-format.patch
46 URL:            http://www.elinks.cz/
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  bzip2-devel
50 BuildRequires:  expat-devel
51 %{?with_fsp:BuildRequires:      fsplib-devel}
52 BuildRequires:  gettext-devel
53 BuildRequires:  gpm-devel
54 %{?with_guile:BuildRequires: guile-devel}
55 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
56 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
57 %{?with_idn:BuildRequires:      libidn-devel}
58 %{?with_smb:BuildRequires:      libsmbclient-devel}
59 %{?with_lua:BuildRequires:      lua50-devel}
60 %{?with_lzma:BuildRequires:     lzma-devel}
61 BuildRequires:  ncurses-devel >= 5.1
62 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
63 %{?with_perl:BuildRequires:     perl-devel}
64 %{?with_python:BuildRequires:   python-devel}
65 %{?with_ruby:BuildRequires:     ruby-devel}
66 BuildRequires:  zlib-devel
67 Suggests:       mailcap
68 Provides:       webclient
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir     /etc/elinks
72 %define         specflags_ia32  -fomit-frame-pointer 
73
74 %description
75 This is the elinks tree - intended to provide feature-rich version of
76 links, however not rock-stable and dedicated mainly for testing. Its
77 purpose is to make alternative to links, until Mikulas will have some
78 time to maintain it, and to test and tune various patches for Mikulas
79 to be able to include them in the official links releases.
80
81 %description -l es.UTF-8
82 Links es un browser WWW modo texto, similar al Lynx. El links muestra
83 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
84 keepalive.
85
86 %description -l pl.UTF-8
87 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
88 elinks jednak jest dedykowana głównie do testowania.
89
90 %description -l pt_BR.UTF-8
91 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
92 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
93 keepalive.
94
95 %prep
96 %setup -q -n %{name}-%{version}%{pre}
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %configure \
106         %{?with_smb:--enable-smb} \
107         --disable-no-root \
108         %{!?debug:--enable-fastmem} \
109         %{?debug:--enable-debug} \
110         %{!?with_ipv6:--disable-ipv6} \
111         %{?with_bittorrent:--enable-bittorrent} \
112         %{?with_cgi:--enable-cgi} \
113         --enable-finger \
114         --enable-gopher \
115         --enable-nntp \
116         %{?with_256:--enable-256-colors} \
117         --enable-exmode \
118         %{?with_fsp:--enable-fsp} \
119         %{?with_leds:--enable-leds} \
120         --enable-marks \
121         --enable-html-highlight \
122         %{!?with_idn:--without-idn} \
123         %{?with_guile:--with-guile} \
124         %{?with_perl:--with-perl} \
125         %{!?with_lua:--without-lua} \
126         %{?with_python:--with-python} \
127         %{?with_ruby:--with-ruby} \
128         %{!?with_js:--without-spidermonkey} \
129         %{?with_gnutls:--with-gnutls} \
130         %{!?with_openssl:--without-openssl} \
131         --with%{!?with_x:out}-x \
132         %{!?with_lzma:--without-lzma}
133 # xterm -e is default, one might want to change it to
134 # something else
135 #       --with-xterm="xterm -e"
136
137 %{__make} %{?with_verbose:V=1}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT%{_desktopdir} \
142         $RPM_BUILD_ROOT%{_datadir}/%{name} \
143         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
144
145 %{__make} install %{?with_verbose:V=1} \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
149 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
150
151 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
161 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
162 %doc contrib/conv/{*awk,*.pl,*.sh}
163 %doc doc/html/*.html
164 %attr(755,root,root) %{_bindir}/*
165 %{_mandir}/man*/*
166 %{_desktopdir}/*.desktop
167 %{_pixmapsdir}/*
168 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.036066 seconds and 3 git commands to generate.