]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- note to previous changelog entry
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x               # Use the X Windows System
4 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
6 %bcond_without  256             # Disable 256 colors support
7 %bcond_without  bittorrent      # Disable BitTorrent support
8 %bcond_without  cgi             # Disable Local CGI support
9 %bcond_without  guile           # Disable Guile scripting
10 %bcond_without  idn             # Disable Internation Domain Names support
11 %bcond_without  ipv6            # Disable IPv6 support
12 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
13 %bcond_without  led             # Disable LEDs
14 %bcond_without  lua             # Disable Lua scripting
15 %bcond_without  openssl         # Disable OpenSSL support
16 %bcond_without  perl            # Disable Perl scripting
17
18 %if %{with gnutls}
19 %undefine       with_openssl
20 %endif
21 #
22 Summary:        Experimantal Links (text WWW browser)
23 Summary(es):    El links es un browser para modo texto, similar a lynx
24 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
25 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
26 Name:           elinks
27 Version:        0.11.2
28 Release:        1
29 Epoch:          1
30 License:        GPL
31 Group:          Applications/Networking
32 #Source0Download:       http://www.elinks.cz/download.html
33 Source0:        http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
34 # Source0-md5:  5a8f83afb527cf443f58b372136a81fc
35 Source1:        %{name}.desktop
36 Source2:        links.png
37 Patch0:         %{name}-home_etc.patch
38 Patch1:         %{name}-lua40.patch
39 Patch2:         %{name}-pl.po-update.patch
40 URL:            http://www.elinks.cz/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  bzip2-devel
44 BuildRequires:  expat-devel
45 BuildRequires:  fsplib-devel
46 BuildRequires:  gettext-devel
47 BuildRequires:  gpm-devel
48 %{?with_guile:BuildRequires: guile-devel}
49 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
50 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
51 %{?with_idn:BuildRequires:      libidn-devel}
52 %{?with_lua:BuildRequires:      lua50-devel}
53 BuildRequires:  ncurses-devel >= 5.1
54 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
55 %{?with_perl:BuildRequires:     perl-devel}
56 %{?with_ruby:BuildRequires:     ruby-devel}
57 BuildRequires:  zlib-devel
58 Provides:       webclient
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _sysconfdir     /etc/elinks
62 %define         specflags_ia32  -fomit-frame-pointer 
63
64 %description
65 This is the elinks tree - intended to provide feature-rich version of
66 links, however not rock-stable and dedicated mainly for testing. Its
67 purpose is to make alternative to links, until Mikulas will have some
68 time to maintain it, and to test and tune various patches for Mikulas
69 to be able to include them in the official links releases.
70
71 %description -l es
72 Links es un browser WWW modo texto, similar al Lynx. El links muestra
73 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
74 keepalive.
75
76 %description -l pl
77 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
78 elinks jednak jest dedykowana g³ównie do testowania.
79
80 %description -l pt_BR
81 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
82 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
83 keepalive.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 %build
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %configure \
96         --disable-no-root \
97         HAVE_SMBCLIENT=yes \
98         %{!?debug:--enable-fastmem} \
99         %{?debug:--enable-debug} \
100         %{!?with_ipv6:--disable-ipv6} \
101         %{?with_bittorrent:--enable-bittorrent} \
102         %{?with_cgi:--enable-cgi} \
103         --enable-finger \
104         --enable-gopher \
105         --enable-nntp \
106         %{?with_256:--enable-256-colors} \
107         --enable-exmode \
108         --enable-fsp \
109         %{?with_leds:--enable-leds} \
110         --enable-marks \
111         --enable-html-highlight \
112         %{!?with_idn:--without-idn} \
113         %{?with_guile:--with-guile} \
114         %{?with_perl:--with-perl} \
115         %{!?with_lua:--without-lua} \
116         %{?with_ruby:--with-ruby} \
117         %{!?with_js:--without-spidermonkey} \
118         %{?with_gnutls:--with-gnutls} \
119         %{!?with_openssl:--without-openssl} \
120         --with%{!?with_x:out}-x
121 # xterm -e is default, one might want to change it to
122 # something else
123 #       --with-xterm="xterm -e"
124
125 %{__make} V=1
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_desktopdir} \
130         $RPM_BUILD_ROOT%{_datadir}/%{name} \
131         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
132
133 %{__make} install V=1 \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
137 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
138
139 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
149 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
150 %doc contrib/conv/{*awk,*.pl,*.sh}
151 %doc doc/html/*.html
152 %attr(755,root,root) %{_bindir}/*
153 %{_mandir}/man*/*
154 %{_desktopdir}/*.desktop
155 %{_pixmapsdir}/*
156 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.049013 seconds and 3 git commands to generate.