]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- release 2
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2
3 # Conditional build:
4 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     lzma            # Enable lzma support
6 %bcond_with     python          # Enable Python scripting support
7 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
8 %bcond_with     verbose         # verbose build (V=1)
9 %bcond_with     x               # Use the X Windows System
10 %bcond_without  256             # Disable 256 colors support
11 %bcond_without  bittorrent      # Disable BitTorrent support
12 %bcond_without  cgi             # Disable Local CGI support
13 %bcond_without  fsp             # Disable FSP support
14 %bcond_without  guile           # Disable Guile scripting
15 %bcond_without  idn             # Disable Internation Domain Names support
16 %bcond_without  ipv6            # Disable IPv6 support
17 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
18 %bcond_without  led             # Disable LEDs
19 %bcond_without  lua             # Disable Lua scripting
20 %bcond_without  openssl         # Disable OpenSSL support
21 %bcond_without  perl            # Disable Perl scripting
22 %bcond_without  smb             # Disable smb protocol support (smb requires libsmbclient)
23
24 %if %{with gnutls}
25 %undefine       with_openssl
26 %endif
27 #
28 %define         pre     pre2
29 Summary:        Experimantal Links (text WWW browser)
30 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
31 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
32 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
33 Name:           elinks
34 Version:        0.12
35 Release:        0.%{pre}.2
36 Epoch:          1
37 License:        GPL
38 Group:          Applications/Networking
39 Source0:        http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
40 # Source0-md5:  bfc2a531f633c9e25e108e5ce2d864ea
41 Source1:        %{name}.desktop
42 Source2:        links.png
43 Patch0:         %{name}-home_etc.patch
44 Patch1:         %{name}-lua40.patch
45 Patch2:         %{name}-date-format.patch
46 Patch3:         %{name}-old_incremental.patch
47 URL:            http://www.elinks.cz/
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  bzip2-devel
51 BuildRequires:  expat-devel
52 %{?with_fsp:BuildRequires:      fsplib-devel}
53 BuildRequires:  gettext-devel
54 BuildRequires:  gpm-devel
55 %{?with_guile:BuildRequires: guile-devel}
56 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
57 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
58 %{?with_idn:BuildRequires:      libidn-devel}
59 %{?with_smb:BuildRequires:      libsmbclient-devel}
60 %{?with_lua:BuildRequires:      lua50-devel}
61 %{?with_lzma:BuildRequires:     lzma-devel}
62 BuildRequires:  ncurses-devel >= 5.1
63 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
64 %{?with_perl:BuildRequires:     perl-devel}
65 %{?with_python:BuildRequires:   python-devel}
66 %{?with_ruby:BuildRequires:     ruby-devel}
67 BuildRequires:  zlib-devel
68 Suggests:       mailcap
69 Provides:       webclient
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _sysconfdir     /etc/elinks
73 %define         specflags_ia32  -fomit-frame-pointer 
74
75 %description
76 This is the elinks tree - intended to provide feature-rich version of
77 links, however not rock-stable and dedicated mainly for testing. Its
78 purpose is to make alternative to links, until Mikulas will have some
79 time to maintain it, and to test and tune various patches for Mikulas
80 to be able to include them in the official links releases.
81
82 %description -l es.UTF-8
83 Links es un browser WWW modo texto, similar al Lynx. El links muestra
84 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
85 keepalive.
86
87 %description -l pl.UTF-8
88 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
89 elinks jednak jest dedykowana głównie do testowania.
90
91 %description -l pt_BR.UTF-8
92 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
93 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
94 keepalive.
95
96 %prep
97 %setup -q -n %{name}-%{version}%{pre}
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 # restores old behaviour of type-ahead search
102 #%patch3 -p1
103
104 %build
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %configure \
109         %{?with_smb:--enable-smb} \
110         --disable-no-root \
111         %{!?debug:--enable-fastmem} \
112         %{?debug:--enable-debug} \
113         %{!?with_ipv6:--disable-ipv6} \
114         %{?with_bittorrent:--enable-bittorrent} \
115         %{?with_cgi:--enable-cgi} \
116         --enable-finger \
117         --enable-gopher \
118         --enable-nntp \
119         %{?with_256:--enable-256-colors} \
120         --enable-exmode \
121         %{?with_fsp:--enable-fsp} \
122         %{?with_leds:--enable-leds} \
123         --enable-marks \
124         --enable-html-highlight \
125         %{!?with_idn:--without-idn} \
126         %{?with_guile:--with-guile} \
127         %{?with_perl:--with-perl} \
128         %{!?with_lua:--without-lua} \
129         %{?with_python:--with-python} \
130         %{?with_ruby:--with-ruby} \
131         %{!?with_js:--without-spidermonkey} \
132         %{?with_gnutls:--with-gnutls} \
133         %{!?with_openssl:--without-openssl} \
134         --with%{!?with_x:out}-x \
135         %{!?with_lzma:--without-lzma}
136 # xterm -e is default, one might want to change it to
137 # something else
138 #       --with-xterm="xterm -e"
139
140 %{__make} %{?with_verbose:V=1}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT%{_desktopdir} \
145         $RPM_BUILD_ROOT%{_datadir}/%{name} \
146         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
147
148 %{__make} install %{?with_verbose:V=1} \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
152 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
153
154 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
164 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
165 %doc contrib/conv/{*awk,*.pl,*.sh}
166 %doc doc/html/*.html
167 %attr(755,root,root) %{_bindir}/*
168 %{_mandir}/man*/*
169 %{_desktopdir}/*.desktop
170 %{_pixmapsdir}/*
171 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.095203 seconds and 3 git commands to generate.