]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
refresh config.sub
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 # - protocols
4 %bcond_without  bittorrent      # BitTorrent protocol support
5 %bcond_without  fsp             # FSP support
6 %bcond_without  idn             # Internation Domain Names support
7 %bcond_without  ipv6            # IPv6 support
8 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
9 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
10 %bcond_without  openssl         # OpenSSL-based SSL support
11 # - content
12 %bcond_without  cgi             # Local CGI support
13 %bcond_with     brotli          # Brotli compression support
14 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
16 # - scripting
17 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
18 %bcond_without  lua             # Lua scripting
19 %bcond_without  perl            # Perl scripting
20 %bcond_with     python          # Python scripting support
21 %bcond_with     ruby            # (experimental) Ruby scripting support
22 # - display and UI
23 %bcond_without  256             # 256 colors support
24 %bcond_without  led             # LEDs
25 %bcond_without  truecolor       # true color
26 %bcond_with     olderisbetter   # variuos pre-0.10.0 behaviour rules (typeahead and esc-esc)
27 %bcond_with     x               # Use the X Window System
28 # - misc
29 %bcond_without  verbose         # verbose build (V=1)
30
31 %if %{with gnutls}
32 %undefine       with_openssl
33 %endif
34
35 Summary:        Experimantal Links (text WWW browser)
36 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
37 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
38 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
39 Name:           elinks
40 Version:        0.13
41 %define snap    20180901
42 %define rel     5
43 Release:        4.%{snap}.%{rel}
44 Epoch:          1
45 License:        GPL v2
46 Group:          Applications/Networking
47 # github gives different archive on each download
48 # http://www.elinks.cz/download/%{name}-current-%{version}.tar.bz2
49 Source0:        http://elinks.cz/download/elinks-current-%{version}.tar.bz2
50 # Source0-md5:  6e45361ed14855ad02d3ae9b7a6ad809
51 Source1:        %{name}.desktop
52 Source2:        links.png
53 Patch0:         %{name}-home_etc.patch
54 Patch1:         %{name}-lua40.patch
55 Patch2:         %{name}-date-format.patch
56 Patch3:         %{name}-old_incremental.patch
57 Patch4:         %{name}-0.10.0-0.9.3-typeahead-beginning.patch
58 Patch5:         %{name}-double-esc.patch
59 Patch6:         js187.patch
60 URL:            http://www.elinks.cz/
61 BuildRequires:  autoconf >= 2.61
62 BuildRequires:  automake
63 BuildRequires:  bzip2-devel
64 BuildRequires:  expat-devel
65 %{?with_fsp:BuildRequires:      fsplib-devel}
66 BuildRequires:  gettext-tools
67 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
68 BuildRequires:  gpm-devel
69 %{?with_guile:BuildRequires: guile-devel}
70 #BuildRequires: heimdal-devel
71 %{?with_js:BuildRequires:       js187-devel}
72 %{?with_brotli:BuildRequires:   libbrotli-devel}
73 %{?with_idn:BuildRequires:      libidn-devel}
74 %{?with_smb:BuildRequires:      libsmbclient-devel}
75 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
76 %{?with_lzma:BuildRequires:     lzma-devel}
77 BuildRequires:  ncurses-devel >= 5.1
78 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
79 %{?with_perl:BuildRequires:     perl-devel}
80 BuildRequires:  pkgconfig
81 %{?with_python:BuildRequires:   python-devel}
82 %{?with_ruby:BuildRequires:     ruby-devel}
83 BuildRequires:  tre-devel
84 BuildRequires:  which
85 BuildRequires:  zlib-devel
86 Suggests:       mailcap
87 Provides:       webclient
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _sysconfdir     /etc/elinks
91 %define         specflags_ia32  -fomit-frame-pointer
92
93 %description
94 This is the elinks tree - intended to provide feature-rich version of
95 links, however not rock-stable and dedicated mainly for testing. Its
96 purpose is to make alternative to links, until Mikulas will have some
97 time to maintain it, and to test and tune various patches for Mikulas
98 to be able to include them in the official links releases.
99
100 %description -l es.UTF-8
101 Links es un browser WWW modo texto, similar al Lynx. El links muestra
102 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
103 keepalive.
104
105 %description -l pl.UTF-8
106 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
107 elinks jednak jest dedykowana głównie do testowania.
108
109 %description -l pt_BR.UTF-8
110 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
111 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
112 keepalive.
113
114 %prep
115 %setup -q -n %{name}-%{version}-%{snap}
116 %patch0 -p1
117 %patch1 -p1
118 %patch2 -p1
119 %if %{with olderisbetter}
120 %patch3 -p1
121 %patch4 -p1
122 %patch5 -p1
123 %endif
124 %patch6 -p1
125
126 %build
127 cp -f /usr/share/automake/config.sub config
128 %{__aclocal}
129 %{__autoconf}
130 %{__autoheader}
131 %configure \
132         %{?with_bittorrent:--enable-bittorrent} \
133         %{?with_cgi:--enable-cgi} \
134         --enable-88-colors \
135         %{?with_256:--enable-256-colors} \
136         %{?with_truecolor:--enable-true-color} \
137         --enable-exmode \
138         %{?debug:--enable-debug} \
139         %{!?debug:--enable-fastmem} \
140         --enable-finger \
141         %{?with_fsp:--enable-fsp} \
142         --enable-gopher \
143         --enable-html-highlight \
144         %{!?with_ipv6:--disable-ipv6} \
145         %{?with_leds:--enable-leds} \
146         --enable-marks \
147         --enable-nntp \
148         --disable-no-root \
149         %{?with_smb:--enable-smb} \
150         %{!?with_brotli:--without-brotli} \
151         --without-gc \
152         %{?with_gnutls:--with-gnutls} \
153         %{?with_guile:--with-guile} \
154         %{!?with_idn:--without-idn} \
155         %{!?with_lua:--without-lua} \
156         %{!?with_lzma:--without-lzma} \
157         %{!?with_openssl:--without-openssl} \
158         %{?with_perl:--with-perl} \
159         %{?with_python:--with-python} \
160         %{?with_ruby:--with-ruby} \
161         %{!?with_js:--without-spidermonkey} \
162         --with-x%{!?with_x:=no}
163 # xterm -e is default, one might want to change it to something else:
164 #       --with-xterm="xterm -e"
165
166 %{__make} %{?with_verbose:V=1}
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT%{_desktopdir} \
171         $RPM_BUILD_ROOT%{_datadir}/%{name} \
172         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
173
174 %{__make} install %{?with_verbose:V=1} \
175         DESTDIR=$RPM_BUILD_ROOT
176
177 %{__rm} $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
178
179 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
180 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
181
182 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
183
184 %find_lang %{name}
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %files -f %{name}.lang
190 %defattr(644,root,root,755)
191 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO doc/html/*.html
192 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh}
193 %attr(755,root,root) %{_bindir}/elinks
194 %{_mandir}/man1/elinks.1*
195 %{_mandir}/man5/elinks.conf.5*
196 %{_mandir}/man5/elinkskeys.5*
197 %{_desktopdir}/elinks.desktop
198 %{_pixmapsdir}/elinks.png
199 %if %{with lua}
200 %dir %{_sysconfdir}
201 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
202 %endif
This page took 0.07828 seconds and 3 git commands to generate.