]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- merge from DEVEL (to be reviewed)
[packages/elinks.git] / elinks.spec
1 # Conditional build:
2 %bcond_with     x       # Use the X Windows System
3 %bcond_with     gnutls  # Enable GNUTLS SSL support (disables openssl)
4 %bcond_with     js      # Enable experimental JavaScript support (using SpiderMonkey)
5 %bcond_without  256     # Disable 256 colors support
6 %bcond_without  cgi     # Disable Local CGI support
7 %bcond_without  guile   # Disable Guile scripting
8 %bcond_without  idn     # Disable Internation Domain Names support
9 %bcond_without  ipv6    # Disable IPv6 support
10 %bcond_without  led     # Disable LEDs
11 %bcond_without  lua     # Disable Lua scripting
12 %bcond_without  openssl # Disable OpenSSL support
13 %bcond_without  perl    # Disable Perl scripting
14
15 %if %{with gnutls}
16 %undefine       with_openssl
17 %endif
18 #
19 Summary:        Experimantal Links (text WWW browser)
20 Summary(es):    El links es un browser para modo texto, similar a lynx
21 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
22 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
23 Name:           elinks
24 Version:        0.10.0
25 Release:        0.1
26 Epoch:          1
27 License:        GPL
28 Group:          Applications/Networking
29 #Source0Download:       http://elinks.or.cz/download.html
30 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
31 # Source0-md5:  09a199b496bcdaf54791f2010a8351b8
32 Source1:        %{name}.desktop
33 Source2:        links.png
34 #Patch0:                %{name}-pl_po.patch
35 Patch1:         %{name}-home_etc.patch
36 Patch2:         %{name}-lua40.patch
37 Patch3:         %{name}-locale_names.patch
38 URL:            http://elinks.or.cz/
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  bzip2-devel
42 BuildRequires:  expat-devel
43 BuildRequires:  gettext-devel
44 BuildRequires:  gpm-devel
45 %{?with_guile:BuildRequires: guile-devel}
46 %{?with_gnutls:BuildRequires: gnutls-devel}
47 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
48 %{?with_idn:BuildRequires:      libidn-devel}
49 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
50 BuildRequires:  ncurses-devel => 5.1
51 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
52 %{?with_perl:BuildRequires:     perl-devel}
53 BuildRequires:  zlib-devel
54 BuildRequires:  tetex
55 Provides:       webclient
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _sysconfdir     /etc/elinks
59 %define         specflags_ia32   -fomit-frame-pointer 
60
61 %description
62 This is the elinks tree - intended to provide feature-rich version of
63 links, however not rock-stable and dedicated mainly for testing. Its
64 purpose is to make alternative to links, until Mikulas will have some
65 time to maintain it, and to test and tune various patches for Mikulas
66 to be able to include them in the official links releases.
67
68 %description -l es
69 Links es un browser WWW modo texto, similar al Lynx. El links muestra
70 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
71 keepalive.
72
73 %description -l pl
74 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
75 elinks jednak jest dedykowana g³ównie do testowania.
76
77 %description -l pt_BR
78 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
79 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
80 keepalive.
81
82 %prep
83 %setup -q
84 #%patch0 -p0
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88
89 mv -f po/{no,nb}.po
90
91 %build
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{!?debug:--enable-fastmem} \
98         %{?debug:--enable-debug} \
99         %{!?with_ipv6:--disable-ipv6} \
100         %{?with_cgi:--enable-cgi} \
101         --enable-finger \
102         --enable-gopher \
103         --enable-nntp \
104         %{?with_256:--enable-256-colors} \
105         --enable-exmode \
106         %{?with_leds:--enable-leds} \
107         --enable-html-highlight \
108         --enable-no-root \
109         %{!?with_idn:--without-idn} \
110         %{?with_guile:--with-guile} \
111         %{?with_perl:--with-perl} \
112         %{!?with_lua:--without-lua} \
113         %{!?with_js:--without-spidermonkey} \
114         %{?with_gnutls:--with-gnutls} \
115         %{!?with_openssl:--without-openssl} \
116         %{?with_x:--with-x} 
117
118 %{__make}
119
120 cd doc
121 texi2html elinks-lua.texi
122 cd ..
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_desktopdir} \
127         $RPM_BUILD_ROOT%{_datadir}/%{name} \
128         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
134 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
135
136 install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
146 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
147 %doc contrib/conv/{*awk,*.pl,*.sh}
148 %doc doc/{*.txt,*.html}
149 %attr(755,root,root) %{_bindir}/*
150 %{_mandir}/man*/*
151 %{_desktopdir}/*
152 %{_pixmapsdir}/*
153 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.068942 seconds and 3 git commands to generate.