]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- bump quickjs BR to properly packaged version
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 # - protocols
4 %bcond_without  bittorrent      # BitTorrent protocol support
5 %bcond_without  fsp             # FSP support
6 %bcond_without  idn             # Internation Domain Names support
7 %bcond_without  ipv6            # IPv6 support
8 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
9 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
10 %bcond_without  openssl         # OpenSSL-based SSL support
11 # - content
12 %bcond_without  cgi             # Local CGI support
13 %bcond_without  brotli          # Brotli compression support
14 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using quickjs)
15 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
16 %bcond_without  zstd    # zstd compression support
17 # - scripting
18 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
19 %bcond_without  lua             # Lua scripting
20 %bcond_with     perl            # Perl scripting
21 %bcond_with     python          # Python scripting support
22 %bcond_with     ruby            # (experimental) Ruby scripting support
23 # - display and UI
24 %bcond_without  256             # 256 colors support
25 %bcond_without  led             # LEDs
26 %bcond_without  truecolor       # true color
27 %bcond_with     x               # Use the X Window System
28 # - misc
29 %bcond_without  verbose         # verbose build (V=1)
30
31 %if %{with gnutls}
32 %undefine       with_openssl
33 %endif
34
35 Summary:        Experimantal Links (text WWW browser)
36 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
37 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
38 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
39 Name:           elinks
40 Version:        0.15.0
41 Release:        1
42 Epoch:          1
43 License:        GPL v2
44 Group:          Applications/Networking
45 Source0:        https://github.com/rkd77/elinks/releases/download/v%{version}/%{name}-%{version}.tar.xz
46 # Source0-md5:  8fe2e81d2cea75f57cd3cf9bdda6821b
47 Source1:        %{name}.desktop
48 Source2:        links.png
49 URL:            http://www.elinks.cz/
50 BuildRequires:  autoconf >= 2.61
51 BuildRequires:  automake
52 BuildRequires:  bzip2-devel
53 BuildRequires:  expat-devel
54 %{?with_fsp:BuildRequires:      fsplib-devel}
55 BuildRequires:  gettext-tools
56 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
57 BuildRequires:  gpm-devel
58 %{?with_guile:BuildRequires: guile-devel}
59 %{?with_js:BuildRequires:       libxml++5-devel >= 5.0.1-2}
60 %{?with_js:BuildRequires:       quickjs-devel >= 20210327-4}
61 %{?with_js:BuildRequires:       sqlite3-devel}
62 %{?with_brotli:BuildRequires:   libbrotli-devel}
63 %{?with_idn:BuildRequires:      libidn-devel}
64 %{?with_smb:BuildRequires:      libsmbclient-devel}
65 %{?with_lua:BuildRequires:      lua53-devel}
66 %{?with_lzma:BuildRequires:     lzma-devel}
67 BuildRequires:  meson
68 BuildRequires:  ncurses-devel >= 5.1
69 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
70 %{?with_perl:BuildRequires:     perl-devel}
71 BuildRequires:  pkgconfig
72 %{?with_python:BuildRequires:   python3-devel}
73 %{?with_ruby:BuildRequires:     ruby-devel}
74 BuildRequires:  sed
75 BuildRequires:  tre-devel
76 BuildRequires:  which
77 BuildRequires:  zlib-devel
78 %{?with_zstd:BuildRequires:     zstd-devel}
79 Suggests:       mailcap
80 Provides:       webclient
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _sysconfdir     /etc/elinks
84 %define         specflags_ia32  -fomit-frame-pointer
85
86 %description
87 This is the elinks tree - intended to provide feature-rich version of
88 links, however not rock-stable and dedicated mainly for testing. Its
89 purpose is to make alternative to links, until Mikulas will have some
90 time to maintain it, and to test and tune various patches for Mikulas
91 to be able to include them in the official links releases.
92
93 %description -l es.UTF-8
94 Links es un browser WWW modo texto, similar al Lynx. El links muestra
95 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
96 keepalive.
97
98 %description -l pl.UTF-8
99 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
100 elinks jednak jest dedykowana głównie do testowania.
101
102 %description -l pt_BR.UTF-8
103 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
104 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
105 keepalive.
106
107 %prep
108 %setup -q
109
110 %build
111 %meson build \
112         %{?with_bittorrent:-Dbittorrent=true} \
113         %{?with_cgi:-Dcgi=true} \
114         -D88-colors=true \
115         %{?with_256:-D256-colors=true} \
116         %{?with_truecolor:-Dtrue-color=true} \
117         -Dexmode=true \
118         %{?debug:-Ddebug=true} \
119         %{!?debug:-Dfastmem=true} \
120         -Dfinger=true \
121         %{?with_fsp:-Dfsp=true} \
122         -Dgemini=true \
123         -Dgettext=true \
124         -Dgopher=true \
125         -Dhtml-highlight=true \
126         %{!?with_ipv6:-Dipv6=false} \
127         %{?with_leds:-Dleds=true} \
128         -Dmarks=true \
129         -Dnntp=true \
130         -Dno-root=false \
131         %{?with_smb:-Dsmb=true} \
132         %{?with_brotli:-Dbrotli=true} \
133         %{?with_zstd:-Dzstd=true} \
134         %{?with_gnutls:-Dgnutls=true} \
135         %{?with_guile:-Dguile=true} \
136         %{!?with_idn:-Didn=false} \
137         %{?with_lua:-Dluapkg=lua5.3} \
138         %{?with_lzma:-Dlzma=true} \
139         %{?with_openssl:-Dopenssl=true} \
140         %{?with_perl:-Dperl=true} \
141         %{?with_python:-Dpython=true} \
142         %{?with_ruby:-Druby=true} \
143         %{?with_js:-Dquickjs=true} \
144         %{?with_x:-Dx=true}
145
146 %ninja_build -C build
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 %ninja_install -C build
151
152 install -d $RPM_BUILD_ROOT%{_desktopdir} \
153         $RPM_BUILD_ROOT%{_datadir}/%{name} \
154         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
155
156 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
157 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
158
159 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
160 sed -i -e 's|bin/lua|bin/lua5.3|g' $RPM_BUILD_ROOT%{_sysconfdir}/*lua
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files -f %{name}.lang
168 %defattr(644,root,root,755)
169 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
170 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh}
171 %attr(755,root,root) %{_bindir}/elinks
172 %{_mandir}/man1/elinks.1*
173 %{_mandir}/man5/elinks.conf.5*
174 %{_mandir}/man5/elinkskeys.5*
175 %{_desktopdir}/elinks.desktop
176 %{_pixmapsdir}/elinks.png
177 %if %{with lua}
178 %dir %{_sysconfdir}
179 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
180 %endif
This page took 0.043945 seconds and 3 git commands to generate.