]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- added the chunked.patch
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2 #
3 # Conditional build:
4 %bcond_with     x               # Use the X Windows System
5 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
6 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
7 %bcond_without  256             # Disable 256 colors support
8 %bcond_without  bittorrent      # Disable BitTorrent support
9 %bcond_without  cgi             # Disable Local CGI support
10 %bcond_without  fsp             # Disable FSP support
11 %bcond_without  guile           # Disable Guile scripting
12 %bcond_without  idn             # Disable Internation Domain Names support
13 %bcond_without  ipv6            # Disable IPv6 support
14 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15 %bcond_without  led             # Disable LEDs
16 %bcond_without  lua             # Disable Lua scripting
17 %bcond_without  openssl         # Disable OpenSSL support
18 %bcond_without  perl            # Disable Perl scripting
19
20 %if %{with gnutls}
21 %undefine       with_openssl
22 %endif
23 #
24 Summary:        Experimantal Links (text WWW browser)
25 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
26 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
27 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
28 Name:           elinks
29 Version:        0.11.3
30 Release:        7
31 Epoch:          1
32 License:        GPL
33 Group:          Applications/Networking
34 Source0:        http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
35 # Source0-md5:  a0eb50e18a2ac8e77d6b0df8f94bb5a6
36 Source1:        %{name}.desktop
37 Source2:        links.png
38 Patch0:         %{name}-home_etc.patch
39 Patch1:         %{name}-lua40.patch
40 Patch2:         %{name}-bug517.patch
41 Patch3:         %{name}-cgi.patch
42 Patch4:         %{name}-date-format.patch
43 Patch5:         %{name}-pl.po.patch
44 Patch6:         %{name}-chunked.patch
45 URL:            http://www.elinks.cz/
46 BuildRequires:  autoconf
47 BuildRequires:  automake
48 BuildRequires:  bzip2-devel
49 BuildRequires:  expat-devel
50 %{?with_fsp:BuildRequires:      fsplib-devel}
51 BuildRequires:  gettext-devel
52 BuildRequires:  gpm-devel
53 %{?with_guile:BuildRequires: guile-devel}
54 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
55 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
56 %{?with_idn:BuildRequires:      libidn-devel}
57 %{?with_lua:BuildRequires:      lua50-devel}
58 BuildRequires:  ncurses-devel >= 5.1
59 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
60 %{?with_perl:BuildRequires:     perl-devel}
61 %{?with_ruby:BuildRequires:     ruby-devel}
62 BuildRequires:  zlib-devel
63 Provides:       webclient
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     /etc/elinks
67 %define         specflags_ia32  -fomit-frame-pointer 
68
69 %description
70 This is the elinks tree - intended to provide feature-rich version of
71 links, however not rock-stable and dedicated mainly for testing. Its
72 purpose is to make alternative to links, until Mikulas will have some
73 time to maintain it, and to test and tune various patches for Mikulas
74 to be able to include them in the official links releases.
75
76 %description -l es.UTF-8
77 Links es un browser WWW modo texto, similar al Lynx. El links muestra
78 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
79 keepalive.
80
81 %description -l pl.UTF-8
82 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
83 elinks jednak jest dedykowana głównie do testowania.
84
85 %description -l pt_BR.UTF-8
86 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
87 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
88 keepalive.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96 %patch4 -p1
97 %patch5 -p1
98 %patch6 -p1
99
100 %build
101 %{__aclocal}
102 %{__autoconf}
103 %{__autoheader}
104 %configure \
105         HAVE_SMBCLIENT=yes \
106         --disable-no-root \
107         %{!?debug:--enable-fastmem} \
108         %{?debug:--enable-debug} \
109         %{!?with_ipv6:--disable-ipv6} \
110         %{?with_bittorrent:--enable-bittorrent} \
111         %{?with_cgi:--enable-cgi} \
112         --enable-finger \
113         --enable-gopher \
114         --enable-nntp \
115         %{?with_256:--enable-256-colors} \
116         --enable-exmode \
117         %{?with_fsp:--enable-fsp} \
118         %{?with_leds:--enable-leds} \
119         --enable-marks \
120         --enable-html-highlight \
121         %{!?with_idn:--without-idn} \
122         %{?with_guile:--with-guile} \
123         %{?with_perl:--with-perl} \
124         %{!?with_lua:--without-lua} \
125         %{?with_ruby:--with-ruby} \
126         %{!?with_js:--without-spidermonkey} \
127         %{?with_gnutls:--with-gnutls} \
128         %{!?with_openssl:--without-openssl} \
129         --with%{!?with_x:out}-x
130 # xterm -e is default, one might want to change it to
131 # something else
132 #       --with-xterm="xterm -e"
133
134 %{__make} V=1
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT%{_desktopdir} \
139         $RPM_BUILD_ROOT%{_datadir}/%{name} \
140         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
141
142 %{__make} install V=1 \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
146 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
147
148 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
149
150 %find_lang %{name}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
158 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
159 %doc contrib/conv/{*awk,*.pl,*.sh}
160 %doc doc/html/*.html
161 %attr(755,root,root) %{_bindir}/*
162 %{_mandir}/man*/*
163 %{_desktopdir}/*.desktop
164 %{_pixmapsdir}/*
165 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.085531 seconds and 3 git commands to generate.