]> git.pld-linux.org Git - packages/elinks.git/blame - elinks.spec
- release 2
[packages/elinks.git] / elinks.spec
CommitLineData
2e552f3e 1# TODO: consider lua51
fb650491 2
21bf3c6a 3# Conditional build:
b67326b7 4%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
505355c8 5%bcond_with lzma # Enable lzma support
507bef3e 6%bcond_with python # Enable Python scripting support
b67326b7 7%bcond_with ruby # Enable (experimental) Ruby scripting support
247545b3 8%bcond_with verbose # verbose build (V=1)
9cd7feaf 9%bcond_with x # Use the X Windows System
b67326b7
JB
10%bcond_without 256 # Disable 256 colors support
11%bcond_without bittorrent # Disable BitTorrent support
12%bcond_without cgi # Disable Local CGI support
b631af97 13%bcond_without fsp # Disable FSP support
b67326b7
JB
14%bcond_without guile # Disable Guile scripting
15%bcond_without idn # Disable Internation Domain Names support
16%bcond_without ipv6 # Disable IPv6 support
17%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
18%bcond_without led # Disable LEDs
19%bcond_without lua # Disable Lua scripting
20%bcond_without openssl # Disable OpenSSL support
21%bcond_without perl # Disable Perl scripting
505355c8 22%bcond_without smb # Disable smb protocol support (smb requires libsmbclient)
3d4d38d9
AG
23#
24%if %{with gnutls}
25%undefine with_openssl
26%endif
21bf3c6a 27#
25e4024f 28%define pre pre2
17631700 29Summary: Experimantal Links (text WWW browser)
f85cbf5d
ER
30Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
31Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
32Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
17631700 33Name: elinks
80cd88a3 34Version: 0.12
878e3ac9 35Release: 0.%{pre}.2
e2affc83 36Epoch: 1
17631700
AM
37License: GPL
38Group: Applications/Networking
80cd88a3 39Source0: http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
25e4024f 40# Source0-md5: bfc2a531f633c9e25e108e5ce2d864ea
17631700 41Source1: %{name}.desktop
5a8f1bd1 42Source2: links.png
ef0f233a
AG
43Patch0: %{name}-home_etc.patch
44Patch1: %{name}-lua40.patch
505355c8 45Patch2: %{name}-date-format.patch
9cd7feaf 46Patch3: %{name}-old_incremental.patch
8ca357a6 47URL: http://www.elinks.cz/
17631700
AM
48BuildRequires: autoconf
49BuildRequires: automake
5a8f1bd1 50BuildRequires: bzip2-devel
fcffdc5b 51BuildRequires: expat-devel
b631af97 52%{?with_fsp:BuildRequires: fsplib-devel}
ab99996e 53BuildRequires: gettext-devel
17631700 54BuildRequires: gpm-devel
3d4d38d9 55%{?with_guile:BuildRequires: guile-devel}
69d969c4 56%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
3d4d38d9
AG
57%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
58%{?with_idn:BuildRequires: libidn-devel}
505355c8 59%{?with_smb:BuildRequires: libsmbclient-devel}
8eb57a4f 60%{?with_lua:BuildRequires: lua50-devel}
505355c8 61%{?with_lzma:BuildRequires: lzma-devel}
1c33e430 62BuildRequires: ncurses-devel >= 5.1
3d4d38d9
AG
63%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
64%{?with_perl:BuildRequires: perl-devel}
9659fcbf 65%{?with_python:BuildRequires: python-devel}
8ca357a6 66%{?with_ruby:BuildRequires: ruby-devel}
5a8f1bd1 67BuildRequires: zlib-devel
e1bc1545 68Suggests: mailcap
17631700
AM
69Provides: webclient
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
c4be24e9 72%define _sysconfdir /etc/elinks
ef0f233a 73%define specflags_ia32 -fomit-frame-pointer
4fc089e9 74
17631700 75%description
cd6ad879
JB
76This is the elinks tree - intended to provide feature-rich version of
77links, however not rock-stable and dedicated mainly for testing. Its
78purpose is to make alternative to links, until Mikulas will have some
79time to maintain it, and to test and tune various patches for Mikulas
80to be able to include them in the official links releases.
17631700 81
3328f371 82%description -l es.UTF-8
c15f1e53 83Links es un browser WWW modo texto, similar al Lynx. El links muestra
84tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
85keepalive.
86
3328f371
JR
87%description -l pl.UTF-8
88Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
89elinks jednak jest dedykowana głównie do testowania.
17631700 90
3328f371
JR
91%description -l pt_BR.UTF-8
92Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
93tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
c15f1e53 94keepalive.
95
17631700 96%prep
80cd88a3 97%setup -q -n %{name}-%{version}%{pre}
fb650491 98%patch0 -p1
1fa8ef0a 99%patch1 -p1
fb650491 100%patch2 -p1
9cd7feaf
TP
101# restores old behaviour of type-ahead search
102#%patch3 -p1
0b57a582 103
17631700 104%build
663b78ce 105%{__aclocal}
285e9f62 106%{__autoconf}
115d3038 107%{__autoheader}
ad628403 108%configure \
505355c8 109 %{?with_smb:--enable-smb} \
2e552f3e 110 --disable-no-root \
3d4d38d9
AG
111 %{!?debug:--enable-fastmem} \
112 %{?debug:--enable-debug} \
cc7f804f 113 %{!?with_ipv6:--disable-ipv6} \
8ca357a6 114 %{?with_bittorrent:--enable-bittorrent} \
3d4d38d9
AG
115 %{?with_cgi:--enable-cgi} \
116 --enable-finger \
117 --enable-gopher \
118 --enable-nntp \
119 %{?with_256:--enable-256-colors} \
120 --enable-exmode \
b631af97 121 %{?with_fsp:--enable-fsp} \
3d4d38d9 122 %{?with_leds:--enable-leds} \
8ca357a6 123 --enable-marks \
3d4d38d9 124 --enable-html-highlight \
3d4d38d9
AG
125 %{!?with_idn:--without-idn} \
126 %{?with_guile:--with-guile} \
127 %{?with_perl:--with-perl} \
62c5be6a 128 %{!?with_lua:--without-lua} \
507bef3e 129 %{?with_python:--with-python} \
8ca357a6 130 %{?with_ruby:--with-ruby} \
3d4d38d9
AG
131 %{!?with_js:--without-spidermonkey} \
132 %{?with_gnutls:--with-gnutls} \
133 %{!?with_openssl:--without-openssl} \
505355c8 134 --with%{!?with_x:out}-x \
135 %{!?with_lzma:--without-lzma}
82dd9b93
AG
136# xterm -e is default, one might want to change it to
137# something else
138# --with-xterm="xterm -e"
3d4d38d9 139
247545b3 140%{__make} %{?with_verbose:V=1}
17631700
AM
141
142%install
143rm -rf $RPM_BUILD_ROOT
1568d5eb 144install -d $RPM_BUILD_ROOT%{_desktopdir} \
ad628403 145 $RPM_BUILD_ROOT%{_datadir}/%{name} \
c4be24e9 146 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
17631700 147
247545b3 148%{__make} install %{?with_verbose:V=1} \
834d1634 149 DESTDIR=$RPM_BUILD_ROOT
17631700 150
1568d5eb 151install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
5a8f1bd1 152install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
153
ef0f233a 154%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
347f019c 155
269a2ef7 156%find_lang %{name}
157
17631700
AM
158%clean
159rm -rf $RPM_BUILD_ROOT
160
269a2ef7 161%files -f %{name}.lang
17631700 162%defattr(644,root,root,755)
bf7521cb 163%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
ab99996e 164%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
5a8f1bd1 165%doc contrib/conv/{*awk,*.pl,*.sh}
cf865ed3 166%doc doc/html/*.html
17631700 167%attr(755,root,root) %{_bindir}/*
17631700 168%{_mandir}/man*/*
1faa0547 169%{_desktopdir}/*.desktop
06096625 170%{_pixmapsdir}/*
a153230d 171%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.085056 seconds and 4 git commands to generate.