]> git.pld-linux.org Git - packages/elinks.git/blame - elinks.spec
- rel .3
[packages/elinks.git] / elinks.spec
CommitLineData
2e552f3e 1# TODO: consider lua51
fb650491 2
21bf3c6a 3# Conditional build:
b67326b7
JB
4%bcond_with x # Use the X Windows System
5%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
505355c8 6%bcond_with lzma # Enable lzma support
507bef3e 7%bcond_with python # Enable Python scripting support
b67326b7 8%bcond_with ruby # Enable (experimental) Ruby scripting support
247545b3 9%bcond_with verbose # verbose build (V=1)
b67326b7
JB
10%bcond_without 256 # Disable 256 colors support
11%bcond_without bittorrent # Disable BitTorrent support
12%bcond_without cgi # Disable Local CGI support
b631af97 13%bcond_without fsp # Disable FSP support
b67326b7
JB
14%bcond_without guile # Disable Guile scripting
15%bcond_without idn # Disable Internation Domain Names support
16%bcond_without ipv6 # Disable IPv6 support
17%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
18%bcond_without led # Disable LEDs
19%bcond_without lua # Disable Lua scripting
20%bcond_without openssl # Disable OpenSSL support
21%bcond_without perl # Disable Perl scripting
505355c8 22%bcond_without smb # Disable smb protocol support (smb requires libsmbclient)
3d4d38d9
AG
23#
24%if %{with gnutls}
25%undefine with_openssl
26%endif
21bf3c6a 27#
505355c8 28%define pre pre1
17631700 29Summary: Experimantal Links (text WWW browser)
f85cbf5d
ER
30Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
31Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
32Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
17631700 33Name: elinks
80cd88a3 34Version: 0.12
2882c202 35Release: 0.%{pre}.3
e2affc83 36Epoch: 1
17631700
AM
37License: GPL
38Group: Applications/Networking
80cd88a3 39Source0: http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
505355c8 40# Source0-md5: 23f745c33ea91f91ef5b2db385efdfff
17631700 41Source1: %{name}.desktop
5a8f1bd1 42Source2: links.png
ef0f233a
AG
43Patch0: %{name}-home_etc.patch
44Patch1: %{name}-lua40.patch
505355c8 45Patch2: %{name}-date-format.patch
8ca357a6 46URL: http://www.elinks.cz/
17631700
AM
47BuildRequires: autoconf
48BuildRequires: automake
5a8f1bd1 49BuildRequires: bzip2-devel
fcffdc5b 50BuildRequires: expat-devel
b631af97 51%{?with_fsp:BuildRequires: fsplib-devel}
ab99996e 52BuildRequires: gettext-devel
17631700 53BuildRequires: gpm-devel
3d4d38d9 54%{?with_guile:BuildRequires: guile-devel}
69d969c4 55%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
3d4d38d9
AG
56%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
57%{?with_idn:BuildRequires: libidn-devel}
505355c8 58%{?with_smb:BuildRequires: libsmbclient-devel}
8eb57a4f 59%{?with_lua:BuildRequires: lua50-devel}
505355c8 60%{?with_lzma:BuildRequires: lzma-devel}
1c33e430 61BuildRequires: ncurses-devel >= 5.1
3d4d38d9
AG
62%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
63%{?with_perl:BuildRequires: perl-devel}
9659fcbf 64%{?with_python:BuildRequires: python-devel}
8ca357a6 65%{?with_ruby:BuildRequires: ruby-devel}
5a8f1bd1 66BuildRequires: zlib-devel
e1bc1545 67Suggests: mailcap
17631700
AM
68Provides: webclient
69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
c4be24e9 71%define _sysconfdir /etc/elinks
ef0f233a 72%define specflags_ia32 -fomit-frame-pointer
4fc089e9 73
17631700 74%description
cd6ad879
JB
75This is the elinks tree - intended to provide feature-rich version of
76links, however not rock-stable and dedicated mainly for testing. Its
77purpose is to make alternative to links, until Mikulas will have some
78time to maintain it, and to test and tune various patches for Mikulas
79to be able to include them in the official links releases.
17631700 80
3328f371 81%description -l es.UTF-8
c15f1e53 82Links es un browser WWW modo texto, similar al Lynx. El links muestra
83tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
84keepalive.
85
3328f371
JR
86%description -l pl.UTF-8
87Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
88elinks jednak jest dedykowana głównie do testowania.
17631700 89
3328f371
JR
90%description -l pt_BR.UTF-8
91Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
92tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
c15f1e53 93keepalive.
94
17631700 95%prep
80cd88a3 96%setup -q -n %{name}-%{version}%{pre}
fb650491 97%patch0 -p1
1fa8ef0a 98%patch1 -p1
fb650491 99%patch2 -p1
0b57a582 100
17631700 101%build
663b78ce 102%{__aclocal}
285e9f62 103%{__autoconf}
115d3038 104%{__autoheader}
ad628403 105%configure \
505355c8 106 %{?with_smb:--enable-smb} \
2e552f3e 107 --disable-no-root \
3d4d38d9
AG
108 %{!?debug:--enable-fastmem} \
109 %{?debug:--enable-debug} \
cc7f804f 110 %{!?with_ipv6:--disable-ipv6} \
8ca357a6 111 %{?with_bittorrent:--enable-bittorrent} \
3d4d38d9
AG
112 %{?with_cgi:--enable-cgi} \
113 --enable-finger \
114 --enable-gopher \
115 --enable-nntp \
116 %{?with_256:--enable-256-colors} \
117 --enable-exmode \
b631af97 118 %{?with_fsp:--enable-fsp} \
3d4d38d9 119 %{?with_leds:--enable-leds} \
8ca357a6 120 --enable-marks \
3d4d38d9 121 --enable-html-highlight \
3d4d38d9
AG
122 %{!?with_idn:--without-idn} \
123 %{?with_guile:--with-guile} \
124 %{?with_perl:--with-perl} \
62c5be6a 125 %{!?with_lua:--without-lua} \
507bef3e 126 %{?with_python:--with-python} \
8ca357a6 127 %{?with_ruby:--with-ruby} \
3d4d38d9
AG
128 %{!?with_js:--without-spidermonkey} \
129 %{?with_gnutls:--with-gnutls} \
130 %{!?with_openssl:--without-openssl} \
505355c8 131 --with%{!?with_x:out}-x \
132 %{!?with_lzma:--without-lzma}
82dd9b93
AG
133# xterm -e is default, one might want to change it to
134# something else
135# --with-xterm="xterm -e"
3d4d38d9 136
247545b3 137%{__make} %{?with_verbose:V=1}
17631700
AM
138
139%install
140rm -rf $RPM_BUILD_ROOT
1568d5eb 141install -d $RPM_BUILD_ROOT%{_desktopdir} \
ad628403 142 $RPM_BUILD_ROOT%{_datadir}/%{name} \
c4be24e9 143 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
17631700 144
247545b3 145%{__make} install %{?with_verbose:V=1} \
834d1634 146 DESTDIR=$RPM_BUILD_ROOT
17631700 147
1568d5eb 148install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
5a8f1bd1 149install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
150
ef0f233a 151%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
347f019c 152
269a2ef7 153%find_lang %{name}
154
17631700
AM
155%clean
156rm -rf $RPM_BUILD_ROOT
157
269a2ef7 158%files -f %{name}.lang
17631700 159%defattr(644,root,root,755)
bf7521cb 160%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
ab99996e 161%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
5a8f1bd1 162%doc contrib/conv/{*awk,*.pl,*.sh}
cf865ed3 163%doc doc/html/*.html
17631700 164%attr(755,root,root) %{_bindir}/*
17631700 165%{_mandir}/man*/*
1faa0547 166%{_desktopdir}/*.desktop
06096625 167%{_pixmapsdir}/*
a153230d 168%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.051358 seconds and 4 git commands to generate.