]> git.pld-linux.org Git - packages/elfutils.git/commitdiff
- added maps patch (fixes backtrace selftest reading /proc/PID/maps:
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Oct 2015 16:39:38 +0000 (18:39 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Oct 2015 16:39:38 +0000 (18:39 +0200)
  inode field is decimal and may have more fields than hex format allows)
- cleaned up obsolete x32 patch

elfutils-maps.patch [new file with mode: 0644]
elfutils.spec
x32.patch [deleted file]

diff --git a/elfutils-maps.patch b/elfutils-maps.patch
new file mode 100644 (file)
index 0000000..67052a0
--- /dev/null
@@ -0,0 +1,11 @@
+--- elfutils-0.164/tests/backtrace-data.c.orig 2015-10-24 16:54:40.223734605 +0200
++++ elfutils-0.164/tests/backtrace-data.c      2015-10-24 16:54:43.840589170 +0200
+@@ -101,7 +101,7 @@
+     {
+       // 37e3c22000-37e3c23000 rw-p 00022000 00:11 49532 /lib64/ld-2.14.90.so */
+       unsigned long start, end, offset;
+-      i = fscanf (f, "%lx-%lx %*s %lx %*x:%*x %*x", &start, &end, &offset);
++      i = fscanf (f, "%lx-%lx %*s %lx %*x:%*x %*u", &start, &end, &offset);
+       assert (errno == 0);
+       assert (i == 3);
+       char *filename = strdup ("");
index 92a940f5b3ae9520dd32ed570edaa5d620d8e83c..b731be39361689c847c1bc439440e2e79bac9ada 100644 (file)
@@ -18,7 +18,7 @@ Patch3:               %{name}-align.patch
 Patch4:                %{name}-paxflags.patch
 Patch5:                %{name}-sparc.patch
 Patch6:                %{name}-inline.patch
 Patch4:                %{name}-paxflags.patch
 Patch5:                %{name}-sparc.patch
 Patch6:                %{name}-inline.patch
-Patch9:                x32.patch
+Patch7:                %{name}-maps.patch
 URL:           https://fedorahosted.org/elfutils/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.8
 URL:           https://fedorahosted.org/elfutils/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.8
@@ -140,9 +140,7 @@ programowalny interfejs asemblera.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-#%ifarch x32
-#%patch9 -p1
-#%endif
+%patch7 -p1
 
 %{__rm} po/stamp-po
 
 
 %{__rm} po/stamp-po
 
diff --git a/x32.patch b/x32.patch
deleted file mode 100644 (file)
index 01eaaf0..0000000
--- a/x32.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- elfutils-0.159/tests/Makefile.am~  2015-01-04 14:41:29.000000000 +0000
-+++ elfutils-0.159/tests/Makefile.am   2015-01-04 16:08:31.699271017 +0000
-@@ -102,8 +102,8 @@
-       run-readelf-mixed-corenote.sh run-dwfllines.sh \
-       run-dwfl-report-elf-align.sh run-addr2line-test.sh \
-       run-addr2line-i-test.sh run-varlocs.sh run-funcretval.sh \
--      run-backtrace-native.sh run-backtrace-data.sh run-backtrace-dwarf.sh \
--      run-backtrace-native-biarch.sh run-backtrace-native-core.sh \
-+      run-backtrace-dwarf.sh \
-+      run-backtrace-native-core.sh \
-       run-backtrace-native-core-biarch.sh run-backtrace-core-x86_64.sh \
-       run-backtrace-core-i386.sh run-backtrace-core-ppc.sh \
-       run-backtrace-core-s390x.sh run-backtrace-core-s390.sh \
This page took 0.0918020000000001 seconds and 4 git commands to generate.