]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- allocated pointers need 8-byte alignment on sparc (to use ldd/std opcodes to access...
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.108
9 Release:        2
10 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/SRPMS/
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  fd318a634c8f67c7ac8a975f16965cc3
15 Patch0:         %{name}-pl.po.patch
16 Patch1:         %{name}-debian-manpages.patch
17 Patch2:         %{name}-portability.patch
18 Patch3:         %{name}-bswap.patch
19 Patch4:         %{name}-robustify.patch
20 #URL:           file://home/devel/drepper
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  gcc >= 3.2
24 BuildRequires:  gettext-devel
25 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
26 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
27 # also needed for nanosecond timestamps on alpha
28 BuildRequires:  glibc-devel >= 6:2.3.4
29 %endif
30 BuildRequires:  libltdl-devel
31 BuildRequires:  perl-tools-pod
32 BuildRequires:  rpmbuild(macros) >= 1.213
33 BuildRequires:  sharutils
34 Requires:       %{name}-libelf = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _programprefix  eu-
38
39 %description
40 Elfutils is a collection of utilities, including ld (a linker), nm
41 (for listing symbols from object files), size (for listing the section
42 sizes of an object or archive file), strip (for discarding symbols),
43 readline (the see the raw ELF file structures), and elflint (to check
44 for well-formed ELF files). Also included are numerous helper
45 libraries which implement DWARF, ELF, and machine-specific ELF
46 handling.
47
48 %description -l pl
49 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
50 listowania symboli z plików obiektów), size (do listowania rozmiarów
51 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
52 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
53 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
54 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
55 specyficznych dla architektury.
56
57 %package devel
58 Summary:        Development part of libraries to handle compiled objects
59 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Obsoletes:      libelf-devel
63
64 %description devel
65 The elfutils-devel package contains the development part of libraries
66 to create applications for handling compiled objects. libelf allows
67 you to access the internals of the ELF object file format, so you can
68 see the different sections of an ELF file. libebl provides some
69 higher-level ELF access functionality. libdwarf provides access to the
70 DWARF debugging information. libasm provides a programmable assembler
71 interface.
72
73 %description devel -l pl
74 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
75 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
76 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
77 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
78 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
79 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
80 udostêpnia programowalny interfejs asemblera.
81
82 %package libelf
83 Summary:        Library to read and write ELF files
84 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
85 Group:          Libraries
86 #Obsoletes:     libelf
87
88 %description libelf
89 The elfutils-libelf package provides a DSO which allows reading and
90 writing ELF files on a high level. Third party programs depend on this
91 package to read internals of ELF files. The programs of the elfutils
92 package use it also to generate new ELF files.
93
94 %description libelf -l pl
95 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
96 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
97 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
98 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
99
100 %package static
101 Summary:        Static libraries to handle compiled objects
102 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105 Obsoletes:      libelf-static
106
107 %description static
108 The elfutils-static package contains the static libraries to create
109 applications for handling compiled objects. libelf allows you to
110 access the internals of the ELF object file format, so you can see the
111 different sections of an ELF file. libebl provides some higher-level
112 ELF access functionality. libdwarf provides access to the DWARF
113 debugging information. libasm provides a programmable assembler
114 interface.
115
116 %description static -l pl
117 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
118 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
119 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
120 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
121 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
122 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
123 programowalny interfejs asemblera.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129 %patch2 -p1
130 %patch3 -p1
131 %patch4 -p1
132
133 %build
134 #%%{__gettextize}
135 %{__aclocal}
136 %{__autoheader}
137 %{__automake}
138 %{__autoconf}
139
140 # Turn off optimization on sparc to avoid Bus error with some tests
141 %ifarch sparc
142 CFLAGS="%{rpmcflags} -O0" ; export CFLAGS
143 %endif
144 %configure \
145         --program-prefix=%{_programprefix} \
146         --enable-shared
147
148 # make check depends on test-nlist not stripped
149 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
150
151 %{__make}
152 %{__make} -C debian/man
153 %if %{with tests}
154 # $ORIGIN used in RPATH needs /proc to work - workaround it using LD_LIBRARY_PATH;
155 # ../libelf is needed also to use proper libelf by ../src/elflint during tests
156 LD_LIBRARY_PATH=../libasm:../libdw:../libebl:../libelf \
157 %{__make} -C tests check
158 %endif
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
163
164 # *OBJEXT must be passed to workaround problem with messed gettext,
165 # which doesn't like *-po dir names
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT \
168         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
169         CATOBJEXT=.gmo \
170         INSTOBJEXT=.mo
171
172 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
173
174 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}/
175 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
176         $RPM_BUILD_ROOT%{_libdir}/libelf.so
177
178 %find_lang libelf
179 %find_lang %{name}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %post   libelf -p /sbin/ldconfig
188 %postun libelf -p /sbin/ldconfig
189
190 %files -f %{name}.lang
191 %defattr(644,root,root,755)
192 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
193 %attr(755,root,root) %{_bindir}/*
194 %attr(755,root,root) %{_libdir}/libasm-*.so
195 %attr(755,root,root) %{_libdir}/libdw-*.so
196 %dir %{_libdir}/elfutils
197 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
198 %{_mandir}/man1/*.1*
199
200 %files devel
201 %defattr(644,root,root,755)
202 #%doc doc/elfutils.sgml
203 %attr(755,root,root) %{_libdir}/libasm.so
204 %attr(755,root,root) %{_libdir}/libdw.so
205 %attr(755,root,root) %{_libdir}/libelf.so
206 %{_libdir}/libebl.a
207 %{_includedir}/*
208
209 %files libelf -f libelf.lang
210 %defattr(644,root,root,755)
211 %attr(755,root,root) /%{_lib}/libelf-*.so
212
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libasm.a
216 %{_libdir}/libdw.a
217 %{_libdir}/libelf.a
This page took 0.065223 seconds and 3 git commands to generate.