]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
7ef8f2e0cb0715d843b702d32823848a9bea2c38
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.124
9 Release:        2
10 License:        GPL v2 with OSL linking exception
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
13 # abuse systemtap to get .tar.gz directly
14 Source0:        ftp://sources.redhat.com/pub/systemtap/elfutils/%{name}-%{version}.tar.gz
15 # Source0-md5:  f77efb19fd90821ab103533a99de0d4a
16 Patch0:         %{name}-pl.po.patch
17 Patch1:         %{name}-debian-manpages.patch
18 Patch2:         %{name}-portability.patch
19 Patch3:         %{name}-robustify.patch
20 Patch4:         %{name}-align.patch
21 Patch5:         %{name}-paxflags.patch
22 Patch6:         %{name}-alpha.patch
23 Patch7:         %{name}-sparc.patch
24 Patch8:         %{name}-strip-copy-symtab.patch
25 Patch9:         %{name}-gcc4.patch
26 #URL:           file://home/devel/drepper
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.7
29 BuildRequires:  gcc >= 3.2
30 BuildRequires:  gettext-devel
31 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
32 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
33 # also needed for nanosecond timestamps on alpha
34 BuildRequires:  glibc-devel >= 6:2.3.4
35 %endif
36 BuildRequires:  libltdl-devel
37 BuildRequires:  perl-tools-pod
38 BuildRequires:  rpmbuild(macros) >= 1.315
39 BuildRequires:  sharutils
40 %if %{with tests} && %(test -d /proc/self ; echo $?)
41 # native test needs proc (for libdwfl -p PID to work)
42 BuildRequires:  MOUNTED_PROC
43 %endif
44 Requires:       %{name}-libelf = %{version}-%{release}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # fails to build with -Wl,-s
48 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
49
50 %define         _programprefix  eu-
51
52 %description
53 Elfutils is a collection of utilities, including ld (a linker), nm
54 (for listing symbols from object files), size (for listing the section
55 sizes of an object or archive file), strip (for discarding symbols),
56 readline (the see the raw ELF file structures), and elflint (to check
57 for well-formed ELF files). Also included are numerous helper
58 libraries which implement DWARF, ELF, and machine-specific ELF
59 handling.
60
61 %description -l pl
62 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
63 listowania symboli z plików obiektów), size (do listowania rozmiarów
64 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
65 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
66 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
67 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
68 specyficznych dla architektury.
69
70 %package devel
71 Summary:        Development part of libraries to handle compiled objects
72 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Obsoletes:      libelf-devel
76
77 %description devel
78 The elfutils-devel package contains the development part of libraries
79 to create applications for handling compiled objects. libelf allows
80 you to access the internals of the ELF object file format, so you can
81 see the different sections of an ELF file. libebl provides some
82 higher-level ELF access functionality. libdwarf provides access to the
83 DWARF debugging information. libasm provides a programmable assembler
84 interface.
85
86 %description devel -l pl
87 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
88 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
89 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
90 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
91 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
92 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
93 udostêpnia programowalny interfejs asemblera.
94
95 %package libelf
96 Summary:        Library to read and write ELF files
97 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
98 Group:          Libraries
99 #Obsoletes:     libelf
100
101 %description libelf
102 The elfutils-libelf package provides a DSO which allows reading and
103 writing ELF files on a high level. Third party programs depend on this
104 package to read internals of ELF files. The programs of the elfutils
105 package use it also to generate new ELF files.
106
107 %description libelf -l pl
108 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
109 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
110 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
111 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
112
113 %package static
114 Summary:        Static libraries to handle compiled objects
115 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118 Obsoletes:      libelf-static
119
120 %description static
121 The elfutils-static package contains the static libraries to create
122 applications for handling compiled objects. libelf allows you to
123 access the internals of the ELF object file format, so you can see the
124 different sections of an ELF file. libebl provides some higher-level
125 ELF access functionality. libdwarf provides access to the DWARF
126 debugging information. libasm provides a programmable assembler
127 interface.
128
129 %description static -l pl
130 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
131 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
132 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
133 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
134 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
135 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
136 programowalny interfejs asemblera.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141 %patch1 -p1
142 %patch2 -p1
143 %patch3 -p1
144 %patch4 -p1
145 %patch5 -p1
146 %patch6 -p1
147 %patch7 -p1
148 %patch8 -p1
149 %patch9 -p1
150
151 # strip-test5 needs adjusting for strip-copy-symtab patch (already in FC, but not worth bothering)
152 # elflint-self fails with recent binutils (generates some 0-sized symbols addressed outside eh_frame section)
153 sed -i -e 's/ run-strip-test5\.sh / /;s/ run-elflint-self\.sh / /' tests/Makefile.am
154
155 %build
156 #%%{__gettextize}
157 %{__aclocal}
158 %{__autoheader}
159 %{__automake}
160 %{__autoconf}
161
162 %configure \
163         --program-prefix=%{_programprefix} \
164         --enable-shared
165
166 # make check depends on test-nlist not stripped
167 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
168
169 %{__make}
170 %{__make} -C debian/man
171 %if %{with tests}
172 # some tests rely on English messages
173 LC_ALL=C \
174 %{__make} -C tests check
175 %endif
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
180
181 # *OBJEXT must be passed to workaround problem with messed gettext,
182 # which doesn't like *-po dir names
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT \
185         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
186         CATOBJEXT=.gmo \
187         INSTOBJEXT=.mo
188
189 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
190
191 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
192 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
193         $RPM_BUILD_ROOT%{_libdir}/libelf.so
194
195 %find_lang libelf
196 %find_lang %{name}
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post   -p /sbin/ldconfig
202 %postun -p /sbin/ldconfig
203
204 %post   libelf -p /sbin/ldconfig
205 %postun libelf -p /sbin/ldconfig
206
207 %files -f %{name}.lang
208 %defattr(644,root,root,755)
209 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
210 %attr(755,root,root) %{_bindir}/*
211 %attr(755,root,root) %{_libdir}/libasm-*.so
212 %attr(755,root,root) %{_libdir}/libdw-*.so
213 %dir %{_libdir}/elfutils
214 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
215 %{_mandir}/man1/*.1*
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libasm.so
220 %attr(755,root,root) %{_libdir}/libdw.so
221 %attr(755,root,root) %{_libdir}/libelf.so
222 %{_libdir}/libebl.a
223 %{_includedir}/*
224
225 %files libelf -f libelf.lang
226 %defattr(644,root,root,755)
227 %attr(755,root,root) /%{_lib}/libelf-*.so
228
229 %files static
230 %defattr(644,root,root,755)
231 %{_libdir}/libasm.a
232 %{_libdir}/libdw.a
233 %{_libdir}/libelf.a
This page took 0.098948 seconds and 2 git commands to generate.