]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- updated to 0.129
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl.UTF-8):      Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.129
9 Release:        1
10 License:        GPL v2 with OSL linking exception
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/source/SRPMS/
13 # or abuse systemtap to get .tar.gz directly
14 Source0:        ftp://sources.redhat.com/pub/systemtap/elfutils/%{name}-%{version}.tar.gz
15 # Source0-md5:  0cbce01d2fbbac19da70b17bdbf18bf8
16 Patch0:         %{name}-pl.po.patch
17 Patch1:         %{name}-debian-manpages.patch
18 Patch2:         %{name}-portability.patch
19 Patch3:         %{name}-robustify.patch
20 Patch4:         %{name}-align.patch
21 Patch5:         %{name}-paxflags.patch
22 Patch6:         %{name}-sparc.patch
23 Patch7:         %{name}-strip-copy-symtab.patch
24 Patch8:         %{name}-gcc4.patch
25 Patch9:         %{name}-inline.patch
26 Patch10:        %{name}-Werror.patch
27 Patch11:        %{name}-elflint-ppc-got.patch
28 #URL:           file://home/devel/drepper
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake >= 1:1.7
31 BuildRequires:  gcc >= 3.2
32 BuildRequires:  gettext-devel
33 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
34 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
35 # also needed for nanosecond timestamps on alpha
36 BuildRequires:  glibc-devel >= 6:2.3.4
37 %endif
38 BuildRequires:  libltdl-devel
39 BuildRequires:  perl-tools-pod
40 BuildRequires:  rpmbuild(macros) >= 1.315
41 BuildRequires:  sharutils
42 %if %{with tests} && %(test -d /proc/self ; echo $?)
43 # native test needs proc (for libdwfl -p PID to work)
44 BuildRequires:  MOUNTED_PROC
45 %endif
46 Requires:       %{name}-libelf = %{version}-%{release}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 # fails to build with -Wl,-s
50 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
51
52 %define         _programprefix  eu-
53
54 %description
55 Elfutils is a collection of utilities, including ld (a linker), nm
56 (for listing symbols from object files), size (for listing the section
57 sizes of an object or archive file), strip (for discarding symbols),
58 readline (the see the raw ELF file structures), and elflint (to check
59 for well-formed ELF files). Also included are numerous helper
60 libraries which implement DWARF, ELF, and machine-specific ELF
61 handling.
62
63 %description -l pl.UTF-8
64 Elfutils to zestaw narzędzi, składający się z ld (linkera), nm (do
65 listowania symboli z plików obiektów), size (do listowania rozmiarów
66 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
67 readline (do oglądania surowych struktur plików ELF) oraz elflint (do
68 sprawdzania poprawności plików ELF). Dołączone są także liczne
69 biblioteki pomocnicze z zaimplementowaną obsługą DWARF, ELF i ELF
70 specyficznych dla architektury.
71
72 %package devel
73 Summary:        Development part of libraries to handle compiled objects
74 Summary(pl.UTF-8):      Część programistyczna bibliotek do obsługi skompilowanych obiektów
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Obsoletes:      libelf-devel
78
79 %description devel
80 The elfutils-devel package contains the development part of libraries
81 to create applications for handling compiled objects. libelf allows
82 you to access the internals of the ELF object file format, so you can
83 see the different sections of an ELF file. libebl provides some
84 higher-level ELF access functionality. libdwarf provides access to the
85 DWARF debugging information. libasm provides a programmable assembler
86 interface.
87
88 %description devel -l pl.UTF-8
89 Pakiet elfutils-devel zawiera część programistyczną bibliotek do
90 tworzenia aplikacji obsługujących skompilowane obiekty. libelf pozwala
91 na dostęp do wnętrzności formatu pliku obiektowego ELF, co pozwala na
92 oglądanie różnych sekcji pliku ELF. libebl udostępnia funkcjonalność
93 dostępu do plików ELF trochę wyższego poziomu. libdwarf pozwala na
94 dostęp do informacji DWARF służących do odpluskwiania. libasm
95 udostępnia programowalny interfejs asemblera.
96
97 %package libelf
98 Summary:        Library to read and write ELF files
99 Summary(pl.UTF-8):      Biblioteki do odczytu i zapisu plików ELF
100 Group:          Libraries
101 #Obsoletes:     libelf
102
103 %description libelf
104 The elfutils-libelf package provides a DSO which allows reading and
105 writing ELF files on a high level. Third party programs depend on this
106 package to read internals of ELF files. The programs of the elfutils
107 package use it also to generate new ELF files.
108
109 %description libelf -l pl.UTF-8
110 Pakiet elfutils-libelf udostępnia bibliotekę dzieloną, która pozwala
111 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
112 wymagają tego pakietu, aby odczytywać zawartość plików ELF. Programy z
113 pakietu elfutils używają jej także do generowania nowych plików ELF.
114
115 %package static
116 Summary:        Static libraries to handle compiled objects
117 Summary(pl.UTF-8):      Statyczne biblioteki do obsługi skompilowanych obiektów
118 Group:          Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120 Obsoletes:      libelf-static
121
122 %description static
123 The elfutils-static package contains the static libraries to create
124 applications for handling compiled objects. libelf allows you to
125 access the internals of the ELF object file format, so you can see the
126 different sections of an ELF file. libebl provides some higher-level
127 ELF access functionality. libdwarf provides access to the DWARF
128 debugging information. libasm provides a programmable assembler
129 interface.
130
131 %description static -l pl.UTF-8
132 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
133 aplikacji obsługujących skompilowane obiekty. libelf pozwala na dostęp
134 do wnętrzności formatu pliku obiektowego ELF, co pozwala na oglądanie
135 różnych sekcji pliku ELF. libebl udostępnia funkcjonalność dostępu do
136 plików ELF trochę wyższego poziomu. libdwarf pozwala na dostęp do
137 informacji DWARF służących do odpluskwiania. libasm udostępnia
138 programowalny interfejs asemblera.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146 %patch4 -p1
147 %patch5 -p1
148 %patch6 -p1
149 %patch7 -p1
150 %patch8 -p1
151 %patch9 -p1
152 %patch10 -p1
153 %patch11 -p0
154
155 rm -f po/stamp-po
156
157 # strip-test5 needs adjusting for strip-copy-symtab patch (already in FC, but not worth bothering)
158 # missing source for dwfl-bug-report
159 # missing run-strip-test7.sh script
160 sed -i -e 's/ run-strip-test[57]\.sh / /;s/ dwfl-bug-report//' tests/Makefile.am
161
162 %build
163 #%%{__gettextize}
164 %{__aclocal}
165 %{__autoheader}
166 %{__autoconf}
167 %{__automake}
168 %configure \
169         --program-prefix=%{_programprefix} \
170         --enable-shared
171
172 # make check depends on test-nlist not stripped
173 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
174
175 # disable test failing on specific archs
176 %ifarch sparc sparc64 alpha
177 %{__perl} -pi -e 's/run-elflint-self.sh//' tests/Makefile
178 %endif
179
180 %{__make}
181 %{__make} -C debian/man
182
183 %if %{with tests}
184 # some tests rely on English messages
185 LC_ALL=C \
186 %{__make} -C tests check
187 %endif
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
192
193 # *OBJEXT must be passed to workaround problem with messed gettext,
194 # which doesn't like *-po dir names
195 %{__make} install \
196         DESTDIR=$RPM_BUILD_ROOT \
197         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
198         CATOBJEXT=.gmo \
199         INSTOBJEXT=.mo
200
201 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
202
203 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
204 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
205         $RPM_BUILD_ROOT%{_libdir}/libelf.so
206
207 /sbin/ldconfig -n -N $RPM_BUILD_ROOT%{_libdir}
208 /sbin/ldconfig -n -N $RPM_BUILD_ROOT/%{_lib}
209
210 %find_lang %{name}
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %post   -p /sbin/ldconfig
216 %postun -p /sbin/ldconfig
217
218 %post   libelf -p /sbin/ldconfig
219 %postun libelf -p /sbin/ldconfig
220
221 %files
222 %defattr(644,root,root,755)
223 %doc AUTHORS EXCEPTION NEWS NOTES README THANKS TODO
224 %attr(755,root,root) %{_bindir}/*
225 %attr(755,root,root) %{_libdir}/libasm-*.so
226 %ghost %attr(755,root,root) %{_libdir}/libasm.so.*
227 %attr(755,root,root) %{_libdir}/libdw-*.so
228 %ghost %attr(755,root,root) %{_libdir}/libdw.so.*
229 %dir %{_libdir}/elfutils
230 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
231 %{_mandir}/man1/*.1*
232
233 %files devel
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libasm.so
236 %attr(755,root,root) %{_libdir}/libdw.so
237 %attr(755,root,root) %{_libdir}/libelf.so
238 %{_libdir}/libebl.a
239 %{_includedir}/*
240
241 %files libelf -f %{name}.lang
242 %defattr(644,root,root,755)
243 %attr(755,root,root) /%{_lib}/libelf-*.so
244 %ghost %attr(755,root,root) /%{_lib}/libelf.so.*
245
246 %files static
247 %defattr(644,root,root,755)
248 %{_libdir}/libasm.a
249 %{_libdir}/libdw.a
250 %{_libdir}/libelf.a
This page took 0.098224 seconds and 3 git commands to generate.