]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- updated for 0.121 (from FC)
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.120
9 Release:        1
10 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
13 # abuse systemtap to get .tar.gz directly
14 Source0:        ftp://sources.redhat.com/pub/systemtap/elfutils/%{name}-%{version}.tar.gz
15 # Source0-md5:  3f757d85af891904892b4a6dc3f9e14c
16 Patch0:         %{name}-pl.po.patch
17 Patch1:         %{name}-debian-manpages.patch
18 Patch2:         %{name}-portability.patch
19 Patch3:         %{name}-robustify.patch
20 Patch4:         %{name}-align.patch
21 Patch5:         %{name}-paxflags.patch
22 Patch6:         %{name}-alpha.patch
23 Patch7:         %{name}-gcc4.patch
24 #URL:           file://home/devel/drepper
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake >= 1:1.7
27 BuildRequires:  gcc >= 3.2
28 BuildRequires:  gettext-devel
29 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
30 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
31 # also needed for nanosecond timestamps on alpha
32 BuildRequires:  glibc-devel >= 6:2.3.4
33 %endif
34 BuildRequires:  libltdl-devel
35 BuildRequires:  perl-tools-pod
36 BuildRequires:  rpmbuild(macros) >= 1.213
37 BuildRequires:  sharutils
38 Requires:       %{name}-libelf = %{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _programprefix  eu-
42
43 %description
44 Elfutils is a collection of utilities, including ld (a linker), nm
45 (for listing symbols from object files), size (for listing the section
46 sizes of an object or archive file), strip (for discarding symbols),
47 readline (the see the raw ELF file structures), and elflint (to check
48 for well-formed ELF files). Also included are numerous helper
49 libraries which implement DWARF, ELF, and machine-specific ELF
50 handling.
51
52 %description -l pl
53 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
54 listowania symboli z plików obiektów), size (do listowania rozmiarów
55 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
56 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
57 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
58 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
59 specyficznych dla architektury.
60
61 %package devel
62 Summary:        Development part of libraries to handle compiled objects
63 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Obsoletes:      libelf-devel
67
68 %description devel
69 The elfutils-devel package contains the development part of libraries
70 to create applications for handling compiled objects. libelf allows
71 you to access the internals of the ELF object file format, so you can
72 see the different sections of an ELF file. libebl provides some
73 higher-level ELF access functionality. libdwarf provides access to the
74 DWARF debugging information. libasm provides a programmable assembler
75 interface.
76
77 %description devel -l pl
78 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
79 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
80 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
81 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
82 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
83 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
84 udostêpnia programowalny interfejs asemblera.
85
86 %package libelf
87 Summary:        Library to read and write ELF files
88 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
89 Group:          Libraries
90 #Obsoletes:     libelf
91
92 %description libelf
93 The elfutils-libelf package provides a DSO which allows reading and
94 writing ELF files on a high level. Third party programs depend on this
95 package to read internals of ELF files. The programs of the elfutils
96 package use it also to generate new ELF files.
97
98 %description libelf -l pl
99 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
100 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
101 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
102 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
103
104 %package static
105 Summary:        Static libraries to handle compiled objects
106 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109 Obsoletes:      libelf-static
110
111 %description static
112 The elfutils-static package contains the static libraries to create
113 applications for handling compiled objects. libelf allows you to
114 access the internals of the ELF object file format, so you can see the
115 different sections of an ELF file. libebl provides some higher-level
116 ELF access functionality. libdwarf provides access to the DWARF
117 debugging information. libasm provides a programmable assembler
118 interface.
119
120 %description static -l pl
121 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
122 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
123 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
124 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
125 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
126 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
127 programowalny interfejs asemblera.
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134 %patch3 -p1
135 %patch4 -p1
136 %patch5 -p1
137 %patch6 -p1
138 %patch7 -p1
139
140 %build
141 #%%{__gettextize}
142 %{__aclocal}
143 %{__autoheader}
144 %{__automake}
145 %{__autoconf}
146
147 %configure \
148         --program-prefix=%{_programprefix} \
149         --enable-shared
150
151 # make check depends on test-nlist not stripped
152 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
153
154 %{__make}
155 %{__make} -C debian/man
156 %if %{with tests}
157 # $ORIGIN used in RPATH needs /proc to work - workaround it using LD_LIBRARY_PATH;
158 # ../libelf is needed also to use proper libelf by ../src/elflint during tests
159 LD_LIBRARY_PATH=../libasm:../libdw:../libebl:../libelf \
160 %{__make} -C tests check
161 %endif
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
166
167 # *OBJEXT must be passed to workaround problem with messed gettext,
168 # which doesn't like *-po dir names
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT \
171         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
172         CATOBJEXT=.gmo \
173         INSTOBJEXT=.mo
174
175 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
176
177 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
178 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
179         $RPM_BUILD_ROOT%{_libdir}/libelf.so
180
181 %find_lang libelf
182 %find_lang %{name}
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post   -p /sbin/ldconfig
188 %postun -p /sbin/ldconfig
189
190 %post   libelf -p /sbin/ldconfig
191 %postun libelf -p /sbin/ldconfig
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
196 %attr(755,root,root) %{_bindir}/*
197 %attr(755,root,root) %{_libdir}/libasm-*.so
198 %attr(755,root,root) %{_libdir}/libdw-*.so
199 %dir %{_libdir}/elfutils
200 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
201 %{_mandir}/man1/*.1*
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libasm.so
206 %attr(755,root,root) %{_libdir}/libdw.so
207 %attr(755,root,root) %{_libdir}/libelf.so
208 %{_libdir}/libebl.a
209 %{_includedir}/*
210
211 %files libelf -f libelf.lang
212 %defattr(644,root,root,755)
213 %attr(755,root,root) /%{_lib}/libelf-*.so
214
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libasm.a
218 %{_libdir}/libdw.a
219 %{_libdir}/libelf.a
This page took 0.041104 seconds and 3 git commands to generate.