]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
284dc84b3b20bf997d0da57a973a2ba84874267e
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without tests    # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.94
9 Release:        1
10 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/SRPMS/elfutils-0.94-2.1.src.rpm
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  de39e0af6b82b30d48e5d69b75aa2e0b
15 Patch0:         %{name}-pl.po.patch
16 Patch1:         %{name}-debian-manpages.patch
17 Patch2:         %{name}-alpha-stat.patch
18 Patch3:         %{name}-gcc34.patch
19 #URL:           file://home/devel/drepper
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1.7
22 BuildRequires:  gcc >= 3.2
23 BuildRequires:  gettext-devel
24 BuildRequires:  libltdl-devel
25 BuildRequires:  perl-tools-pod
26 BuildRequires:  sharutils
27 Requires:       %{name}-libelf = %{version}-%{release}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _programprefix  eu-
31
32 %description
33 Elfutils is a collection of utilities, including ld (a linker), nm
34 (for listing symbols from object files), size (for listing the section
35 sizes of an object or archive file), strip (for discarding symbols),
36 readline (the see the raw ELF file structures), and elflint (to check
37 for well-formed ELF files). Also included are numerous helper
38 libraries which implement DWARF, ELF, and machine-specific ELF
39 handling.
40
41 %description -l pl
42 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
43 listowania symboli z plików obiektów), size (do listowania rozmiarów
44 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
45 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
46 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
47 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
48 specyficznych dla architektury.
49
50 %package devel
51 Summary:        Development part of libraries to handle compiled objects
52 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Obsoletes:      libelf-devel
56
57 %description devel
58 The elfutils-devel package contains the development part of libraries
59 to create applications for handling compiled objects. libelf allows
60 you to access the internals of the ELF object file format, so you can
61 see the different sections of an ELF file. libebl provides some
62 higher-level ELF access functionality. libdwarf provides access to the
63 DWARF debugging information. libasm provides a programmable assembler
64 interface.
65
66 %description devel -l pl
67 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
68 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
69 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
70 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
71 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
72 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
73 udostêpnia programowalny interfejs asemblera.
74
75 %package libelf
76 Summary:        Library to read and write ELF files
77 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
78 Group:          Libraries
79 #Obsoletes:     libelf
80
81 %description libelf
82 The elfutils-libelf package provides a DSO which allows reading and
83 writing ELF files on a high level. Third party programs depend on this
84 package to read internals of ELF files. The programs of the elfutils
85 package use it also to generate new ELF files.
86
87 %description libelf -l pl
88 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
89 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
90 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
91 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
92
93 %package static
94 Summary:        Static libraries to handle compiled objects
95 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Obsoletes:      libelf-static
99
100 %description static
101 The elfutils-static package contains the static libraries to create
102 applications for handling compiled objects. libelf allows you to
103 access the internals of the ELF object file format, so you can see the
104 different sections of an ELF file. libebl provides some higher-level
105 ELF access functionality. libdwarf provides access to the DWARF
106 debugging information. libasm provides a programmable assembler
107 interface.
108
109 %description static -l pl
110 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
111 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
112 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
113 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
114 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
115 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
116 programowalny interfejs asemblera.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122 # to be removed || updated after switching to glibc 2.3.4
123 # (alpha stat64() with nsec fields was added in linux-2.6.4/glibc-2.3.4,
124 #  I don't know if elfutils knows how to use it)
125 %patch2 -p1
126 %patch3 -p1
127
128 %build
129 %{__gettextize}
130 %{__aclocal}
131 %{__autoheader}
132 %{__automake}
133 %{__autoconf}
134 %configure \
135         --program-prefix=%{_programprefix} \
136         --enable-shared
137
138 # make check depends on test-nlist not stripped
139 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
140
141 %{__make}
142 %{__make} -C debian/man
143 %{?with_tests:%{__make} -C tests check}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT%{_mandir}/man1
148
149 # *OBJEXT must be passed to workaround problem with messed gettext,
150 # which doesn't like *-po dir names
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT \
153         CATOBJEXT=.gmo \
154         INSTOBJEXT=.mo
155
156 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
157
158 %find_lang libelf
159 %find_lang libasm
160 %find_lang libdw
161 # currently there is no localizable messages in libebl
162 #%find_lang libebl
163 :>libebl.lang
164 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/pl/LC_MESSAGES/libebl.mo
165 %find_lang %{name}
166 cat libasm.lang libdw.lang libebl.lang >> %{name}.lang
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %post   libelf -p /sbin/ldconfig
175 %postun libelf -p /sbin/ldconfig
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
180 %attr(755,root,root) %{_bindir}/*
181 %attr(755,root,root) %{_libdir}/libasm-*.so
182 %attr(755,root,root) %{_libdir}/libdw-*.so
183 %dir %{_libdir}/elfutils
184 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
185 %{_mandir}/man1/*.1*
186
187 %files devel
188 %defattr(644,root,root,755)
189 %doc doc/elfutils.sgml
190 %attr(755,root,root) %{_libdir}/libasm.so
191 %attr(755,root,root) %{_libdir}/libdw.so
192 %attr(755,root,root) %{_libdir}/libelf.so
193 %{_libdir}/libebl.a
194 %{_includedir}/*
195
196 %files libelf -f libelf.lang
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libelf-*.so
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/libasm.a
203 %{_libdir}/libdw.a
204 %{_libdir}/libelf.a
This page took 0.083429 seconds and 2 git commands to generate.