]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
12bea10e384f5a94419b38986ad7d11fb039642b
[packages/elfutils.git] / elfutils.spec
1 # TODO:
2 # - package debuginfod.service
3 #
4 # Conditional build:
5 %bcond_without  debuginfod      # debuginfod server and client
6 %bcond_without  tests   # do not perform tests
7 #
8 Summary:        A collection of utilities and DSOs to handle compiled objects
9 Summary(pl.UTF-8):      Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
10 Name:           elfutils
11 Version:        0.188
12 Release:        1
13 License:        GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
14 Group:          Development/Tools
15 Source0:        https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
16 # Source0-md5:  efb25a91873b2eec4df9f31e6a4f4e5c
17 Patch0:         %{name}-pl.po.patch
18 Patch1:         %{name}-debian-manpages.patch
19 Patch2:         %{name}-awk.patch
20 Patch3:         %{name}-align.patch
21 Patch4:         %{name}-paxflags.patch
22 Patch5:         %{name}-sparc.patch
23 Patch6:         disable-tests.patch
24 URL:            https://sourceware.org/elfutils/
25 BuildRequires:  autoconf >= 2.63
26 BuildRequires:  automake >= 1:1.11
27 %{?with_tests:BuildRequires:    bsdtar}
28 BuildRequires:  bzip2-devel
29 BuildRequires:  gawk
30 BuildRequires:  gcc >= 6:4.3
31 BuildRequires:  gettext-tools >= 0.19.6
32 BuildRequires:  glibc-devel >= 6:2.7
33 BuildRequires:  libstdc++-devel >= 6:4.7
34 BuildRequires:  perl-tools-pod
35 BuildRequires:  rpmbuild(macros) >= 1.527
36 BuildRequires:  sharutils
37 BuildRequires:  xz-devel
38 BuildRequires:  zlib-devel
39 BuildRequires:  zstd-devel
40 %if %{with tests} && %(test -d /proc/self ; echo $?)
41 # native test needs proc (for libdwfl -p PID to work)
42 BuildRequires:  MOUNTED_PROC
43 %endif
44 %if %{with debuginfod}
45 BuildRequires:  curl-devel >= 7.29.0
46 BuildRequires:  libarchive-devel >= 3.1.2
47 BuildRequires:  libmicrohttpd-devel >= 0.9.33
48 BuildRequires:  sqlite3-devel >= 3.7.17
49 %endif
50 Requires:       %{name}-libelf = %{version}-%{release}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 # fails to build with -Wl,-s
54 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
55 %if %{with tests} && 0%(echo %{rpmcflags} | grep -q '\<-g' ; echo $?)
56 # tests require debug symbols
57 %define         specflags       -g
58 %endif
59
60 %define         programprefix   eu-
61
62 %description
63 Elfutils is a collection of utilities, including ld (a linker), nm
64 (for listing symbols from object files), size (for listing the section
65 sizes of an object or archive file), strip (for discarding symbols),
66 readline (the see the raw ELF file structures), and elflint (to check
67 for well-formed ELF files). Also included are numerous helper
68 libraries which implement DWARF, ELF, and machine-specific ELF
69 handling.
70
71 %description -l pl.UTF-8
72 Elfutils to zestaw narzędzi, składający się z ld (linkera), nm (do
73 listowania symboli z plików obiektów), size (do listowania rozmiarów
74 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
75 readline (do oglądania surowych struktur plików ELF) oraz elflint (do
76 sprawdzania poprawności plików ELF). Dołączone są także liczne
77 biblioteki pomocnicze z zaimplementowaną obsługą DWARF, ELF i ELF
78 specyficznych dla architektury.
79
80 %package devel
81 Summary:        Development part of libraries to handle compiled objects
82 Summary(pl.UTF-8):      Część programistyczna bibliotek do obsługi skompilowanych obiektów
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       bzip2-devel
86 Requires:       xz-devel
87 Requires:       zlib-devel
88 Obsoletes:      libelf-devel < 0.8.14
89 Obsoletes:      libelf0-devel < 0.8.14
90
91 %description devel
92 The elfutils-devel package contains the development part of libraries
93 to create applications for handling compiled objects. libelf allows
94 you to access the internals of the ELF object file format, so you can
95 see the different sections of an ELF file. libdw provides access to
96 the DWARF debugging information. libasm provides a programmable
97 assembler interface.
98
99 %description devel -l pl.UTF-8
100 Pakiet elfutils-devel zawiera część programistyczną bibliotek do
101 tworzenia aplikacji obsługujących skompilowane obiekty. libelf pozwala
102 na dostęp do wnętrzności formatu pliku obiektowego ELF, co pozwala na
103 oglądanie różnych sekcji pliku ELF. libdw pozwala na dostęp do
104 informacji DWARF służących do odpluskwiania. libasm udostępnia
105 programowalny interfejs asemblera.
106
107 %package libelf
108 Summary:        Library to read and write ELF files
109 Summary(pl.UTF-8):      Biblioteki do odczytu i zapisu plików ELF
110 Group:          Libraries
111 #Obsoletes:     libelf
112
113 %description libelf
114 The elfutils-libelf package provides a DSO which allows reading and
115 writing ELF files on a high level. Third party programs depend on this
116 package to read internals of ELF files. The programs of the elfutils
117 package use it also to generate new ELF files.
118
119 %description libelf -l pl.UTF-8
120 Pakiet elfutils-libelf udostępnia bibliotekę dzieloną, która pozwala
121 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
122 wymagają tego pakietu, aby odczytywać zawartość plików ELF. Programy z
123 pakietu elfutils używają jej także do generowania nowych plików ELF.
124
125 %package static
126 Summary:        Static libraries to handle compiled objects
127 Summary(pl.UTF-8):      Statyczne biblioteki do obsługi skompilowanych obiektów
128 Group:          Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130 Obsoletes:      libelf-static < 0.8.14
131
132 %description static
133 The elfutils-static package contains the static libraries to create
134 applications for handling compiled objects. libelf allows you to
135 access the internals of the ELF object file format, so you can see the
136 different sections of an ELF file. libdw provides access to the DWARF
137 debugging information. libasm provides a programmable assembler
138 interface.
139
140 %description static -l pl.UTF-8
141 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
142 aplikacji obsługujących skompilowane obiekty. libelf pozwala na dostęp
143 do wnętrzności formatu pliku obiektowego ELF, co pozwala na oglądanie
144 różnych sekcji pliku ELF. libdw pozwala na dostęp do informacji DWARF
145 służących do odpluskwiania. libasm udostępnia programowalny interfejs
146 asemblera.
147
148 %package debuginfod
149 Summary:        debuginfod server and client
150 Summary(pl.UTF-8):      Serwer i klient debuginfod
151 Group:          Libraries
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       %{name}-debuginfod-libs = %{version}-%{release}
154 Requires:       libarchive >= 3.1.2
155 Requires:       libmicrohttpd >= 0.9.33
156 Requires:       sqlite3 >= 3.7.17
157
158 %description debuginfod
159 debuginfod server and client.
160
161 %description debuginfod -l pl.UTF-8
162 Serwer i klient debuginfod.
163
164 %package debuginfod-libs
165 Summary:        debuginfod library
166 Summary(pl.UTF-8):      Biblioteka debuginfod
167 Group:          Libraries
168 Requires:       curl-libs >= 7.29.0
169 Conflicts:      elfutils-debuginfod < 0.187-3
170
171 %description debuginfod-libs
172 debuginfod library.
173
174 %description debuginfod-libs -l pl.UTF-8
175 Biblioteka debuginfod.
176
177 %package debuginfod-devel
178 Summary:        Header file for debuginfod library
179 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki debuginfod
180 Group:          Development/Libraries
181 Requires:       %{name}-debuginfod-libs = %{version}-%{release}
182 Requires:       %{name}-devel = %{version}-%{release}
183
184 %description debuginfod-devel
185 Header file for debuginfod library.
186
187 %description debuginfod-devel -l pl.UTF-8
188 Plik nagłówkowy biblioteki debuginfod.
189
190 %prep
191 %setup -q
192 %patch0 -p1
193 %patch1 -p1
194 %patch2 -p1
195 %patch3 -p1
196 %patch4 -p1
197 %patch5 -p1
198 %patch6 -p1
199
200 %{__rm} po/stamp-po
201
202 # temporarily disable failing tests (depending on arch)
203 %ifarch x32
204 %{__sed} -i -e 's/run-backtrace-native-biarch.sh//' tests/Makefile.am
205 %endif
206
207 # make sure this is not even tried on arch it has no chance to run
208 %ifarch %{ix86}
209 %{__sed} -i -e 's/run-disasm-x86-64.sh//' tests/Makefile.am
210 %endif
211
212 %build
213 #%%{__gettextize}
214 %{__aclocal} -I m4
215 %{__autoconf}
216 %{__autoheader}
217 %{__automake}
218 %configure \
219         --disable-silent-rules \
220         %{__enable_disable debuginfod} \
221         --program-prefix=%{programprefix}
222
223 # make check depends on test-nlist not stripped
224 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
225
226 %{__make}
227 %{__make} -C debian/man
228
229 %if %{with tests}
230 # some tests rely on English messages
231 LC_ALL=C \
232 %{__make} -C tests check
233 %endif
234
235 %install
236 rm -rf $RPM_BUILD_ROOT
237 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
238
239 %{__make} install \
240         DESTDIR=$RPM_BUILD_ROOT
241
242 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
243
244 %{__mv} $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
245 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelf-*.so) \
246         $RPM_BUILD_ROOT%{_libdir}/libelf.so
247
248 %find_lang %{name}
249
250 %clean
251 rm -rf $RPM_BUILD_ROOT
252
253 %post   -p /sbin/ldconfig
254 %postun -p /sbin/ldconfig
255
256 %post   libelf -p /sbin/ldconfig
257 %postun libelf -p /sbin/ldconfig
258
259 %post   debuginfod-libs -p /sbin/ldconfig
260 %postun debuginfod-libs -p /sbin/ldconfig
261
262 %files
263 %defattr(644,root,root,755)
264 %doc AUTHORS CONTRIBUTING ChangeLog NEWS NOTES README THANKS TODO
265 %attr(755,root,root) %{_bindir}/eu-*
266 %attr(755,root,root) %{_libdir}/libasm-*.so
267 %attr(755,root,root) %ghost %{_libdir}/libasm.so.1
268 %attr(755,root,root) %{_libdir}/libdw-*.so
269 %attr(755,root,root) %ghost %{_libdir}/libdw.so.1
270 %{_mandir}/man1/eu-*.1*
271
272 %files devel
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_libdir}/libasm.so
275 %attr(755,root,root) %{_libdir}/libdw.so
276 %attr(755,root,root) %{_libdir}/libelf.so
277 %{_includedir}/dwarf.h
278 %{_includedir}/gelf.h
279 %{_includedir}/libelf.h
280 %{_includedir}/nlist.h
281 %dir %{_includedir}/elfutils
282 %{_includedir}/elfutils/elf-knowledge.h
283 %{_includedir}/elfutils/known-dwarf.h
284 %{_includedir}/elfutils/libasm.h
285 %{_includedir}/elfutils/libdw.h
286 %{_includedir}/elfutils/libdwelf.h
287 %{_includedir}/elfutils/libdwfl.h
288 %{_includedir}/elfutils/version.h
289 %{_pkgconfigdir}/libdw.pc
290 %{_pkgconfigdir}/libelf.pc
291 %{_mandir}/man3/elf_begin.3*
292 %{_mandir}/man3/elf_clone.3*
293 %{_mandir}/man3/elf_getdata.3*
294 %{_mandir}/man3/elf_update.3*
295
296 %files libelf -f %{name}.lang
297 %defattr(644,root,root,755)
298 %attr(755,root,root) /%{_lib}/libelf-*.so
299 %attr(755,root,root) %ghost /%{_lib}/libelf.so.1
300
301 %files static
302 %defattr(644,root,root,755)
303 %{_libdir}/libasm.a
304 %{_libdir}/libdw.a
305 %{_libdir}/libelf.a
306
307 %if %{with debuginfod}
308 %files debuginfod
309 %defattr(644,root,root,755)
310 %attr(755,root,root) %{_bindir}/debuginfod
311 %attr(755,root,root) %{_bindir}/debuginfod-find
312 %{_mandir}/man1/debuginfod-find.1*
313 %{_mandir}/man7/debuginfod-client-config.7*
314 %{_mandir}/man8/debuginfod.8*
315 %attr(755,root,root) /etc/profile.d/debuginfod.sh
316 %attr(755,root,root) /etc/profile.d/debuginfod.csh
317
318 %files debuginfod-libs
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_libdir}/libdebuginfod-*.so
321 %attr(755,root,root) %ghost %{_libdir}/libdebuginfod.so.1
322
323 %files debuginfod-devel
324 %defattr(644,root,root,755)
325 %attr(755,root,root) %{_libdir}/libdebuginfod.so
326 %{_includedir}/elfutils/debuginfod.h
327 %{_pkgconfigdir}/libdebuginfod.pc
328 %{_mandir}/man3/debuginfod_*.3*
329 %endif
This page took 0.09883 seconds and 2 git commands to generate.