]> git.pld-linux.org Git - packages/elfutils.git/blame - elfutils.spec
- raw version from Rawhide
[packages/elfutils.git] / elfutils.spec
CommitLineData
ecbc8f89
AF
1Summary: A collection of utilities and DSOs to handle compiled objects.
2Name: elfutils
3Version: 0.76
4Release: 3
5Copyright: GPL
6Group: Development/Tools
7#URL: file://home/devel/drepper
8Source: elfutils-%{version}.tar.gz
9Obsoletes: libelf libelf-devel
10Requires: elfutils-libelf = %{version}-%{release}
11
12# ExcludeArch: xxx
13
14BuildRoot: %{_tmppath}/%{name}-root
15BuildRequires: gcc >= 3.2
16BuildRequires: sharutils
17
18%define _gnu %{nil}
19%define _programprefix eu-
20
21%description
22Elfutils is a collection of utilities, including ld (a linker),
23nm (for listing symbols from object files), size (for listing the
24section sizes of an object or archive file), strip (for discarding
25symbols), readline (the see the raw ELF file structures), and elflint
26(to check for well-formed ELF files). Also included are numerous
27helper libraries which implement DWARF, ELF, and machine-specific ELF
28handling.
29
30%package devel
31Summary: Development libraries to handle compiled objects.
32Group: Development/Tools
33Requires: elfutils = %{version}-%{release}
34
35%description devel
36The elfutils-devel package contains the libraries to create
37applications for handling compiled objects. libelf allows you to
38access the internals of the ELF object file format, so you can see the
39different sections of an ELF file. libebl provides some higher-level
40ELF access functionality. libdwarf provides access to the DWARF
41debugging information. libasm provides a programmable assembler
42interface.
43
44%package libelf
45Summary: Library to read and write ELF files.
46Group: Development/Tools
47
48%description libelf
49The elfutils-libelf package provides a DSO which allows reading and
50writing ELF files on a high level. Third party programs depend on
51this package to read internals of ELF files. The programs of the
52elfutils package use it also to generate new ELF files.
53
54%prep
55%setup -q
56
57%build
58mkdir build-%{_target_platform}
59cd build-%{_target_platform}
60../configure \
61 --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} \
62 --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
63 --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} \
64 --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} \
65 --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} \
66 --infodir=%{_infodir} --program-prefix=%{_programprefix} --enable-shared
67cd ..
68
69%install
70rm -rf ${RPM_BUILD_ROOT}
71mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
72
73cd build-%{_target_platform}
74#make check
75%makeinstall
76
77chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
78chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
79
80cd ..
81
82# XXX Nuke unpackaged files
83{ cd ${RPM_BUILD_ROOT}
84 rm -f .%{_bindir}/eu-ld
85 rm -f .%{_includedir}/elfutils/libasm.h
86 rm -f .%{_includedir}/elfutils/libdw.h
87 rm -f .%{_includedir}/elfutils/libdwarf.h
88 rm -f .%{_libdir}/libasm-%{version}.so
89 rm -f .%{_libdir}/libasm.a
90 rm -f .%{_libdir}/libdw-%{version}.so
91 rm -f .%{_libdir}/libdw.a
92 rm -f .%{_libdir}/libdwarf.a
93}
94
95%check
96cd build-%{_target_platform}
97make check
98
99%clean
100rm -rf ${RPM_BUILD_ROOT}
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%post libelf -p /sbin/ldconfig
107
108%postun libelf -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root)
112%doc README TODO libdwarf/AVAILABLE
113%{_bindir}/eu-elflint
114#%{_bindir}/eu-ld
115%{_bindir}/eu-nm
116%{_bindir}/eu-readelf
117%{_bindir}/eu-size
118%{_bindir}/eu-strip
119#%{_libdir}/libasm-%{version}.so
120%{_libdir}/libebl-%{version}.so
121#%{_libdir}/libdw-%{version}.so
122%{_libdir}/libdwarf-%{version}.so
123#%{_libdir}/libasm*.so.*
124%{_libdir}/libebl*.so.*
125#%{_libdir}/libdw*.so.*
126%{_libdir}/libdwarf*.so.*
127%dir %{_libdir}/elfutils
128%{_libdir}/elfutils/lib*.so
129
130%files devel
131%defattr(-,root,root)
132%{_includedir}/dwarf.h
133%{_includedir}/libelf.h
134%{_includedir}/gelf.h
135%{_includedir}/nlist.h
136%dir %{_includedir}/elfutils
137%{_includedir}/elfutils/elf-knowledge.h
138%{_includedir}/elfutils/libebl.h
139#%{_libdir}/libasm.a
140%{_libdir}/libebl.a
141%{_libdir}/libelf.a
142#%{_libdir}/libdw.a
143#%{_libdir}/libasm.so
144%{_libdir}/libebl.so
145%{_libdir}/libelf.so
146#%{_libdir}/libdw.so
147#%{_libdir}/libdwarf.so
148
149%files libelf
150%defattr(-,root,root)
151%{_libdir}/libelf-%{version}.so
152%{_libdir}/libelf*.so.*
153
154%changelog
155* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
156- debuginfo rebuild
157
158* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
159- use the correct way of identifying the section via the sh_info link.
160
161* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
162- update to 0.75 (eu-strip -g fix)
163
164* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
165- update to 0.74 (fix for writing with some non-dirty sections)
166
167* Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
168- another -0.73 update (with sparc fixes).
169- do "make check" in %%check, not %%install, section.
170
171* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
172- update to 0.73 (with s390 fixes).
173
174* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
175- rebuilt
176
177* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
178- fix arguments to gelf_getsymshndx and elf_getshstrndx
179- fix other warnings
180- reenable checks on s390x
181
182* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
183- temporarily disable checks on s390x, until someone has
184 time to look at it
185
186* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
187- update to 0.72
188
189* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
190- update to 0.71
191
192* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
193- update to 0.69.
194- add "make check" and segfault avoidance patch.
195- elfutils-libelf needs to run ldconfig.
196
197* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
198- update to 0.68.
199
200* Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
201- update to 0.67.
202
203* Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
204- update to 0.65.
205
206* Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
207- update to 0.64.
208
209* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
210- split packages further into elfutils-libelf
211
212* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
213- update to 0.63.
214
215* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
216- Adjust for dropping libtool
217
218* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
219- update to 0.59
220
221* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
222- update to 0.56
223
224* Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
225- update to 0.54
226
227* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
228- update to 0.53
229- drop x86_64 hack, ICE fixed in gcc-3.2-11.
230
231* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
232- get beehive to punch a rhpkg generated package.
233
234* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
235- build in 8.0.1.
236- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
237
238* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
239- Add libelf-devel to conflicts for elfutils-devel
240
241* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
242- Split into runtime and devel package
243
244* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
245- integrate into official sources
246
247* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
248- Swaddle.
This page took 0.544597 seconds and 4 git commands to generate.