]> git.pld-linux.org Git - packages/elfutils.git/blame - elfutils.spec
- PLDized
[packages/elfutils.git] / elfutils.spec
CommitLineData
d5753979
AF
1Summary: A collection of utilities and DSOs to handle compiled objects.
2Name: elfutils
3Version: 0.76
4Release: 4
5License: GPL
6Group: Development/Tools
ecbc8f89 7#URL: file://home/devel/drepper
d5753979
AF
8Source0: %{name}-%{version}.tar.gz
9Requires: elfutils-libelf = %{version}-%{release}
10BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11BuildRequires: gcc >= 3.2
12BuildRequires: sharutils
ecbc8f89 13
ecbc8f89
AF
14%define _programprefix eu-
15
16%description
d5753979
AF
17Elfutils is a collection of utilities, including ld (a linker), nm
18(for listing symbols from object files), size (for listing the section
19sizes of an object or archive file), strip (for discarding symbols),
20readline (the see the raw ELF file structures), and elflint (to check
21for well-formed ELF files). Also included are numerous helper
22libraries which implement DWARF, ELF, and machine-specific ELF
ecbc8f89
AF
23handling.
24
25%package devel
d5753979
AF
26Summary: Development libraries to handle compiled objects.
27Group: Development/Tools
28Obsoletes: libelf-devel
29Requires: elfutils = %{version}-%{release}
ecbc8f89
AF
30
31%description devel
32The elfutils-devel package contains the libraries to create
d5753979 33applications for handling compiled objects. libelf allows you to
ecbc8f89 34access the internals of the ELF object file format, so you can see the
d5753979
AF
35different sections of an ELF file. libebl provides some higher-level
36ELF access functionality. libdwarf provides access to the DWARF
37debugging information. libasm provides a programmable assembler
ecbc8f89
AF
38interface.
39
40%package libelf
d5753979
AF
41Summary: Library to read and write ELF files.
42Group: Development/Tools
43Obsoletes: libelf
ecbc8f89
AF
44
45%description libelf
46The elfutils-libelf package provides a DSO which allows reading and
d5753979
AF
47writing ELF files on a high level. Third party programs depend on this
48package to read internals of ELF files. The programs of the elfutils
49package use it also to generate new ELF files.
ecbc8f89
AF
50
51%prep
52%setup -q
53
54%build
d5753979
AF
55%{__aclocal}
56%{__autoheader}
57%{__automake}
58%{__autoconf}
59%configure \
60 --program-prefix=%{_programprefix} \
61 --enable-shared
ecbc8f89
AF
62
63%install
d5753979
AF
64rm -rf $RPM_BUILD_ROOT
65install -d ${RPM_BUILD_ROOT}%{_prefix}
ecbc8f89 66
ecbc8f89 67#make check
d5753979
AF
68%{__make} install \
69 DESTDIR=$RPM_BUILD_ROOT
ecbc8f89
AF
70
71chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
72chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
73
ecbc8f89
AF
74
75# XXX Nuke unpackaged files
76{ cd ${RPM_BUILD_ROOT}
77 rm -f .%{_bindir}/eu-ld
78 rm -f .%{_includedir}/elfutils/libasm.h
79 rm -f .%{_includedir}/elfutils/libdw.h
80 rm -f .%{_includedir}/elfutils/libdwarf.h
81 rm -f .%{_libdir}/libasm-%{version}.so
82 rm -f .%{_libdir}/libasm.a
83 rm -f .%{_libdir}/libdw-%{version}.so
84 rm -f .%{_libdir}/libdw.a
85 rm -f .%{_libdir}/libdwarf.a
86}
87
d5753979
AF
88#%%check
89#make check
ecbc8f89
AF
90
91%clean
92rm -rf ${RPM_BUILD_ROOT}
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%post libelf -p /sbin/ldconfig
99
100%postun libelf -p /sbin/ldconfig
101
102%files
d5753979 103%defattr(644,root,root,755)
ecbc8f89 104%doc README TODO libdwarf/AVAILABLE
d5753979 105%attr(755,root,root) %{_bindir}/eu-elflint
ecbc8f89 106#%{_bindir}/eu-ld
d5753979
AF
107%attr(755,root,root) %{_bindir}/eu-nm
108%attr(755,root,root) %{_bindir}/eu-readelf
109%attr(755,root,root) %{_bindir}/eu-size
110%attr(755,root,root) %{_bindir}/eu-strip
ecbc8f89
AF
111#%{_libdir}/libasm-%{version}.so
112%{_libdir}/libebl-%{version}.so
113#%{_libdir}/libdw-%{version}.so
114%{_libdir}/libdwarf-%{version}.so
115#%{_libdir}/libasm*.so.*
116%{_libdir}/libebl*.so.*
117#%{_libdir}/libdw*.so.*
118%{_libdir}/libdwarf*.so.*
119%dir %{_libdir}/elfutils
120%{_libdir}/elfutils/lib*.so
121
122%files devel
d5753979 123%defattr(644,root,root,755)
ecbc8f89
AF
124%{_includedir}/dwarf.h
125%{_includedir}/libelf.h
126%{_includedir}/gelf.h
127%{_includedir}/nlist.h
128%dir %{_includedir}/elfutils
129%{_includedir}/elfutils/elf-knowledge.h
130%{_includedir}/elfutils/libebl.h
131#%{_libdir}/libasm.a
132%{_libdir}/libebl.a
133%{_libdir}/libelf.a
134#%{_libdir}/libdw.a
135#%{_libdir}/libasm.so
136%{_libdir}/libebl.so
137%{_libdir}/libelf.so
138#%{_libdir}/libdw.so
139#%{_libdir}/libdwarf.so
140
141%files libelf
d5753979 142%defattr(644,root,root,755)
ecbc8f89
AF
143%{_libdir}/libelf-%{version}.so
144%{_libdir}/libelf*.so.*
This page took 0.042986 seconds and 4 git commands to generate.