]> git.pld-linux.org Git - packages/elektra.git/commitdiff
- updated to 0.7.2
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Mar 2013 19:42:24 +0000 (20:42 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Mar 2013 19:42:24 +0000 (20:42 +0100)
- updated elektraenv patch
- added am patch (fixes build with automake 1.13)
- removed obsolete Makefile_CFLAGS,libdir,not_implemented_func_hack,doc patches
- package C++ binding

elektra-Makefile_CFLAGS.patch [deleted file]
elektra-am.patch [new file with mode: 0644]
elektra-doc.patch [deleted file]
elektra-elektraenv.patch
elektra-libdir.patch [deleted file]
elektra-not_implemented_func_hack.patch [deleted file]
elektra.spec

diff --git a/elektra-Makefile_CFLAGS.patch b/elektra-Makefile_CFLAGS.patch
deleted file mode 100644 (file)
index 2a58797..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -Nurb o/Makefile n/Makefile
---- o/Makefile 1970-10-30 02:52:28.000000000 +0100
-+++ n/Makefile 2004-11-09 01:31:53.322186704 +0100
-@@ -3,7 +3,9 @@
- # $LastChangedBy: aviram $
- NAME=elektra
--CC=gcc -O3 -g -Wcomment -Wformat -Wimplicit-int -Wimplicit-function-declaration -Wparentheses -Wreturn-type -Wunused -Wuninitialized
-+CC = cc
-+CFLAGS ?= -ggdb -O0
-+AFLAGS += -Wall
- XMLINCLUDES=`xml2-config --cflags`
- XMLLIBS=`xml2-config --libs`
-@@ -16,7 +18,7 @@
- .c.o:
--      ${CC} -g -fpic -o $@ -c $<
-+      $(CC) $(CFLAGS) $(AFLAGS)  -fpic -o $@ -c $<
-@@ -36,11 +38,11 @@
-       for x in ${DIRS}; do (cd "$$x"; make $@); done
- libregistry.so: registrystub.o libkdb.so
--      ${CC} -shared -fpic -o $@ libkdb.so registrystub.o
-+      $(CC) $(CFLAGS) $(AFLAGS)  -shared -fpic -o $@ libkdb.so registrystub.o
- libkdb.so: localkdb.o key.o
--      ${CC} -shared -fpic -o $@ localkdb.o key.o
-+      $(CC) $(CFLAGS) $(AFLAGS)  -shared -fpic -o $@ localkdb.o key.o
-@@ -51,25 +53,25 @@
- key.o: key.c kdb.h kdbprivate.h
--      ${CC} -g -fpic -o $@ -c $<
-+      $(CC) $(CFLAGS) $(AFLAGS)  -fpic -o $@ -c $<
- localkdb.o: localkdb.c kdb.h kdbprivate.h
--      ${CC} -g -fpic -c $<
-+      $(CC) $(CFLAGS) $(AFLAGS)  -fpic -c $<
- kdb.o: kdb.c kdb.h kdbprivate.h
--      ${CC} -g ${XMLINCLUDES} -fpic -c $<
-+      $(CC) $(CFLAGS) $(AFLAGS)  ${XMLINCLUDES} -fpic -c $<
- kdb: kdb.o libkdb.so
--      ${CC} -g -L. ${XMLLIBS} -lkdb -o $@ $<
-+      $(CC) $(CFLAGS) $(AFLAGS)  -L. ${XMLLIBS} -lkdb -o $@ $<
-       # ld -shared -lc -lkdb -static -lxml2 -lz -o $@ $<
diff --git a/elektra-am.patch b/elektra-am.patch
new file mode 100644 (file)
index 0000000..17a0c49
--- /dev/null
@@ -0,0 +1,33 @@
+--- elektra-0.7.0/doc/Makefile.am.orig 2008-10-16 20:53:31.000000000 +0200
++++ elektra-0.7.0/doc/Makefile.am      2013-03-26 20:58:28.370640680 +0100
+@@ -198,8 +198,8 @@
+       list=`find $$api_d`; for p in $$list; do \
+       if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+       f="`echo $$p | sed -e 's|^.*/||'`"; \
+-        echo " $(develdocDATA_INSTALL) $$d$$p $(DESTDIR)$(apihtmldir)/$$f"; \
+-        $(develdocDATA_INSTALL) $$d$$p $(DESTDIR)$(apihtmldir)/$$f; \
++        echo " $(install_sh_DATA) $$d$$p $(DESTDIR)$(apihtmldir)/$$f"; \
++        $(install_sh_DATA) $$d$$p $(DESTDIR)$(apihtmldir)/$$f; \
+       done
+ uninstall-develdocDATA:
+--- elektra-0.7.2/src/bindings/cpp/Makefile.am.orig    2010-04-27 09:17:25.000000000 +0200
++++ elektra-0.7.2/src/bindings/cpp/Makefile.am 2013-03-27 20:00:49.167160035 +0100
+@@ -12,7 +12,7 @@
+ objects = kdb.o key.o keyset.o
+-lib_LIBRARIES = libelektra-cpp.a
++ulib_LIBRARIES = libelektra-cpp.a
+ libelektra_cpp_a_SOURCES = $(sources)
+ libelektra_cpp_a_DEPENDENCIES =
+ libelektra_cpp_a_CXXFLAGS = $(cxxflags)
+@@ -20,7 +20,7 @@
+ libelektra_cpp_a_LIBADD =
+ BUILT_SOURCES =
+-lib_LTLIBRARIES = libelektra-cpp.la
++ulib_LTLIBRARIES = libelektra-cpp.la
+ libelektra_cpp_la_SOURCES = $(sources)
+ libelektra_cpp_la_DEPENDENCIES =
+ libelektra_cpp_la_CXXFLAGS = $(cxxflags)
diff --git a/elektra-doc.patch b/elektra-doc.patch
deleted file mode 100644 (file)
index e017215..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- elektra/doc/Makefile~      2006-03-02 12:41:01.000000000 +0200
-+++ elektra/doc/Makefile       2006-03-02 12:41:05.000000000 +0200
-@@ -84,13 +84,10 @@
-       [ -d ${DESTDIR}/usr/share/man/man3 ] || mkdir -p ${DESTDIR}/usr/share/man/man3
-       [ -d ${DESTDIR}/usr/share/man/man5 ] || mkdir -p ${DESTDIR}/usr/share/man/man5
-       [ -d ${DESTDIR}/usr/share/man/man7 ] || mkdir -p ${DESTDIR}/usr/share/man/man7
--      find ${APIDIR}/html | cpio -pdm ${DESTDIR}/usr/share/doc/elektra-devel/
--      for m in `ls *.1`; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man1/$$m.gz; done
--#     for m in `ls *.3`; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man3/$$m.gz; done
--      gzip ${APIDIR}/man/man3/kdb*.3 ${APIDIR}/man/man3/key*.3 ${APIDIR}/man/man3/ks*.3
--      cp ${APIDIR}/man/man3/kdb*.3.gz ${APIDIR}/man/man3/key*.3.gz ${APIDIR}/man/man3/ks*.3.gz ${DESTDIR}/usr/share/man/man3/
--      for m in `ls *.5`; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man5/$$m.gz; done
--      for m in `ls *.7`; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man7/$$m.gz; done
-+      for m in *.1; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man1/$$m.gz; done
-+      for m in ${APIDIR}/man/man3/{kdb,key,ks}*.3; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man3/$$(basename $$m).gz; done
-+      for m in *.5; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man5/$$m.gz; done
-+      for m in *.7; do gzip -c --best $$m > ${DESTDIR}/usr/share/man/man7/$$m.gz; done
- #     cat kdb.3.xml | perl -e '{while (<>) {m/<function>(\w*)<\/function>/; print $$1 . "\n" if ($$1); }}' | \
- #             grep kdb | sort -u | while read f; do ln -s kdb.3.gz ${DESTDIR}/usr/share/man/man3/$$f.3.gz; done
- #     cat key.3.xml | perl -e '{while (<>) {m/<function>(\w*)<\/function>/; print $$1 . "\n" if ($$1); }}' | \
index 815418e2796d02574984d9c0714650c883105349..471fef91c843cb795a7fe622a59f85bf84126423 100644 (file)
@@ -1,18 +1,11 @@
---- w/scripts/elektraenv       1970-08-22 22:34:52.000000000 +0100
-+++ elektra/scripts/elektraenv 2004-11-09 22:32:13.716304744 +0100
-@@ -31,12 +31,14 @@
- ## April 2004
+--- elektra-0.7.0/scripts/elektraenv.sh.orig   2013-03-26 18:13:21.471056433 +0100
++++ elektra-0.7.0/scripts/elektraenv.sh        2013-03-26 18:13:41.247722269 +0100
+@@ -34,6 +34,8 @@
  ##
+ ###########################################################################
  
 +[ -s /etc/sysconfig/elektra ] && . /etc/sysconfig/elektra
 +[ x$RUN = xyes ] || return 0
  
- if [ -z "$RG" ]; then
-       RG=kdb
- fi
--FILE="/tmp/elektraenv$$"
-+FILE=$(mktemp /tmp/elektraenv.XXXXXX) || return 0
- #set -vx
+ if [ -z "$KDB" ]; then
+       KDB=kdb
diff --git a/elektra-libdir.patch b/elektra-libdir.patch
deleted file mode 100644 (file)
index ca2a151..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- elektra/Makefile~  2004-11-09 19:51:22.991243784 +0000
-+++ elektra/Makefile   2004-11-09 19:53:18.951615128 +0000
-@@ -8,6 +8,7 @@
- AFLAGS += -Wall
- XMLINCLUDES=`xml2-config --cflags`
- XMLLIBS=`xml2-config --libs`
-+LIB=/lib
- DTDVERSION=0.1.0
- SVNREP=http://germane-software.com/repositories/elektra
-@@ -118,16 +119,16 @@
-       for x in ${DIRS}; do (cd "$$x"; make DTDVERSION=${DTDVERSION} $@); done
-       strip libkdb.so
-       strip libregistry.so  # remove me in the future
--      [ -d "${DESTDIR}/lib" ] || mkdir -p ${DESTDIR}/lib
--      [ -d "${DESTDIR}/usr/lib" ] || mkdir -p ${DESTDIR}/usr/lib
-+      [ -d "${DESTDIR}${LIB}" ] || mkdir -p ${DESTDIR}${LIB}
-+      [ -d "${DESTDIR}/usr${LIB}" ] || mkdir -p ${DESTDIR}/usr${LIB}
-       [ -d "${DESTDIR}/bin" ] || mkdir -p ${DESTDIR}/bin
-       [ -d "${DESTDIR}/usr/include" ] || mkdir -p ${DESTDIR}/usr/include
-       [ -d "${DESTDIR}/etc/profile.d" ] || mkdir -p ${DESTDIR}/etc/profile.d
-       [ -d "${DESTDIR}/usr/share/doc/${NAME}" ] || mkdir -p ${DESTDIR}/usr/share/doc/${NAME}
-       [ -d "${DESTDIR}/usr/share/doc/${NAME}-devel" ] || mkdir -p ${DESTDIR}/usr/share/doc/${NAME}-devel
--      cp libkdb.so ${DESTDIR}/lib
--      cp libkdb.a ${DESTDIR}/usr/lib
--      cp libregistry.so ${DESTDIR}/lib # remove me in the future
-+      cp libkdb.so ${DESTDIR}${LIB}
-+      cp libkdb.a ${DESTDIR}/usr${LIB}
-+      cp libregistry.so ${DESTDIR}${LIB} # remove me in the future
-       strip kdb
-       cp kdb ${DESTDIR}/bin
-       cp kdb.h ${DESTDIR}/usr/include
diff --git a/elektra-not_implemented_func_hack.patch b/elektra-not_implemented_func_hack.patch
deleted file mode 100644 (file)
index 30e5620..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -Nurb b/kdb.h n/kdb.h
---- b/kdb.h    1970-10-09 14:30:09.000000000 +0100
-+++ n/kdb.h    2004-11-09 19:57:51.226251920 +0100
-@@ -285,8 +285,8 @@
- int kdbGetValueByParent(const char *parentName, const char *baseName, char *returned,
-       size_t maxSize);
--int kdbGetComment(const char *keyname, char *returned, size_t maxSize);
--size_t kdbSetComment(const char *keyname, const char *comment);
-+// not implemented int kdbGetComment(const char *keyname, char *returned, size_t maxSize);
-+// not implemented size_t kdbSetComment(const char *keyname, const char *comment);
- int kdbStatKey(Key *key);
- int kdbGetKey(Key *key);
-diff -Nurb b/registrystub.c n/registrystub.c
---- b/registrystub.c   1970-08-22 22:34:52.000000000 +0100
-+++ n/registrystub.c   2004-11-09 19:58:50.723207008 +0100
-@@ -85,14 +85,16 @@
- }
--int registryGetComment(char *keyname, char *returned,size_t maxSize) {
-+/* kdbGetComment is not implemented
-+ * int registryGetComment(char *keyname, char *returned,size_t maxSize) {
-       return kdbGetComment(keyname, returned,maxSize);
--}
-+} */
--size_t registrySetComment(char *keyname, char *comment) {
-+/* kdbSetComment is not implemented
-+ * size_t registrySetComment(char *keyname, char *comment) {
-       return kdbSetComment(keyname, comment);
--}
-+} */
- int registryStatKey(Key *key) {
-       return kdbStatKey(key);
index a361d9c5b91d698243e9fabffdf2b23dd41534ef..58df0149166ed66531f161832388ce34352715cd 100644 (file)
@@ -1,28 +1,45 @@
+# TODO: PLDify init script
+#
+# Conditonal build:
+%bcond_with    db      # BerkeleyDB backend [slightly outdated]
+%bcond_with    gconf   # GConf backend [same as above]
+%bcond_with    python  # Python binding [same as above]
+#
 Summary:       A key/value pair database to store software configurations
 Summary(pl.UTF-8):     Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
 Name:          elektra
-Version:       0.4.6
+Version:       0.7.2
 Release:       0.1
-Epoch:         0
 License:       BSD
 Group:         Applications/System
-Source0:       http://dl.sourceforge.net/elektra/%{name}-%{version}.tar.gz
-# Source0-md5: f032ec83ffe91f2e7c2a0d70f67749eb
-Patch0:                %{name}-Makefile_CFLAGS.patch
-Patch1:                %{name}-libdir.patch
-Patch2:                %{name}-not_implemented_func_hack.patch
-Patch3:                %{name}-elektraenv.patch
-Patch4:                %{name}-doc.patch
-URL:           http://elektra.sourceforge.net/
+Source0:       http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
+# Source0-md5: 29f14be7693ae627fb8cc30a079b10c9
+Patch0:                %{name}-elektraenv.patch
+Patch1:                %{name}-am.patch
+URL:           http://www.libelektra.org/
+%{?with_gconf:BuildRequires:   GConf2-devel}
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake
+%{?with_db:BuildRequires:      db-devel}
+BuildRequires: doxygen
+BuildRequires: gettext-devel
+BuildRequires: libstdc++-devel
+BuildRequires: libltdl-devel
+BuildRequires: libtool
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-progs
-Requires(post):        /sbin/ldconfig
+BuildRequires: pkgconfig
+%{?with_python:BuildRequires:  python-devel}
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      mktemp
 # for /usr/share/sgml dir
 Requires:      sgml-common
 Obsoletes:     registry
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _bindir         /bin
+%define                _sbindir        /sbin
+
 %description
 The Elektra Project provides a framework to store generic
 configuration data in an hierarchical key-value pair database, instead
@@ -41,13 +58,13 @@ W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
 konfiguracji innych aplikacji, ułatwiając ich integrację.
 
-%package devel
-Summary:       Include files and API documentation for Elektra Project
-Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja API projektu Elektra
-Group:         Development/Libraries
-Requires:      elektra = %{epoch}:%{version}-%{release}
+%package libs
+Summary:       Elektra Project libraries
+Summary(pl.UTF-8):     Biblioteki projektu Elektra
+Group:         Libraries
+Conflicts:     elektra < 0.7
 
-%description devel
+%description libs
 The Elektra Project provides a framework to store generic
 configuration data in an hierarchical key-value pair database, instead
 of a human-readable only text file.
@@ -56,10 +73,9 @@ This way any software can read/save his configuration using a
 consistent API. Also, applications can be aware of other applications
 configurations, leveraging easy application integration.
 
-This package contains the include files and API manual pages to use
-the Elektra API in C.
+This package contains Elektra shared libraries.
 
-%description devel -l pl.UTF-8
+%description libs -l pl.UTF-8
 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
@@ -68,90 +84,200 @@ W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
 konfiguracji innych aplikacji, ułatwiając ich integrację.
 
+Ten pakiet zawiera biblioteki współdzielone Elektry.
+
+%package devel
+Summary:       Include files and API documentation for Elektra Project
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja API projektu Elektra
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description devel
+This package contains the include files and API manual pages to use
+the Elektra API in C.
+
+%description devel -l pl.UTF-8
 Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
 systemowego opisującego sposób użycia API Elektry w C.
 
 %package static
-Summary:       Static library for Elektra Project
-Summary(pl.UTF-8):     Statyczna wersja biblioteki projektu Elektra
+Summary:       Static libraries for Elektra Project
+Summary(pl.UTF-8):     Statyczne biblioteki projektu Elektra
 Group:         Development/Libraries
-Requires:      elektra-devel = %{epoch}:%{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-The Elektra Project provides a framework to store generic
-configuration data in an hierarchical key-value pair database, instead
-of a human-readable only text file.
+This package contains static libraries for Elektra Project.
 
-This way any software can read/save his configuration using a
-consistent API. Also, applications can be aware of other applications
-configurations, leveraging easy application integration.
+%description static -l pl.UTF-8
+Ten pakiet zawiera statyczne biblioteki projektu Elektra.
 
-This package contains static library for Elektra Project.
+%package cpp
+Summary:       C++ interface for Elektra library
+Summary(pl.UTF-8):     Interfejs C++ do biblioteki Elektra
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
 
-%description static -l pl.UTF-8
-Projekt Elektra dostarcza szkielet do przechowywania typowych danych
-konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
-danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
+%description cpp
+C++ interface for Elektra library.
 
-W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
-pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
-konfiguracji innych aplikacji, ułatwiając ich integrację.
+%description cpp -l pl.UTF-8
+Interfejs C++ do biblioteki Elektra.
+
+%package cpp-devel
+Summary:       Header files of C++ interface for Elektra library
+Summary(pl.UTF-8):     Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
+Group:         Development/Libraries
+Requires:      %{name}-cpp = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      libstdc++-devel
+
+%description cpp-devel
+Header files of C++ interface for Elektra library.
+
+%description cpp-devel -l pl.UTF-8
+Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
+
+%package cpp-static
+Summary:       Static library of C++ interface for Elektra library
+Summary(pl.UTF-8):     Biblioteka statyczna interfejsu C++ do biblioteki Elektra
+Group:         Development/Libraries
+Requires:      %{name}-cpp-devel = %{version}-%{release}
 
-Ten pakiet zawiera wersję statyczną biblioteki projektu Elektra.
+%description cpp-static
+Static library of C++ interface for Elektra library.
+
+%description cpp-static -l pl.UTF-8
+Biblioteka statyczna interfejsu C++ do biblioteki Elektra.
 
 %prep
-%setup -q -n %{name}
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
-%{__make} all \
-       CC="%{__cc}" \
-       CFLAGS="%{rpmcflags}"
+cp -f /usr/share/gettext/config.rpath .
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --libdir=/%{_lib} \
+       %{?with_db:--enable-berkeleydb} \
+       %{?with_gconf:--enable-gconf} \
+       --enable-passwd \
+       %{?with_python:--enable-python}
+# also outdated (as of 0.7.2): daemon, fstab
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/sysconfig
 
 %{__make} install \
-        LIB=/%{_lib} \
-        DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       elektrainitdir=/etc/rc.d/init.d
+
+%{!?with_berkeleydb:%{__rm} $RPM_BUILD_ROOT/%{_lib}/elektra/libelektra-ddefault.so}
 
-rm -rf elektra-api
-cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-devel elektra-api
-rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}{,-devel}
+# prepare docs
+rm -rf installed-doc
+install -d installed-doc
+mv $RPM_BUILD_ROOT%{_docdir}/%{name}-devel installed-doc/elektra-api
+mv $RPM_BUILD_ROOT%{_docdir}/%{name}/scripts installed-doc/scripts
+rmdir $RPM_BUILD_ROOT%{_docdir}/%{name}
 
 echo 'RUN="no"' > $RPM_BUILD_ROOT/etc/sysconfig/elektra
 
+# move devel files to /usr
+%{__mv} $RPM_BUILD_ROOT/%{_lib}/libelektra.a $RPM_BUILD_ROOT%{_libdir}
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelektra.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libelektra.so
+%{__rm} $RPM_BUILD_ROOT/%{_lib}/libelektra.so
+
+# dlopened modules
+%{__rm} $RPM_BUILD_ROOT/%{_lib}/elektra/*.{la,a}
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT/%{_lib}/lib*.la \
+       $RPM_BUILD_ROOT%{_libdir}/lib*.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/sbin/ldconfig
 # Create basic key structure for apps
 kdb set -t dir system/sw || :
+kdb set system/sw/kdb/schemapath "%{_datadir}/sgml/elektra-0.7.1/elektra.xsd"
 
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
+%post  cpp -p /sbin/ldconfig
+%postun        cpp -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc articles doc/standards example scripts AUTHORS ChangeLog README TODO
-%attr(755,root,root) /bin/*
-%attr(755,root,root) /%{_lib}/lib*.so
-%attr(755,root,root) /etc/profile.d/*
-%{_datadir}/sgml/*
-%{_mandir}/man[157]/*
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
+%doc AUTHORS COPYING ChangeLog NEWS README TODO doc/standards installed-doc/scripts
+%attr(755,root,root) /bin/kdb
+%attr(755,root,root) /bin/kdb_static
+%attr(755,root,root) /bin/preload
+%attr(755,root,root) /bin/preload_static
+%dir /%{_lib}/elektra
+%attr(755,root,root) /%{_lib}/elektra/libelektra-default.so
+%attr(755,root,root) /%{_lib}/elektra/libelektra-filesys.so*
+%attr(755,root,root) /%{_lib}/elektra/libelektra-hosts.so*
+%attr(755,root,root) /%{_lib}/elektra/libelektra-passwd.so*
+%if %{with db}
+%attr(755,root,root) /%{_lib}/elektra/libelektra-berkeleydb.so*
+%attr(755,root,root) /%{_lib}/elektra/libelektra-ddefault.so
+%endif
+%if %{with gconf}
+%attr(755,root,root) /%{_lib}/elektra/libelektra-gconf.so*
+%endif
+%attr(754,root,root) /etc/rc.d/init.d/kdbd
+%attr(755,root,root) /etc/profile.d/elektraenv.sh
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/elektra
+%{_datadir}/sgml/elektra-0.7.1
+%{_mandir}/man1/kdb.1*
+%{_mandir}/man5/elektra.5*
+%{_mandir}/man7/elektra.7*
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) /%{_lib}/libelektra.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libelektra.so.3
+%attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
 
 %files devel
 %defattr(644,root,root,755)
-%doc bindings elektra-api/*
-%{_includedir}/*
-%{_mandir}/man3/*
+%doc installed-doc/elektra-api/*
+%attr(755,root,root) %{_libdir}/libelektra.so
+%attr(755,root,root) %{_libdir}/libelektratools.so
+%{_includedir}/kdb*.h
+%{_pkgconfigdir}/elektra.pc
+%{_pkgconfigdir}/elektratools.pc
+%{_mandir}/man3/kdb*.3*
+%{_mandir}/man3/key*.3*
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libelektra.a
+%{_libdir}/libelektratools.a
+
+%files cpp
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libelektra-cpp.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libelektra-cpp.so.0
+
+%files cpp-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libelektra-cpp.so
+%{_includedir}/kdb
+%{_includedir}/key
+%{_includedir}/keyset
+%{_pkgconfigdir}/elektracpp.pc
+
+%files cpp-static
+%defattr(644,root,root,755)
+%{_libdir}/libelektra-cpp.a
This page took 0.123935 seconds and 4 git commands to generate.