]> git.pld-linux.org Git - packages/elektra.git/blob - elektra.spec
00dd6ad7fd0d0b5613ad706f00f594420dfbb6d9
[packages/elektra.git] / elektra.spec
1 # TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
2 #
3 # Conditonal build:
4 %bcond_with     full    # "full" variant (libelektra-full with all plugins linked in)
5 %bcond_without  java    # Java support: JNA binding and JNI plugin (needs Java 8)
6 %bcond_without  glib    # GLib/GObject binding
7 %bcond_without  lua     # Lua (5.2) support: binding and plugin
8 %bcond_without  python2 # Python 2 support: binding and plugin
9 %bcond_without  python3 # Python 3 support: binding and plugin
10 %bcond_without  qt      # Qt GUI
11 #
12 Summary:        A key/value pair database to store software configurations
13 Summary(pl.UTF-8):      Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
14 Name:           elektra
15 Version:        0.8.19
16 Release:        1
17 License:        BSD
18 Group:          Applications/System
19 Source0:        http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  6669e765c834e259fb7570f126b85d7e
21 Patch1:         %{name}-no-markdown.patch
22 Patch2:         %{name}-no-deb.patch
23 URL:            http://www.libelektra.org/
24 %if %{with qt}
25 BuildRequires:  Qt5Core-devel >= 5
26 BuildRequires:  Qt5Gui-devel >= 5
27 BuildRequires:  Qt5Qml-devel >= 5
28 BuildRequires:  Qt5Quick-devel >= 5
29 BuildRequires:  Qt5Widgets-devel >= 5
30 BuildRequires:  Qt5Test-devel >= 5
31 %endif
32 BuildRequires:  augeas-devel >= 1.0
33 BuildRequires:  boost-devel
34 BuildRequires:  cmake >= 2.8.8
35 BuildRequires:  dbus-devel
36 BuildRequires:  doxygen
37 BuildRequires:  gettext-tools
38 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.36}
39 %{?with_glib:BuildRequires:     gobject-introspection-devel >= 1.38}
40 # for binding
41 %{?with_java:BuildRequires:     java-jna}
42 %{?with_java:BuildRequires:     jdk >= 1.8}
43 # jawt for plugin
44 %{?with_java:BuildRequires:     jre-X11 >= 1.8}
45 BuildRequires:  libgcrypt-devel
46 %{?with_qt:BuildRequires:       libmarkdown-devel}
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libxml2-devel >= 2.0
49 BuildRequires:  libxslt-progs
50 %{?with_lua:BuildRequires:      lua52-devel >= 5.2}
51 BuildRequires:  pkgconfig
52 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
53 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
54 BuildRequires:  ronn
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.612
57 BuildRequires:  swig >= 2
58 %if %{with python2} || %{with python3}
59 BuildRequires:  swig-python >= 2
60 %endif
61 BuildRequires:  systemd-devel
62 BuildRequires:  tcl-devel
63 BuildRequires:  yajl-devel
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       mktemp
66 Obsoletes:      registry
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 The Elektra Project provides a framework to store generic
71 configuration data in an hierarchical key-value pair database, instead
72 of a human-readable only text file.
73
74 This way any software can read/save his configuration using a
75 consistent API. Also, applications can be aware of other applications
76 configurations, leveraging easy application integration.
77
78 %description -l pl.UTF-8
79 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
80 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
81 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
82
83 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
84 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
85 konfiguracji innych aplikacji, ułatwiając ich integrację.
86
87 %package gui
88 Summary:        Qt based GUI for Elektra
89 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs do Elektry
90 Group:          X11/Applications
91 Requires:       %{name} = %{version}-%{release}
92
93 %description gui
94 Qt based GUI for Elektra.
95
96 %description gui -l pl.UTF-8
97 Oparty na Qt graficzny interfejs do Elektry.
98
99 %package plugin-jni
100 Summary:        Java JNI plugin for Elektra
101 Summary(pl.UTF-8):      Wtyczka Java JNI dla Elektry
102 Group:          Libraries
103 Requires:       %{name} = %{version}-%{release}
104 # jawt
105 Requires:       jre-X11 >= 1.8
106
107 %description plugin-jni
108 Java JNI plugin for Elektra. It allows to use plugins written in Java.
109
110 %description plugin-jni -l pl.UTF-8
111 Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
112 Javie.
113
114 %package plugin-lua
115 Summary:        Lua plugin for Elektra
116 Summary(pl.UTF-8):      Wtyczka Lua dla Elektry
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       lua52-libs >= 5.2
120
121 %description plugin-lua
122 Lua plugin for Elektra. It allows to use plugins written in Lua.
123
124 %description plugin-lua -l pl.UTF-8
125 Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
126
127 %package plugin-python2
128 Summary:        Python 2 plugin for Elektra
129 Summary(pl.UTF-8):      Wtyczka Python 2 dla Elektry
130 Group:          Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       python-libs >= 1:2.7
133
134 %description plugin-python2
135 Python 2 plugin for Elektra. It allows to use plugins written in
136 Python 2.
137
138 %description plugin-python2 -l pl.UTF-8
139 Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
140 Pythonie 2.
141
142 %package plugin-python3
143 Summary:        Python plugin for Elektra
144 Summary(pl.UTF-8):      Wtyczka Python dla Elektry
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       python3-libs >= 1:3.2
148
149 %description plugin-python3
150 Python 3 plugin for Elektra. It allows to use plugins written in
151 Python 3.
152
153 %description plugin-python3 -l pl.UTF-8
154 Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
155 Pythonie 3.
156
157 %package -n bash-completion-elektra
158 Summary:        Bash completion for Elektra commands
159 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
160 Group:          Applications/Shells
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       bash-completion
163
164 %description -n bash-completion-elektra
165 Bash completion for Elektra kdb command.
166
167 %description -n bash-completion-elektra -l pl.UTF-8
168 Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
169
170 %package libs
171 Summary:        Elektra Project libraries
172 Summary(pl.UTF-8):      Biblioteki projektu Elektra
173 Group:          Libraries
174 Obsoletes:      elektra-cpp < 0.8
175 Conflicts:      elektra < 0.7
176
177 %description libs
178 The Elektra Project provides a framework to store generic
179 configuration data in an hierarchical key-value pair database, instead
180 of a human-readable only text file.
181
182 This way any software can read/save his configuration using a
183 consistent API. Also, applications can be aware of other applications
184 configurations, leveraging easy application integration.
185
186 This package contains Elektra shared libraries.
187
188 %description libs -l pl.UTF-8
189 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
190 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
191 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
192
193 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
194 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
195 konfiguracji innych aplikacji, ułatwiając ich integrację.
196
197 Ten pakiet zawiera biblioteki współdzielone Elektry.
198
199 %package devel
200 Summary:        Include files and API documentation for Elektra Project
201 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API projektu Elektra
202 Group:          Development/Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204
205 %description devel
206 This package contains the include files and API manual pages to use
207 the Elektra API in C.
208
209 %description devel -l pl.UTF-8
210 Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
211 systemowego opisującego sposób użycia API Elektry w C.
212
213 %package static
214 Summary:        Static libraries for Elektra Project
215 Summary(pl.UTF-8):      Statyczne biblioteki projektu Elektra
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}-%{release}
218
219 %description static
220 This package contains static libraries for Elektra Project.
221
222 %description static -l pl.UTF-8
223 Ten pakiet zawiera statyczne biblioteki projektu Elektra.
224
225 %package cpp-devel
226 Summary:        Header files of C++ interface for Elektra library
227 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
228 Group:          Development/Libraries
229 Requires:       %{name}-devel = %{version}-%{release}
230 Requires:       libstdc++-devel
231 Obsoletes:      elektra-cpp-static < 0.8
232
233 %description cpp-devel
234 Header files of C++ interface for Elektra library.
235
236 %description cpp-devel -l pl.UTF-8
237 Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
238
239 %package glib
240 Summary:        GLib/GObject binding for Elektra
241 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry
242 Group:          Libraries
243 Requires:       %{name}-libs = %{version}-%{release}
244 Requires:       glib2 >= 1:2.36
245
246 %description glib
247 GLib/GObject binding for Elektra.
248
249 %description glib -l pl.UTF-8
250 Wiązanie GLib/GObject do Elektry.
251
252 %package glib-devel
253 Summary:        GLib/GObject binding for Elektra - development files
254 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry - pliki programistyczne
255 Group:          Libraries
256 Requires:       %{name}-devel = %{version}-%{release}
257 Requires:       glib2-devel >= 1:2.36
258
259 %description glib-devel
260 GLib/GObject binding for Elektra - development files.
261
262 %description glib-devel -l pl.UTF-8
263 Wiązanie GLib/GObject do Elektry - pliki programistyczne.
264
265 %package -n java-elektra
266 Summary:        Java binding for Elektra
267 Summary(pl.UTF-8):      Wiązanie języka Java dla Elektry
268 Group:          Libraries
269 Requires:       %{name}-libs = %{version}-%{release}
270 Requires:       java-jna
271 Requires:       jre
272
273 %description -n java-elektra
274 Java binding for Elektra.
275
276 %description -n java-elektra -l pl.UTF-8
277 Wiązanie języka Java dla Elektry.
278
279 %package -n lua-elektra
280 Summary:        Lua binding for Elektra
281 Summary(pl.UTF-8):      Wiązanie języka Lua dla Elektry
282 Group:          Libraries
283 Requires:       %{name}-libs = %{version}-%{release}
284 Requires:       lua52-libs >= 5.2
285
286 %description -n lua-elektra
287 Lua binding for Elektra.
288
289 %description -n lua-elektra -l pl.UTF-8
290 Wiązanie języka Lua dla Elektry.
291
292 %package -n lua-elektra-glib
293 Summary:        Lua/GI binding for Elektra
294 Summary(pl.UTF-8):      Wiązanie Lua/GI dla Elektry
295 Group:          Libraries
296 Requires:       %{name}-glib = %{version}-%{release}
297 Requires:       lua52-libs >= 5.2
298 #R: lua52-lgi ?
299
300 %description -n lua-elektra-glib
301 Lua/GI binding for Elektra.
302
303 %description -n lua-elektra-glib -l pl.UTF-8
304 Wiązanie Lua/GI dla Elektry.
305
306 %package -n python-elektra
307 Summary:        Python 2 binding for Elektra
308 Summary(pl.UTF-8):      Wiązanie Pythona 2 dla Elektry
309 Group:          Libraries
310 Requires:       %{name}-libs = %{version}-%{release}
311 Requires:       python-libs >= 1:2.7
312
313 %description -n python-elektra
314 Python 2 binding for Elektra.
315
316 %description -n python-elektra -l pl.UTF-8
317 Wiązanie Pythona 2 dla Elektry.
318
319 %package -n python3-elektra
320 Summary:        Python 3 binding for Elektra
321 Summary(pl.UTF-8):      Wiązanie Pythona 3 dla Elektry
322 Group:          Libraries
323 Requires:       %{name}-libs = %{version}-%{release}
324 Requires:       python3-libs >= 1:3.2
325
326 %description -n python3-elektra
327 Python 3 binding for Elektra.
328
329 %description -n python3-elektra -l pl.UTF-8
330 Wiązanie Pythona 3 dla Elektry.
331
332 %package -n python3-elektra-glib
333 Summary:        Python 3 GI binding for Elektra
334 Summary(pl.UTF-8):      Wiązanie Pythona 3 GI dla Elektry
335 Group:          Libraries
336 Requires:       %{name}-glib = %{version}-%{release}
337 Requires:       python3-pygobject3 >= 3
338
339 %description -n python3-elektra-glib
340 Python 3 GI binding for Elektra.
341
342 %description -n python3-elektra-glib -l pl.UTF-8
343 Wiązanie Pythona 3 GI dla Elektry.
344
345 %prep
346 %setup -q
347 %patch1 -p1
348 %patch2 -p1
349
350 %build
351 install -d build
352 cd build
353 %cmake .. \
354         -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
355         %{!?with_full:-DBUILD_FULL=OFF} \
356         -DINSTALL_TESTING=FALSE \
357         -DPLUGINS=ALL \
358         -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
359         -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}"
360
361 %{__make} -j1
362
363 %install
364 rm -rf $RPM_BUILD_ROOT
365
366 %{__make} -C build install \
367         DESTDIR=$RPM_BUILD_ROOT
368
369 install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
370
371 %if %{with python2}
372 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
373 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
374 %py_postclean
375 %endif
376
377 %if %{with python3}
378 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
379 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
380 %endif
381
382 # prepare docs
383 %{__rm} -rf installed-doc
384 install -d installed-doc
385 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
386
387 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*}.3elektra
388
389 %clean
390 rm -rf $RPM_BUILD_ROOT
391
392 %post   libs -p /sbin/ldconfig
393 %postun libs -p /sbin/ldconfig
394
395 %post   glib -p /sbin/ldconfig
396 %postun glib -p /sbin/ldconfig
397
398 %files
399 %defattr(644,root,root,755)
400 %doc doc/{AUTHORS,COPYING,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
401 # doc/standards installed-doc/scripts
402 %attr(755,root,root) %{_bindir}/kdb
403 %if %{with full}
404 %attr(755,root,root) %{_bindir}/kdb-full
405 %endif
406 %dir %{_libdir}/elektra
407 # R: augeas-libs
408 %attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
409 %attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
410 %attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
411 %attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
412 %attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
413 # R: libgcrypt
414 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto.so
415 %attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
416 # R: dbus
417 %attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
418 %attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
419 %attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
420 %attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
421 %attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
422 %attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
423 %attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
424 %attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
425 %attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
426 %attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
427 %attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
428 %attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
429 # uses internal inih library
430 %attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
431 # R: systemd-libs
432 %attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
433 %attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
434 %attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
435 %attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
436 %attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
437 %attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
438 %attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
439 %attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
440 %attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
441 # uses internal nickel library
442 %attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
443 %attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
444 %attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
445 %attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
446 %attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
447 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
448 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
449 %attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
450 %attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
451 %attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
452 %attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
453 %attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
454 %attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
455 %attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
456 %attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
457 %attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
458 %attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
459 %attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
460 %attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
461 # R: libxml2
462 %attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
463 # R: yajl
464 %attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
465 %dir %{_libdir}/elektra/tool_exec
466 %attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
467 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
468 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
469 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
470 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
471 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
472 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
473 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
474 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
475 %attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
476 %attr(755,root,root) %{_libdir}/elektra/tool_exec/getenv
477 %attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
478 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
479 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
480 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
481 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
482 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-spec
483 %attr(755,root,root) %{_libdir}/elektra/tool_exec/race
484 %attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
485 %{_datadir}/sgml/elektra
486 %{_mandir}/man1/kdb.1*
487 %{_mandir}/man1/kdb-check.1*
488 %{_mandir}/man1/kdb-convert.1*
489 %{_mandir}/man1/kdb-cp.1*
490 %{_mandir}/man1/kdb-elektrify-getenv.1*
491 %{_mandir}/man1/kdb-export.1*
492 %{_mandir}/man1/kdb-file.1*
493 %{_mandir}/man1/kdb-fstab.1*
494 %{_mandir}/man1/kdb-get.1*
495 %{_mandir}/man1/kdb-getmeta.1*
496 %{_mandir}/man1/kdb-help.1*
497 %{_mandir}/man1/kdb-import.1*
498 %{_mandir}/man1/kdb-info.1*
499 %{_mandir}/man1/kdb-introduction.1*
500 %{_mandir}/man1/kdb-list.1*
501 %{_mandir}/man1/kdb-list-tools.1*
502 %{_mandir}/man1/kdb-ls.1*
503 %{_mandir}/man1/kdb-lsmeta.1*
504 %{_mandir}/man1/kdb-merge.1*
505 %{_mandir}/man1/kdb-mount.1*
506 %{_mandir}/man1/kdb-mv.1*
507 %{_mandir}/man1/kdb-remount.1*
508 %{_mandir}/man1/kdb-rm.1*
509 %{_mandir}/man1/kdb-set.1*
510 %{_mandir}/man1/kdb-setmeta.1*
511 %{_mandir}/man1/kdb-sget.1*
512 %{_mandir}/man1/kdb-shell.1*
513 %{_mandir}/man1/kdb-test.1*
514 %{_mandir}/man1/kdb-umount.1*
515 %{_mandir}/man1/kdb-vset.1*
516 %{_mandir}/man7/elektra-*.7*
517
518 %if 0
519 %files gen ?
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
522 %{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
523 # FIXME: should be in elektra_gen subdir
524 %{py_sitescriptdir}/support
525 %{_datadir}/elektra/templates
526 %endif
527
528 %files gui
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
531 %{_mandir}/man1/kdb-qt-gui.1*
532
533 %if %{with java}
534 %files plugin-jni
535 %defattr(644,root,root,755)
536 # R: jre with jawt
537 %attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
538 %endif
539
540 %if %{with lua}
541 %files plugin-lua
542 %defattr(644,root,root,755)
543 # R: lua52-libs
544 %attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
545 %endif
546
547 %if %{with python2}
548 %files plugin-python2
549 %defattr(644,root,root,755)
550 # R: python-libs
551 %attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
552 %endif
553
554 %if %{with python3}
555 %files plugin-python3
556 %defattr(644,root,root,755)
557 # R: python3-libs
558 %attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
559 %endif
560
561 %files -n bash-completion-elektra
562 %defattr(644,root,root,755)
563 /etc/bash_completion.d/kdb
564
565 %files libs
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
569 %attr(755,root,root) %{_libdir}/libelektragetenv.so
570 %attr(755,root,root) %{_libdir}/libelektratools.so
571 %if %{with full}
572 %attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
573 %attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
574 %endif
575
576 %files devel
577 %defattr(644,root,root,755)
578 %doc doc/API.md installed-doc/elektra-api/html
579 %attr(755,root,root) %{_libdir}/libelektra.so
580 %if %{with full}
581 %attr(755,root,root) %{_libdir}/libelektra-full.so
582 %endif
583 %dir %{_includedir}/elektra
584 %{_includedir}/elektra/crypto_internal.h
585 %{_includedir}/elektra/kdb*.h
586 %{_pkgconfigdir}/elektra.pc
587 %{_datadir}/cmake/Modules/ElektraConfig*.cmake
588 %{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
589 %{_mandir}/man3/api.3elektra*
590 %{_mandir}/man3/deprecated.3elektra*
591 %{_mandir}/man3/kdb*.3elektra*
592 %{_mandir}/man3/key*.3elektra*
593 %{_mandir}/man3/meta.3elektra*
594 %{_mandir}/man3/plugin.3elektra*
595 %{_mandir}/man3/proposal.3elektra*
596 %{_mandir}/man3/proposal.c.3elektra*
597
598 %files static
599 %defattr(644,root,root,755)
600 %{_libdir}/libelektra-static.a
601 %{_libdir}/libelektratools-static.a
602
603 %files cpp-devel
604 %defattr(644,root,root,755)
605 %{_includedir}/elektra/*.hpp
606 %{_includedir}/elektra/helper
607 %{_includedir}/elektra/merging
608 # libelektratools API man pages
609 %{_mandir}/man3/automergeconfiguration.hpp.3elektra*
610 %{_mandir}/man3/automergestrategy.cpp.3elektra*
611 %{_mandir}/man3/automergestrategy.hpp.3elektra*
612 %{_mandir}/man3/comparison.cpp.3elektra*
613 %{_mandir}/man3/comparison.hpp.3elektra*
614 %{_mandir}/man3/backend.hpp.3elektra*
615 %{_mandir}/man3/backends.hpp.3elektra*
616 %{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
617 %{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
618 %{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
619 %{_mandir}/man3/mergeconfiguration.hpp.3elektra*
620 %{_mandir}/man3/mergeconflict.hpp.3elektra*
621 %{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
622 %{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
623 %{_mandir}/man3/mergeresult.cpp.3elektra*
624 %{_mandir}/man3/mergeresult.hpp.3elektra*
625 %{_mandir}/man3/mergetask.hpp.3elektra*
626 %{_mandir}/man3/mergetestutils.cpp.3elektra*
627 %{_mandir}/man3/metamergestrategy.cpp.3elektra*
628 %{_mandir}/man3/metamergestrategy.hpp.3elektra*
629 %{_mandir}/man3/newkeystrategy.cpp.3elektra*
630 %{_mandir}/man3/newkeystrategy.hpp.3elektra*
631 %{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
632 %{_mandir}/man3/onesidestrategy.cpp.3elektra*
633 %{_mandir}/man3/onesidestrategy.hpp.3elektra*
634 %{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
635 %{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
636 %{_mandir}/man3/modules.cpp.3elektra*
637 %{_mandir}/man3/modules.hpp.3elektra*
638 %{_mandir}/man3/plugin.cpp.3elektra*
639 %{_mandir}/man3/plugin.hpp.3elektra*
640 %{_mandir}/man3/plugins.cpp.3elektra*
641 %{_mandir}/man3/plugins.hpp.3elektra*
642 %{_mandir}/man3/src_backend.cpp.3elektra*
643 %{_mandir}/man3/testtool_*.cpp.3elektra*
644 %{_mandir}/man3/threewaymerge.cpp.3elektra*
645 %{_mandir}/man3/threewaymerge.hpp.3elektra*
646 %{_mandir}/man3/toolexcept.hpp.3elektra*
647
648 %if %{with glib}
649 %files glib
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/libgelektra-4.0.so
652 %{_libdir}/girepository-1.0/GElektra-4.0.typelib
653
654 %files glib-devel
655 %defattr(644,root,root,755)
656 %{_datadir}/gir-1.0/GElektra-4.0.gir
657 %{_includedir}/elektra/gelektra-*.h
658 %{_pkgconfigdir}/gelektra-4.0.pc
659 %endif
660
661 %if %{with java}
662 %files -n java-elektra
663 %defattr(644,root,root,755)
664 %{_javadir}/libelektra-1.jar
665 %{_javadir}/libelektra.jar
666 %endif
667
668 %if %{with lua}
669 %files -n lua-elektra
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
672
673 %if %{with glib}
674 %files -n lua-elektra-glib
675 %defattr(644,root,root,755)
676 %dir %{_datadir}/lua/5.2/lgi
677 %dir %{_datadir}/lua/5.2/lgi/override
678 %{_datadir}/lua/5.2/lgi/override/GElektra.lua
679 %endif
680 %endif
681
682 %if %{with python2}
683 %files -n python-elektra
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{py_sitedir}/_kdb.so
686 %{py_sitedir}/kdb.py[co]
687 %endif
688
689 %if %{with python3}
690 %files -n python3-elektra
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{py3_sitedir}/_kdb.so
693 %{py3_sitedir}/kdb.py
694 %{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
695
696 %if %{with glib}
697 %files -n python3-elektra-glib
698 %defattr(644,root,root,755)
699 %{py3_sitedir}/gi/overrides/GElektra.py
700 %{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
701 %endif
702 %endif
This page took 0.06368 seconds and 3 git commands to generate.