]> git.pld-linux.org Git - packages/elektra.git/blame_incremental - elektra.spec
- tool_exec dir is LIB_SUFFIX aware now
[packages/elektra.git] / elektra.spec
... / ...
CommitLineData
1# TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
2#
3# Conditonal build:
4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
5%bcond_with java # Java support: JNA binding and JNI plugin (needs Java 8)
6%bcond_without glib # GLib/GObject binding
7%bcond_without lua # Lua (5.2) support: binding and plugin
8%bcond_without python2 # Python 2 support: binding and plugin
9%bcond_without python3 # Python 3 support: binding and plugin
10%bcond_without qt # Qt GUI
11#
12Summary: A key/value pair database to store software configurations
13Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
14Name: elektra
15Version: 0.8.14
16Release: 1
17License: BSD
18Group: Applications/System
19Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
20# Source0-md5: a87cd3845e590bf413959dfd555e3704
21Patch0: %{name}-elektraenv.patch
22Patch1: %{name}-no-markdown.patch
23Patch2: %{name}-no-deb.patch
24URL: http://www.libelektra.org/
25%if %{with qt}
26BuildRequires: Qt5Core-devel >= 5
27BuildRequires: Qt5Gui-devel >= 5
28BuildRequires: Qt5Qml-devel >= 5
29BuildRequires: Qt5Quick-devel >= 5
30BuildRequires: Qt5Widgets-devel >= 5
31BuildRequires: Qt5Test-devel >= 5
32%endif
33BuildRequires: augeas-devel >= 1.0
34BuildRequires: boost-devel
35BuildRequires: cmake >= 2.8.8
36BuildRequires: dbus-devel
37BuildRequires: doxygen
38BuildRequires: gettext-tools
39%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
40%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
41%{?with_java:BuildRequires: java-jna}
42%{?with_java:BuildRequires: jdk >= 1.8}
43BuildRequires: libgcrypt-devel
44%{?with_qt:BuildRequires: libmarkdown-devel}
45BuildRequires: libstdc++-devel
46BuildRequires: libxml2-devel >= 2.0
47BuildRequires: libxslt-progs
48%{?with_lua:BuildRequires: lua52-devel >= 5.2}
49BuildRequires: pkgconfig
50%{?with_python2:BuildRequires: python-devel >= 1:2.7}
51%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
52BuildRequires: rpm-pythonprov
53BuildRequires: rpmbuild(macros) >= 1.612
54BuildRequires: swig >= 2
55%if %{with python2} || %{with python3}
56BuildRequires: swig-python >= 2
57%endif
58BuildRequires: systemd-devel
59BuildRequires: tcl-devel
60BuildRequires: yajl-devel
61Requires: %{name}-libs = %{version}-%{release}
62Requires: mktemp
63Obsoletes: registry
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%description
67The Elektra Project provides a framework to store generic
68configuration data in an hierarchical key-value pair database, instead
69of a human-readable only text file.
70
71This way any software can read/save his configuration using a
72consistent API. Also, applications can be aware of other applications
73configurations, leveraging easy application integration.
74
75%description -l pl.UTF-8
76Projekt Elektra dostarcza szkielet do przechowywania typowych danych
77konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
78danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
79
80W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
81pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
82konfiguracji innych aplikacji, ułatwiając ich integrację.
83
84%package gui
85Summary: Qt based GUI for Elektra
86Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
87Group: X11/Applications
88Requires: %{name} = %{version}-%{release}
89
90%description gui
91Qt based GUI for Elektra.
92
93%description gui -l pl.UTF-8
94Oparty na Qt graficzny interfejs do Elektry.
95
96%package -n bash-completion-elektra
97Summary: Bash completion for Elektra commands
98Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
99Group: Applications/Shells
100Requires: %{name} = %{version}-%{release}
101Requires: bash-completion
102
103%description -n bash-completion-elektra
104Bash completion for Elektra kdb command.
105
106%description -n bash-completion-elektra -l pl.UTF-8
107Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
108
109%package libs
110Summary: Elektra Project libraries
111Summary(pl.UTF-8): Biblioteki projektu Elektra
112Group: Libraries
113Obsoletes: elektra-cpp < 0.8
114Conflicts: elektra < 0.7
115
116%description libs
117The Elektra Project provides a framework to store generic
118configuration data in an hierarchical key-value pair database, instead
119of a human-readable only text file.
120
121This way any software can read/save his configuration using a
122consistent API. Also, applications can be aware of other applications
123configurations, leveraging easy application integration.
124
125This package contains Elektra shared libraries.
126
127%description libs -l pl.UTF-8
128Projekt Elektra dostarcza szkielet do przechowywania typowych danych
129konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
130danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
131
132W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
133pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
134konfiguracji innych aplikacji, ułatwiając ich integrację.
135
136Ten pakiet zawiera biblioteki współdzielone Elektry.
137
138%package devel
139Summary: Include files and API documentation for Elektra Project
140Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
141Group: Development/Libraries
142Requires: %{name}-libs = %{version}-%{release}
143
144%description devel
145This package contains the include files and API manual pages to use
146the Elektra API in C.
147
148%description devel -l pl.UTF-8
149Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
150systemowego opisującego sposób użycia API Elektry w C.
151
152%package static
153Summary: Static libraries for Elektra Project
154Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
155Group: Development/Libraries
156Requires: %{name}-devel = %{version}-%{release}
157
158%description static
159This package contains static libraries for Elektra Project.
160
161%description static -l pl.UTF-8
162Ten pakiet zawiera statyczne biblioteki projektu Elektra.
163
164%package cpp-devel
165Summary: Header files of C++ interface for Elektra library
166Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
167Group: Development/Libraries
168Requires: %{name}-devel = %{version}-%{release}
169Requires: libstdc++-devel
170Obsoletes: elektra-cpp-static < 0.8
171
172%description cpp-devel
173Header files of C++ interface for Elektra library.
174
175%description cpp-devel -l pl.UTF-8
176Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
177
178%package glib
179Summary: GLib/GObject binding for Elektra
180Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
181Group: Libraries
182Requires: %{name}-libs = %{version}-%{release}
183Requires: glib2 >= 1:2.36
184
185%description glib
186GLib/GObject binding for Elektra.
187
188%description glib -l pl.UTF-8
189Wiązanie GLib/GObject do Elektry.
190
191%package glib-devel
192Summary: GLib/GObject binding for Elektra - development files
193Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
194Group: Libraries
195Requires: %{name}-devel = %{version}-%{release}
196Requires: glib2-devel >= 1:2.36
197
198%description glib-devel
199GLib/GObject binding for Elektra - development files.
200
201%description glib-devel -l pl.UTF-8
202Wiązanie GLib/GObject do Elektry - pliki programistyczne.
203
204%package -n lua-elektra
205Summary: Lua binding for Elektra
206Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
207Group: Libraries
208Requires: %{name}-libs = %{version}-%{release}
209Requires: lua52-libs >= 5.2
210
211%description -n lua-elektra
212Lua binding for Elektra.
213
214%description -n lua-elektra -l pl.UTF-8
215Wiązanie języka Lua dla Elektry.
216
217%package -n lua-elektra-glib
218Summary: Lua/GI binding for Elektra
219Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
220Group: Libraries
221Requires: %{name}-glib = %{version}-%{release}
222Requires: lua52-libs >= 5.2
223#R: lua52-lgi ?
224
225%description -n lua-elektra-glib
226Lua/GI binding for Elektra.
227
228%description -n lua-elektra-glib -l pl.UTF-8
229Wiązanie Lua/GI dla Elektry.
230
231%package -n python-elektra
232Summary: Python 2 binding for Elektra
233Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
234Group: Libraries
235Requires: %{name}-libs = %{version}-%{release}
236Requires: python-libs >= 1:2.7
237
238%description -n python-elektra
239Python 2 binding for Elektra.
240
241%description -n python-elektra -l pl.UTF-8
242Wiązanie Pythona 2 dla Elektry.
243
244%package -n python3-elektra
245Summary: Python 3 binding for Elektra
246Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
247Group: Libraries
248Requires: %{name}-libs = %{version}-%{release}
249Requires: python3-libs >= 1:3.2
250
251%description -n python3-elektra
252Python 3 binding for Elektra.
253
254%description -n python3-elektra -l pl.UTF-8
255Wiązanie Pythona 3 dla Elektry.
256
257%package -n python3-elektra-glib
258Summary: Python 3 GI binding for Elektra
259Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
260Group: Libraries
261Requires: %{name}-glib = %{version}-%{release}
262Requires: python3-pygobject3 >= 3
263
264%description -n python3-elektra-glib
265Python 3 GI binding for Elektra.
266
267%description -n python3-elektra-glib -l pl.UTF-8
268Wiązanie Pythona 3 GI dla Elektry.
269
270%prep
271%setup -q
272%patch0 -p1
273%patch1 -p1
274%patch2 -p1
275
276%build
277install -d build
278cd build
279%cmake .. \
280 -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
281 %{!?with_full:-DBUILD_FULL=OFF} \
282 -DINSTALL_TESTING=FALSE \
283 -DPLUGINS=ALL \
284 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
285 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}"
286
287%{__make} -j1
288
289%install
290rm -rf $RPM_BUILD_ROOT
291install -d $RPM_BUILD_ROOT/etc/sysconfig
292
293%{__make} -C build install \
294 DESTDIR=$RPM_BUILD_ROOT
295
296%{__mv} $RPM_BUILD_ROOT/etc/profile.d/{kdb,kdb.sh}
297echo 'RUN="no"' > $RPM_BUILD_ROOT/etc/sysconfig/elektra
298install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
299
300%if %{with python2}
301%py_comp $RPM_BUILD_ROOT%{py_sitedir}
302%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
303%py_postclean
304%endif
305
306%if %{with python3}
307%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
308%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
309%endif
310
311# "static" variant (with libelektra-static and thus all plugins linked in);
312# we don't need it
313%{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
314
315%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/elektra/test_data
316
317# prepare docs
318%{__rm} -rf installed-doc
319install -d installed-doc
320%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
321
322%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,src_plugins_*_md}.3elektra
323
324%clean
325rm -rf $RPM_BUILD_ROOT
326
327%post libs -p /sbin/ldconfig
328%postun libs -p /sbin/ldconfig
329
330%post glib -p /sbin/ldconfig
331%postun glib -p /sbin/ldconfig
332
333%files
334%defattr(644,root,root,755)
335%doc doc/{AUTHORS,COPYING,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
336# doc/standards installed-doc/scripts
337%attr(755,root,root) %{_bindir}/kdb
338%if %{with full}
339%attr(755,root,root) %{_bindir}/kdb-full
340%endif
341%dir %{_libdir}/elektra
342# R: augeas-libs
343%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
344%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
345%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
346%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
347%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
348# R: libgcrypt
349%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto.so
350%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
351# R: dbus
352%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
353%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
354%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
355%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
356%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
357%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
358%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
359%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
360%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
361%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
362%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
363%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
364# uses internal inih library
365%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
366# R: systemd-libs
367%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
368%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
369%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
370%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
371%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
372%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
373%if %{with lua}
374# R: lua52-libs
375%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
376%endif
377%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
378%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
379%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
380# uses internal nickel library
381%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
382%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
383%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
384%if %{with python2}
385# R: python-libs
386%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
387%endif
388%if %{with python3}
389# R: python3-libs
390%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
391%endif
392%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
393%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
394%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
395%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
396%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
397%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
398%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
399%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
400%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
401%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
402%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
403%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
404%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
405%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
406%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
407%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
408# R: libxml2
409%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
410# R: yajl
411%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
412%dir %{_libdir}/elektra/tool_exec
413%attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
414%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
415%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
416%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
417%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
418%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
419%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
420%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
421%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
422%attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
423%attr(755,root,root) %{_libdir}/elektra/tool_exec/getenv
424%attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
425%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
426%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
427%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
428%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
429%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-spec
430%attr(755,root,root) %{_libdir}/elektra/tool_exec/race
431%attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
432
433%attr(755,root,root) /etc/profile.d/kdb.sh
434%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/elektra
435%{_datadir}/sgml/elektra
436
437%if 0
438%files gen ?
439%defattr(644,root,root,755)
440%attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
441%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
442# FIXME: should be in elektra_gen subdir
443%{py_sitescriptdir}/support
444%{_datadir}/elektra/templates
445%endif
446
447%files gui
448%defattr(644,root,root,755)
449%attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
450
451%files -n bash-completion-elektra
452%defattr(644,root,root,755)
453/etc/bash_completion.d/kdb
454
455%files libs
456%defattr(644,root,root,755)
457%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
458%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
459%attr(755,root,root) %{_libdir}/libelektragetenv.so
460%attr(755,root,root) %{_libdir}/libelektratools.so
461%if %{with full}
462%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
463%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
464%endif
465
466%files devel
467%defattr(644,root,root,755)
468%doc doc/API.md installed-doc/elektra-api/html
469%attr(755,root,root) %{_libdir}/libelektra.so
470%if %{with full}
471%attr(755,root,root) %{_libdir}/libelektra-full.so
472%endif
473%dir %{_includedir}/elektra
474%{_includedir}/elektra/crypto_internal.h
475%{_includedir}/elektra/kdb*.h
476%{_pkgconfigdir}/elektra.pc
477%{_datadir}/cmake/Modules/ElektraConfig*.cmake
478%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
479%{_mandir}/man3/api.3elektra*
480%{_mandir}/man3/deprecated.3elektra*
481%{_mandir}/man3/kdb*.3elektra*
482%{_mandir}/man3/key*.3elektra*
483%{_mandir}/man3/meta.3elektra*
484%{_mandir}/man3/plugin.3elektra*
485%{_mandir}/man3/proposal.3elektra*
486%{_mandir}/man3/proposal.c.3elektra*
487
488%files static
489%defattr(644,root,root,755)
490%{_libdir}/libelektra-static.a
491%{_libdir}/libelektratools-static.a
492
493%files cpp-devel
494%defattr(644,root,root,755)
495%{_includedir}/elektra/*.hpp
496%{_includedir}/elektra/helper
497%{_includedir}/elektra/merging
498# libelektratools API man pages
499%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
500%{_mandir}/man3/automergestrategy.cpp.3elektra*
501%{_mandir}/man3/automergestrategy.hpp.3elektra*
502%{_mandir}/man3/comparison.cpp.3elektra*
503%{_mandir}/man3/comparison.hpp.3elektra*
504%{_mandir}/man3/backend.hpp.3elektra*
505%{_mandir}/man3/backends.hpp.3elektra*
506%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
507%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
508%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
509%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
510%{_mandir}/man3/mergeconflict.hpp.3elektra*
511%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
512%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
513%{_mandir}/man3/mergeresult.cpp.3elektra*
514%{_mandir}/man3/mergeresult.hpp.3elektra*
515%{_mandir}/man3/mergetask.hpp.3elektra*
516%{_mandir}/man3/mergetestutils.cpp.3elektra*
517%{_mandir}/man3/metamergestrategy.cpp.3elektra*
518%{_mandir}/man3/metamergestrategy.hpp.3elektra*
519%{_mandir}/man3/newkeystrategy.cpp.3elektra*
520%{_mandir}/man3/newkeystrategy.hpp.3elektra*
521%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
522%{_mandir}/man3/onesidestrategy.cpp.3elektra*
523%{_mandir}/man3/onesidestrategy.hpp.3elektra*
524%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
525%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
526%{_mandir}/man3/modules.cpp.3elektra*
527%{_mandir}/man3/modules.hpp.3elektra*
528%{_mandir}/man3/plugin.cpp.3elektra*
529%{_mandir}/man3/plugin.hpp.3elektra*
530%{_mandir}/man3/plugins.cpp.3elektra*
531%{_mandir}/man3/plugins.hpp.3elektra*
532%{_mandir}/man3/src_backend.cpp.3elektra*
533%{_mandir}/man3/testtool_*.cpp.3elektra*
534%{_mandir}/man3/threewaymerge.cpp.3elektra*
535%{_mandir}/man3/threewaymerge.hpp.3elektra*
536%{_mandir}/man3/toolexcept.hpp.3elektra*
537
538%if %{with glib}
539%files glib
540%defattr(644,root,root,755)
541%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
542%{_libdir}/girepository-1.0/GElektra-4.0.typelib
543
544%files glib-devel
545%defattr(644,root,root,755)
546%{_datadir}/gir-1.0/GElektra-4.0.gir
547%{_includedir}/elektra/gelektra-*.h
548%{_pkgconfigdir}/gelektra-4.0.pc
549%endif
550
551%if %{with lua}
552%files -n lua-elektra
553%defattr(644,root,root,755)
554%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
555
556%if %{with glib}
557%files -n lua-elektra-glib
558%defattr(644,root,root,755)
559%dir %{_datadir}/lua/5.2/lgi
560%dir %{_datadir}/lua/5.2/lgi/override
561%{_datadir}/lua/5.2/lgi/override/GElektra.lua
562%endif
563%endif
564
565%if %{with python2}
566%files -n python-elektra
567%defattr(644,root,root,755)
568%attr(755,root,root) %{py_sitedir}/_kdb.so
569%{py_sitedir}/kdb.py[co]
570%endif
571
572%if %{with python3}
573%files -n python3-elektra
574%defattr(644,root,root,755)
575%attr(755,root,root) %{py3_sitedir}/_kdb.so
576%{py3_sitedir}/kdb.py
577%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
578
579%if %{with glib}
580%files -n python3-elektra-glib
581%defattr(644,root,root,755)
582%{py3_sitedir}/gi/overrides/GElektra.py
583%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
584%endif
585%endif
This page took 0.108399 seconds and 4 git commands to generate.