]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
- Adjusted BR
[packages/ekg2.git] / ekg2.spec
1 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
2                                         # (must use ./builder -n5 or plain rpmbuild)
3 %bcond_with     aspell                  # Build in spell-checking support with aspell
4                                         # (currently leaks memory)
5
6 %if %{with yesterday_snapshot}
7 %define         _snap %(date +%%Y%%m%%d -d yesterday)
8 %else
9 %define         _snap 20040706
10 %endif
11
12 Summary:        A client compatible with Gadu-Gadu
13 Summary(de):    Einen client kompatibel zu Gadu-Gadu
14 Summary(it):    Esperimentale cliente di Gadu-Gadu
15 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
16 Name:           ekg2
17 Version:        2.0
18 Release:        0.%{_snap}.1
19 License:        GPL v2+
20 Group:          Applications/Communications
21 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
22 # Source0-md5:  94136ee525ad5a5becce4e40f639f9d0
23 URL:            http://www.ekg2.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  libgadu-devel
27 BuildRequires:  libtool
28 BuildRequires:  libltdl-devel
29 BuildRequires:  libgsm-devel
30 BuildRequires:  ncurses-devel
31 BuildRequires:  openssl-devel >= 0.9.7d
32 %if %{with aspell}
33 BuildRequires:  aspell-devel
34 %endif
35 BuildRequires:  gpm-devel
36 BuildRequires:  gnutls-devel
37 BuildRequires:  expat-devel
38 BuildRequires:  libjpeg-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A client compatible with Gadu-Gadu and Jabber.
43
44 %description -l de
45 Einen client kompatibel zu Gadu-Gadu und Jabber.
46
47 %description -l it
48 Esperimentale cliente di Gadu-Gadu.
49
50 %description -l pl
51 Eksperymentalny Klient Gadu-Gadu. W wersji 2.0 obs³uguje zarówno
52 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
53
54 %prep
55 %setup -q -n %{name}-%{_snap}
56
57 %build
58 %{__libtoolize} --ltdl
59 %{__aclocal} -I m4
60 %{__autoconf}
61 %{__autoheader}
62 %{__automake}
63 %configure \
64         %{!?_with_aspell:--without-aspell} %{?_with_aspell:--with-aspell}
65 echo '#define HAVE_GNUTLS 1' >> ekg2-config.h # KLUDGE, wait for autoconf update
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72 rm -rf docs/{CVS,.cvsignore,Makefile*}
73 mv README README-main
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc NEWS* README-main docs/*
81 %attr(755,root,root) %{_bindir}/*
82 %dir %{_libdir}/ekg2
83 %dir %{_libdir}/ekg2/plugins
84 %attr(755,root,root) %{_libdir}/ekg2/plugins/*.so
85 %{?_with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
This page took 0.224181 seconds and 4 git commands to generate.