]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
- cosmetics
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_without  aspell                  # Don't build in spell-checking support with aspell
6 %bcond_with     ioctl_daemon            # With (suid-root) ioctl daemon
7
8 %if %{with yesterday_snapshot}
9 %define         _snap %(date +%%Y%%m%%d -d yesterday)
10 %else
11 %define         _snap 20041229
12 %endif
13
14 Summary:        A client compatible with Gadu-Gadu
15 Summary(de):    Einen client kompatibel zu Gadu-Gadu
16 Summary(it):    Esperimentale cliente di Gadu-Gadu
17 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
18 Name:           ekg2
19 Version:        2.0
20 Release:        0.%{_snap}.1
21 License:        GPL v2+
22 Group:          Applications/Communications
23 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
24 # Source0-md5:  2d0309616a1bf969dfa91fd2797a6aa2
25 URL:            http://www.ekg2.org/
26 %{?with_aspell:BuildRequires:   aspell-devel}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  expat-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  gnutls-devel >= 1.0.0
32 BuildRequires:  gpm-devel
33 BuildRequires:  libgadu-devel
34 BuildRequires:  libgsm-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libltdl-devel
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openssl-devel >= 0.9.7d
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  xosd-devel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A client compatible with Gadu-Gadu and Jabber.
46
47 %description -l de
48 Einen client kompatibel zu Gadu-Gadu und Jabber.
49
50 %description -l it
51 Esperimentale cliente di Gadu-Gadu.
52
53 %description -l pl
54 Eksperymentalny Klient Gadu-Gadu. W wersji drugiej obs³uguje zarówno
55 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
56
57 %package plugin-xosd
58 Summary:        xosd plugin for ekg2
59 Summary(pl):    Wtyczka xosd dla ekg2
60 Group:          Applications/Communications
61 Requires:       %{name} = %{version}-%{release}
62
63 %description plugin-xosd
64 xosd plugin for ekg2.
65
66 %description plugin-xosd -l pl
67 Wtyczka xosd dla ekg2.
68
69 %prep
70 %setup -q -n %{name}-%{_snap}
71 sed -i -e 's/AC_LIBLTDL_CONVENIENCE/AC_LIBLTDL_INSTALLABLE/' configure.ac
72
73 %build
74 %{__libtoolize} --ltdl
75 cd libltdl
76 %{__aclocal}
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 cd ..
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --with%{!?with_aspell:out}-aspell
87         
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95 %{!?with_ioctl_daemon:rm $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/ioctld.*}
96
97 rm -rf docs/{CVS,.cvsignore,Makefile*}
98 mv -f README README-main
99
100 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files -f %{name}.lang
108 %defattr(644,root,root,755)
109 %doc NEWS* README-main docs/*
110 %attr(755,root,root) %{_bindir}/*
111 %dir %{_libdir}/%{name}
112 %dir %{_libdir}/%{name}/plugins
113 %attr(755,root,root) %{_libdir}/%{name}/plugins/[!x]*.so
114 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
115 %dir %{_datadir}/%{name}
116 %{_datadir}/%{name}/[!p]*
117 %dir %{_datadir}/%{name}/plugins
118 %{_datadir}/%{name}/plugins/[!x]*
119
120 %files plugin-xosd
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/%{name}/plugins/xosd.so
123 %{_datadir}/%{name}/plugins/xosd
This page took 0.068974 seconds and 3 git commands to generate.