]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
8bae6ceb81a0427bf789eee5016c4f5dbc08d757
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_without  aspell                  # Don't build in spell-checking support with aspell
6 %bcond_with     ioctl_daemon            # With (suid-root) ioctl daemon
7
8 %if %{with yesterday_snapshot}
9 %define         _snap %(date +%%Y%%m%%d -d yesterday)
10 %else
11 %define         _snap 20040902
12 %endif
13
14 Summary:        A client compatible with Gadu-Gadu
15 Summary(de):    Einen client kompatibel zu Gadu-Gadu
16 Summary(it):    Esperimentale cliente di Gadu-Gadu
17 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
18 Name:           ekg2
19 Version:        2.0
20 Release:        0.%{_snap}.1
21 License:        GPL v2+
22 Group:          Applications/Communications
23 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
24 # Source0-md5:  d12e86bff3876f8be4969c008cae4058
25 URL:            http://www.ekg2.org/
26 BuildRequires:  automake
27 BuildRequires:  libgadu-devel
28 BuildRequires:  libgsm-devel
29 BuildRequires:  ncurses-devel
30 BuildRequires:  openssl-devel >= 0.9.7d
31 BuildRequires:  gpm-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  gcc-c++
35 BuildRequires:  autoconf
36 BuildRequires:  gettext-devel
37 BuildRequires:  libstdc++-devel
38 %{?with_aspell:BuildRequires:   aspell-devel}
39 BuildRequires:  gnutls-devel
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 A client compatible with Gadu-Gadu and Jabber.
44
45 %description -l de
46 Einen client kompatibel zu Gadu-Gadu und Jabber.
47
48 %description -l it
49 Esperimentale cliente di Gadu-Gadu.
50
51 %description -l pl
52 Eksperymentalny Klient Gadu-Gadu. W wersji drugiej obs³uguje zarówno
53 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
54
55 %prep
56 %setup -q -n %{name}-%{_snap}
57
58 %build
59 cp -f /usr/share/automake/config.sub .
60 cp -f /usr/share/automake/config.sub libltdl/
61 %configure \
62         --with%{!?with_aspell:out}-aspell
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70 %{!?with_ioctl_daemon:rm $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/ioctld.*}
71
72 rm -rf docs/{CVS,.cvsignore,Makefile*}
73 mv -f README README-main
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc NEWS* README-main docs/*
81 %attr(755,root,root) %{_bindir}/*
82 %dir %{_libdir}/%{name}
83 %dir %{_libdir}/%{name}/plugins
84 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
85 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
86 %{_datadir}/%{name}
87 %{_datadir}/locale/*/LC_MESSAGES/%{name}.mo
This page took 0.190469 seconds and 2 git commands to generate.