]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- snap 20071225
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_without  pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 %bcond_with     lock_reason     # with lock_reason patch
9 %bcond_with     gtk             # with gtk frontend
10 #
11 Summary:        A client compatible with Gadu-Gadu
12 Summary(de.UTF-8):      Ein Cliente kompatibel mit Gadu-Gadu
13 Summary(es.UTF-8):      Un cliente compatible con Gadu-Gadu
14 Summary(it.UTF-8):      Un cliente compatibile con Gadu-Gadu
15 Summary(pl.UTF-8):      Klient kompatybilny z Gadu-Gadu
16 Name:           ekg
17 %define snap    20071225
18 Version:        1.7
19 Release:        4.%{snap}.1
20 Epoch:          4
21 License:        GPL v2
22 Group:          Applications/Communications
23 Source0:        http://ekg.chmurka.net/%{name}-%{snap}.tar.gz
24 # Source0-md5:  34b541bb6c58695dee2b9aea0a5d6d74
25 Source1:        %{name}.conf
26 Patch0:         %{name}-LDFLAGS.patch
27 Patch1:         %{name}-lock_reason.patch
28 Patch2:         %{name}-external_libgadu.patch
29 URL:            http://ekg.chmurka.net/
30 BuildRequires:  %{_bindir}/perl
31 %{?with_aspell:BuildRequires:   aspell-devel}
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 %{?with_gtk:BuildRequires: gtk+2-devel}
35 BuildRequires:  libgadu-devel >= 4:1.7.0
36 %{?with_voip:BuildRequires:     libgsm-devel}
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openssl-devel >= 0.9.7d
40 %if %{with python}
41 BuildRequires:  python
42 BuildRequires:  python-devel
43 %endif
44 BuildRequires:  readline-devel
45 BuildRequires:  zlib-devel
46 Requires:       libgadu >= 4:1.7.0
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
51 client for UNIX systems. Gadu-Gadu is an instant messaging program,
52 very popular in Poland.
53
54 EKG features include:
55   - irssi-like ncurses interface
56   - sending and receiving files
57   - voice conversations
58   - launching shell commands on certain events
59   - reading input from pipe
60   - python scripting support
61   - speech synthesis (using an external program)
62   - encryption support
63
64 Please note that the program is not internationalized and all messages
65 are in Polish (although the commands are in English).
66
67 %description -l de.UTF-8
68 Ein Cliente kompatibel mit Gadu-Gadu.
69
70 %description -l es.UTF-8
71 Un cliente compatible con Gadu-Gadu.
72
73 %description -l it.UTF-8
74 Un cliente compatibile con Gadu-Gadu.
75
76 %description -l pl.UTF-8
77 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
78 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
79 Polsce komunikator internetowy.
80
81 Możliwości EKG:
82   - interfejs użytkownika podobny do irssi,
83   - wysyłanie i odbieranie plików,
84   - rozmowy głosowe,
85   - uruchamianie poleceń powłoki w określonych sytuacjach,
86   - wczytywanie wejścia z potoku,
87   - wsparcie dla skryptów w języku Python,
88   - synteza mowy (z użyciem zewnętrznego programu),
89   - wsparcie dla szyfrowania.
90
91 Program nie jest umiędzynarodowiony i wszystkie komunikaty są po
92 polsku (jednak komendy są w języku angielskim).
93
94 %prep
95 %setup -q -n %{name}-%{snap}
96 %patch0 -p0
97 %if %{with lock_reason}
98 %patch1 -p1
99 %endif
100 %patch2 -p0
101
102 %build
103 %{__aclocal} -I m4
104 %{__autoheader}
105 %{__autoconf}
106 %configure \
107         CFLAGS_LIBGADU="%{rpmcflags}" \
108         --enable-dynamic \
109         --enable-shared \
110         --enable-static \
111 %if %{with pthread}
112         --with-pthread \
113 %else
114         --without-pthread \
115 %endif
116         --without-bind \
117         %{?with_python:--with-python} \
118         %{!?with_voip:--without-libgsm} \
119         %{?with_aspell:--enable-aspell} \
120         %{?with_ioctl_daemon:--enable-ioctld} \
121         %{?with_gtk:--enable-ui-gtk}
122
123 %{__make}
124
125 %if %{with ioctl_daemon}
126 %{__make} -C src ioctld
127 %endif
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT%{_sysconfdir}
132
133 %{__make} install install-ekl2 \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
137
138 # For libgadu-devel
139
140 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
141 rm -rf examples/CVS
142
143 %if %{with ioctl_daemon}
144 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
145 %endif
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
153 %{?with_aspell:%doc docs/slownik.txt}
154 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
155 %attr(755,root,root) %{_bindir}/e*
156 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
157 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
158 %{_datadir}/ekg
159 %{_mandir}/man1/*
160 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.648445 seconds and 3 git commands to generate.