]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- updated to 20050318 snap (a _lot_ of bugfixes since 1.5)
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_with             pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 #
9 %define         _snap   20050318
10 #
11 Summary:        A client compatible with Gadu-Gadu
12 Summary(de):    Ein Cliente kompatibel mit Gadu-Gadu
13 Summary(es):    Un cliente compatible con Gadu-Gadu
14 Summary(it):    Un cliente compatibile con Gadu-Gadu
15 Summary(pl):    Klient kompatybilny z Gadu-Gadu
16 Name:           ekg
17 Version:        1.5
18 Release:        6.%{_snap}.1
19 Epoch:          4
20 License:        GPL v2
21 Group:          Applications/Communications
22 Source0:        http://dev.null.pl/ekg/%{name}-%{_snap}.tar.gz
23 # Source0-md5:  a25337b88263f808d2044e3f3b33673c
24 Source1:        %{name}.conf
25 Patch0:         %{name}-kadu-0_3_6.patch
26 URL:            http://dev.null.pl/ekg/
27 %{?with_aspell:BuildRequires:   aspell-devel}
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 %{?with_voip:BuildRequires:     libgsm-devel}
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  ncurses-devel
33 BuildRequires:  openssl-devel >= 0.9.7d
34 BuildRequires:  %{_bindir}/perl
35 %{?with_python:BuildRequires:   python-devel}
36 BuildRequires:  readline-devel
37 BuildRequires:  zlib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A client compatible with Gadu-Gadu.
42
43 %description -l de
44 Ein Cliente kompatibel mit Gadu-Gadu.
45
46 %description -l es
47 Un cliente compatible con Gadu-Gadu.
48
49 %description -l it
50 Un cliente compatibile con Gadu-Gadu.
51
52 %description -l pl
53 Klient kompatybilny z Gadu-Gadu.
54
55 %package -n libgadu
56 Summary:        libgadu library
57 Summary(es):    Biblioteca libgadu
58 Summary(pl):    Biblioteka libgadu
59 License:        LGPL v2.1
60 Group:          Libraries
61 Obsoletes:      libgg
62
63 %description -n libgadu
64 libgadu is intended to make it easy to add Gadu-Gadu communication
65 support to your software.
66
67 %description -n libgadu -l de
68 Mit libgadu ist es Ihnen möglich auf einfache Weise Gadu-Gadu
69 Kommunikations-Unterstützung in Ihre Software einzubinden.
70
71 %description -n libgadu -l es
72 libgadu está pensada para facilitar añadirle comunicación vía
73 Gadu-Gadu a su software.
74
75 %description -n libgadu -l pl
76 libgadu umo¿liwia ³atwe dodanie do ró¿nych aplikacji komunikacji
77 bazuj±cej na protokole Gadu-Gadu.
78
79 %package -n libgadu-devel
80 Summary:        libgadu development library
81 Summary(es):    Biblioteca de desarrollo de libgadu
82 Summary(pl):    Czê¶æ biblioteki libgadu dla programistów
83 License:        LGPL v2.1
84 Group:          Development/Libraries
85 Requires:       libgadu = %{epoch}:%{version}-%{release}
86 Requires:       openssl-devel
87 Obsoletes:      libgg-devel
88
89 %description -n libgadu-devel
90 The libgadu-devel package contains the header files and some
91 documentation needed to develop application with libgadu.
92
93 %description -n libgadu-devel -l de
94 Das libgadu-devel Paket enthält Header-Files (Kopfzeilenordner) und
95 die Dokumentation die Sie benötigen um mit libgadu Anwendungen zu
96 entwickeln.
97
98 %description -n libgadu-devel -l es
99 El paquete libgadu-devel contiene los ficheros de cabecera, juntos con
100 una documentación, necesarios para desarrollar aplicaciones que usar
101 libgadu.
102
103 %description -n libgadu-devel -l pl
104 Pakiet libgadu-devel zawiera pliki nag³ówkowe i dokumentacjê,
105 potrzebne do kompilowania aplikacji korzystaj±cych z libgadu.
106
107 %package -n libgadu-static
108 Summary:        Static libgadu library
109 Summary(es):    Biblioteca libgadu estática
110 Summary(pl):    Statyczna biblioteka libgadu
111 License:        LGPL v2.1
112 Group:          Development/Libraries
113 Requires:       libgadu-devel = %{epoch}:%{version}-%{release}
114 Obsoletes:      libgg-static
115
116 %description -n libgadu-static
117 Static libgadu library.
118
119 %description -n libgadu-static -l de
120 Statisches libgadu Archiv.
121
122 %description -n libgadu-static -l es
123 Biblioteca libgadu estática.
124
125 %description -n libgadu-static -l pl
126 Statyczna biblioteka libgadu.
127
128 %prep
129 %setup -q -n %{name}-%{_snap}
130 #%patch0 -p1
131
132 %build
133 rm -f missing
134 %{__aclocal} -I m4
135 %{__autoheader}
136 %{__autoconf}
137 %configure \
138         --enable-shared \
139         --enable-static \
140 %if %{with pthread}
141         --with-pthread \
142 %else
143         --without-pthread \
144 %endif
145         --without-bind \
146         %{?with_python:--with-python} \
147         %{!?with_voip:--without-libgsm} \
148         %{?with_aspell:--enable-aspell} \
149         %{?with_ioctl_daemon:--enable-ioctld}
150
151 %{__make} \
152         CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
153
154 %if %{with ioctl_daemon}
155 %{__make} -C src ioctld
156 %endif
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT%{_sysconfdir}
161
162 %{__make} install install-ekl2 \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
166
167 # For libgadu-devel
168
169 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
170 rm -rf examples/CVS
171
172 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
173 cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
174
175 %if %{with ioctl_daemon}
176 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
177 %endif
178
179 cd $RPM_BUILD_ROOT%{_libdir}
180 ln -sf libgadu.so.*.* libgadu.so
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -n libgadu -p /sbin/ldconfig
186 %postun -n libgadu -p /sbin/ldconfig
187
188 %files
189 %defattr(644,root,root,755)
190 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
191 %{?with_aspell:%doc docs/slownik.txt}
192 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
193 %attr(755,root,root) %{_bindir}/e*
194 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
195 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
196 %{_datadir}/ekg
197 %{_mandir}/man1/*
198 %lang(pl) %{_mandir}/pl/man1/*
199
200 %files -n libgadu
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libgadu.so.*.*
203
204 %files -n libgadu-devel
205 %defattr(644,root,root,755)
206 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
207 %doc ChangeLog docs/{README,TODO}
208 %attr(755,root,root) %{_libdir}/libgadu.so
209 %{_includedir}/libgadu.h
210 %{_includedir}/libgadu-config.h
211 %{_pkgconfigdir}/*
212 %{_examplesdir}/libgadu-%{version}
213
214 %files -n libgadu-static
215 %defattr(644,root,root,755)
216 %{_libdir}/libgadu.a
This page took 0.092887 seconds and 3 git commands to generate.