]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- strict internal deps, cleanups
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_with     python          # with python support
6 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
7 #
8 Summary:        A client compatible with Gadu-Gadu
9 Summary(de):    Ein Cliente kompatibel mit Gadu-Gadu
10 Summary(es):    Un cliente compatible con Gadu-Gadu
11 Summary(it):    Un cliente compatibile con Gadu-Gadu
12 Summary(pl):    Klient kompatybilny z Gadu-Gadu
13 Name:           ekg
14 Version:        1.5
15 Release:        1
16 Epoch:          4
17 License:        GPL v2
18 Group:          Applications/Communications
19 Source0:        http://dev.null.pl/ekg/%{name}-%{version}.tar.gz
20 # Source0-md5:  721ebfe7b13e9531b30d558465e6695f
21 Source1:        %{name}.conf
22 Patch0:         %{name}-kadu-0_3_6.patch
23 URL:            http://dev.null.pl/ekg/
24 %{?with_aspell:BuildRequires:   aspell-devel}
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 %{?with_voip:BuildRequires:     libgsm-devel}
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  ncurses-devel
30 BuildRequires:  openssl-devel >= 0.9.7d
31 BuildRequires:  %{_bindir}/perl
32 %{?with_python:BuildRequires:   python-devel}
33 BuildRequires:  readline-devel
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A client compatible with Gadu-Gadu.
39
40 %description -l de
41 Ein Cliente kompatibel mit Gadu-Gadu.
42
43 %description -l es
44 Un cliente compatible con Gadu-Gadu.
45
46 %description -l it
47 Un cliente compatibile con Gadu-Gadu.
48
49 %description -l pl
50 Klient kompatybilny z Gadu-Gadu.
51
52 %package -n libgadu
53 Summary:        libgadu library
54 Summary(es):    Biblioteca libgadu
55 Summary(pl):    Biblioteka libgadu
56 License:        LGPL v2.1
57 Group:          Libraries
58 Obsoletes:      libgg
59
60 %description -n libgadu
61 libgadu is intended to make it easy to add Gadu-Gadu communication
62 support to your software.
63
64 %description -n libgadu -l de
65 Mit libgadu ist es Ihnen möglich auf einfache Weise Gadu-Gadu
66 Kommunikations-Unterstützung in Ihre Software einzubinden.
67
68 %description -n libgadu -l es
69 libgadu está pensada para facilitar añadirle comunicación vía
70 Gadu-Gadu a su software.
71
72 %description -n libgadu -l pl
73 libgadu umo¿liwia ³atwe dodanie do ró¿nych aplikacji komunikacji
74 bazuj±cej na protokole Gadu-Gadu.
75
76 %package -n libgadu-devel
77 Summary:        libgadu development library
78 Summary(es):    Biblioteca de desarrollo de libgadu
79 Summary(pl):    Czê¶æ biblioteki libgadu dla programistów
80 License:        LGPL v2.1
81 Group:          Development/Libraries
82 Requires:       libgadu = %{epoch}:%{version}-%{release}
83 Requires:       openssl-devel
84 Obsoletes:      libgg-devel
85
86 %description -n libgadu-devel
87 The libgadu-devel package contains the header files and some
88 documentation needed to develop application with libgadu.
89
90 %description -n libgadu-devel -l de
91 Das libgadu-devel Paket enthält Header-Files (Kopfzeilenordner) und
92 die Dokumentation die Sie benötigen um mit libgadu Anwendungen zu
93 entwickeln.
94
95 %description -n libgadu-devel -l es
96 El paquete libgadu-devel contiene los ficheros de cabecera, juntos con
97 una documentación, necesarios para desarrollar aplicaciones que usar
98 libgadu.
99
100 %description -n libgadu-devel -l pl
101 Pakiet libgadu-devel zawiera pliki nag³ówkowe i dokumentacjê,
102 potrzebne do kompilowania aplikacji korzystaj±cych z libgadu.
103
104 %package -n libgadu-static
105 Summary:        Static libgadu library
106 Summary(es):    Biblioteca libgadu estática
107 Summary(pl):    Statyczna biblioteka libgadu
108 License:        LGPL v2.1
109 Group:          Development/Libraries
110 Requires:       libgadu-devel = %{epoch}:%{version}-%{release}
111 Obsoletes:      libgg-static
112
113 %description -n libgadu-static
114 Static libgadu library.
115
116 %description -n libgadu-static -l de
117 Statisches libgadu Archiv.
118
119 %description -n libgadu-static -l es
120 Biblioteca libgadu estática.
121
122 %description -n libgadu-static -l pl
123 Statyczna biblioteka libgadu.
124
125 %prep
126 %setup -q
127 #%patch0 -p1
128
129 %build
130 sed -i -e 's/#define.*GG_LIBGADU_VERSION.*/#define GG_LIBGADU_VERSION "%{version}.%{snap}"/g' lib/libgadu.h
131
132 rm -f missing
133 %{__aclocal} -I m4
134 %{__autoheader}
135 %{__autoconf}
136 %configure \
137         --enable-shared \
138         --enable-static \
139         --with-pthread \
140         --without-bind \
141         %{?with_python:--with-python} \
142         %{!?with_voip:--without-libgsm} \
143         %{?with_aspell:--enable-aspell} \
144         %{!?with_ioctl_daemon:--disable-ioctld}
145
146 %{__make} \
147         CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
148
149 %if %{with ioctl_daemon}
150 %{__make} -C src ioctld
151 %endif
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155 install -d $RPM_BUILD_ROOT%{_sysconfdir}
156
157 %{__make} install install-ekl2 \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
161
162 # For libgadu-devel
163
164 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
165 rm -rf examples/CVS
166
167 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
168 cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
169
170 %if %{with ioctl_daemon}
171 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
172 %endif
173
174 cd $RPM_BUILD_ROOT%{_libdir}
175 ln -sf libgadu.so.*.* libgadu.so
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -n libgadu -p /sbin/ldconfig
181 %postun -n libgadu -p /sbin/ldconfig
182
183 %files
184 %defattr(644,root,root,755)
185 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
186 %{?with_aspell:%doc docs/slownik.txt}
187 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
188 %attr(755,root,root) %{_bindir}/e*
189 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
190 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
191 %{_datadir}/ekg
192 %{_mandir}/man1/*
193 %lang(pl) %{_mandir}/pl/man1/*
194
195 %files -n libgadu
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libgadu.so.*.*
198
199 %files -n libgadu-devel
200 %defattr(644,root,root,755)
201 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
202 %doc ChangeLog docs/{README,TODO}
203 %attr(755,root,root) %{_libdir}/libgadu.so
204 %{_includedir}/libgadu.h
205 %{_includedir}/libgadu-config.h
206 %{_pkgconfigdir}/*
207 %{_examplesdir}/libgadu-%{version}
208
209 %files -n libgadu-static
210 %defattr(644,root,root,755)
211 %{_libdir}/libgadu.a
This page took 0.053974 seconds and 3 git commands to generate.