]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- ncurses rebuild
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_without  pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 %bcond_with     lock_reason     # with lock_reason patch
9 #
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de.UTF-8):      Ein Cliente kompatibel mit Gadu-Gadu
12 Summary(es.UTF-8):      Un cliente compatible con Gadu-Gadu
13 Summary(it.UTF-8):      Un cliente compatibile con Gadu-Gadu
14 Summary(pl.UTF-8):      Klient kompatybilny z Gadu-Gadu
15 Name:           ekg
16 Version:        1.7
17 Release:        12
18 Epoch:          4
19 License:        GPL v2
20 Group:          Applications/Communications
21 Source0:        http://ekg.chmurka.net/%{name}-%{version}.tar.gz
22 # Source0-md5:  2aa92b56517fdf09d75519a105772b74
23 Source1:        %{name}.conf
24 Patch0:         %{name}-LDFLAGS.patch
25 Patch1:         %{name}-lock_reason.patch
26 Patch2:         %{name}-external_libgadu.patch
27 URL:            http://ekg.chmurka.net/
28 BuildRequires:  %{_bindir}/perl
29 %{?with_aspell:BuildRequires:   aspell-devel}
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  libgadu-devel >= 4:1.7.0
33 %{?with_voip:BuildRequires:     libgsm-devel}
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  ncurses-devel
36 BuildRequires:  openssl-devel >= 0.9.7d
37 BuildRequires:  pkgconfig
38 %if %{with python}
39 BuildRequires:  python
40 BuildRequires:  python-devel
41 BuildRequires:  python-modules
42 %endif
43 BuildRequires:  readline-devel
44 BuildRequires:  zlib-devel
45 Requires:       libgadu >= 4:1.7.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
50 client for UNIX systems. Gadu-Gadu is an instant messaging program,
51 very popular in Poland.
52
53 EKG features include:
54   - irssi-like ncurses interface
55   - sending and receiving files
56   - voice conversations
57   - launching shell commands on certain events
58   - reading input from pipe
59   - python scripting support
60   - speech synthesis (using an external program)
61   - encryption support
62
63 Please note that the program is not internationalized and all messages
64 are in Polish (although the commands are in English).
65
66 %description -l de.UTF-8
67 Ein Cliente kompatibel mit Gadu-Gadu.
68
69 %description -l es.UTF-8
70 Un cliente compatible con Gadu-Gadu.
71
72 %description -l it.UTF-8
73 Un cliente compatibile con Gadu-Gadu.
74
75 %description -l pl.UTF-8
76 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
77 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
78 Polsce komunikator internetowy.
79
80 Możliwości EKG:
81   - interfejs użytkownika podobny do irssi,
82   - wysyłanie i odbieranie plików,
83   - rozmowy głosowe,
84   - uruchamianie poleceń powłoki w określonych sytuacjach,
85   - wczytywanie wejścia z potoku,
86   - wsparcie dla skryptów w języku Python,
87   - synteza mowy (z użyciem zewnętrznego programu),
88   - wsparcie dla szyfrowania.
89
90 Program nie jest umiędzynarodowiony i wszystkie komunikaty są po
91 polsku (jednak komendy są w języku angielskim).
92
93 %prep
94 %setup -q
95 %patch0 -p0
96 %if %{with lock_reason}
97 %patch1 -p1
98 %endif
99 %patch2 -p0
100
101 %build
102 %{__aclocal} -I m4
103 %{__autoheader}
104 %{__autoconf}
105 %configure \
106         CFLAGS_LIBGADU="%{rpmcflags}" \
107         --enable-dynamic \
108         --enable-shared \
109         --enable-static \
110 %if %{with pthread}
111         --with-pthread \
112 %else
113         --without-pthread \
114 %endif
115         --without-bind \
116         %{?with_python:--with-python} \
117         %{!?with_voip:--without-libgsm} \
118         %{?with_aspell:--enable-aspell} \
119         %{?with_ioctl_daemon:--enable-ioctld}
120
121 %{__make}
122
123 %if %{with ioctl_daemon}
124 %{__make} -C src ioctld
125 %endif
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_sysconfdir}
130
131 %{__make} install install-ekl2 \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
135
136 # For libgadu-devel
137
138 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
139 rm -rf examples/CVS
140
141 %if %{with ioctl_daemon}
142 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
143 %endif
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
151 %{?with_aspell:%doc docs/slownik.txt}
152 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
153 %attr(755,root,root) %{_bindir}/e*
154 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
155 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
156 %{_datadir}/ekg
157 %{_mandir}/man1/*
158 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.068793 seconds and 3 git commands to generate.