]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- keep versioned libgadu R
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_without  pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 %bcond_with     lock_reason     # with lock_reason patch
9 #
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de.UTF-8):      Ein Cliente kompatibel mit Gadu-Gadu
12 Summary(es.UTF-8):      Un cliente compatible con Gadu-Gadu
13 Summary(it.UTF-8):      Un cliente compatibile con Gadu-Gadu
14 Summary(pl.UTF-8):      Klient kompatybilny z Gadu-Gadu
15 Name:           ekg
16 Version:        1.7
17 Release:        4
18 Epoch:          4
19 License:        GPL v2
20 Group:          Applications/Communications
21 Source0:        http://ekg.chmurka.net/%{name}-%{version}.tar.gz
22 # Source0-md5:  2aa92b56517fdf09d75519a105772b74
23 Source1:        %{name}.conf
24 Patch0:         %{name}-LDFLAGS.patch
25 Patch1:         %{name}-lock_reason.patch
26 Patch2:         %{name}-external_libgadu.patch
27 URL:            http://ekg.chmurka.net/
28 BuildRequires:  %{_bindir}/perl
29 %{?with_aspell:BuildRequires:   aspell-devel}
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  libgadu-devel >= 4:1.7.0
33 %{?with_voip:BuildRequires:     libgsm-devel}
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  ncurses-devel
36 BuildRequires:  openssl-devel >= 0.9.7d
37 %if %{with python}
38 BuildRequires:  python
39 BuildRequires:  python-devel
40 %endif
41 BuildRequires:  readline-devel
42 BuildRequires:  zlib-devel
43 Requires:       libgadu >= 4:1.7.0
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
48 client for UNIX systems. Gadu-Gadu is an instant messaging program,
49 very popular in Poland.
50
51 EKG features include:
52   - irssi-like ncurses interface
53   - sending and receiving files
54   - voice conversations
55   - launching shell commands on certain events
56   - reading input from pipe
57   - python scripting support
58   - speech synthesis (using an external program)
59   - encryption support
60
61 Please note that the program is not internationalized and all messages
62 are in Polish (although the commands are in English).
63
64 %description -l de.UTF-8
65 Ein Cliente kompatibel mit Gadu-Gadu.
66
67 %description -l es.UTF-8
68 Un cliente compatible con Gadu-Gadu.
69
70 %description -l it.UTF-8
71 Un cliente compatibile con Gadu-Gadu.
72
73 %description -l pl.UTF-8
74 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
75 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
76 Polsce komunikator internetowy.
77
78 Możliwości EKG:
79   - interfejs użytkownika podobny do irssi,
80   - wysyłanie i odbieranie plików,
81   - rozmowy głosowe,
82   - uruchamianie poleceń powłoki w określonych sytuacjach,
83   - wczytywanie wejścia z potoku,
84   - wsparcie dla skryptów w języku Python,
85   - synteza mowy (z użyciem zewnętrznego programu),
86   - wsparcie dla szyfrowania.
87
88 Program nie jest umiędzynarodowiony i wszystkie komunikaty są po
89 polsku (jednak komendy są w języku angielskim).
90
91 %prep
92 %setup -q
93 %patch0 -p0
94 %if %{with lock_reason}
95 %patch1 -p1
96 %endif
97 %patch2 -p0
98
99 %build
100 %{__aclocal} -I m4
101 %{__autoheader}
102 %{__autoconf}
103 %configure \
104         CFLAGS_LIBGADU="%{rpmcflags}" \
105         --enable-dynamic \
106         --enable-shared \
107         --enable-static \
108 %if %{with pthread}
109         --with-pthread \
110 %else
111         --without-pthread \
112 %endif
113         --without-bind \
114         %{?with_python:--with-python} \
115         %{!?with_voip:--without-libgsm} \
116         %{?with_aspell:--enable-aspell} \
117         %{?with_ioctl_daemon:--enable-ioctld}
118
119 %{__make}
120
121 %if %{with ioctl_daemon}
122 %{__make} -C src ioctld
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_sysconfdir}
128
129 %{__make} install install-ekl2 \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
133
134 # For libgadu-devel
135
136 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
137 rm -rf examples/CVS
138
139 %if %{with ioctl_daemon}
140 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
141 %endif
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
149 %{?with_aspell:%doc docs/slownik.txt}
150 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
151 %attr(755,root,root) %{_bindir}/e*
152 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
153 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
154 %{_datadir}/ekg
155 %{_mandir}/man1/*
156 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.099487 seconds and 3 git commands to generate.