]> git.pld-linux.org Git - packages/ejabberd.git/commitdiff
Version: 13.10 (not finished yet)
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 14 Nov 2013 09:53:21 +0000 (10:53 +0100)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 14 Nov 2013 09:59:30 +0000 (10:59 +0100)
– mod_logdb disabled (not available for this version)
- vcard-access-get.patch dropped, upgrade blocked if it was used in
  ejabberd.cfg
– pgsql support included upstream, no need for external module

ejabberd-config.patch [deleted file]
ejabberd-makefile.patch
ejabberd-mod_muc.patch [deleted file]
ejabberd-pack_deps.sh [new file with mode: 0755]
ejabberd.spec

diff --git a/ejabberd-config.patch b/ejabberd-config.patch
deleted file mode 100644 (file)
index f04f706..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
---- ejabberd-2.0.0/src/ejabberd.cfg.example.orig       2008-02-21 11:02:12.000000000 +0100
-+++ ejabberd-2.0.0/src/ejabberd.cfg.example    2008-02-22 14:57:55.000000000 +0100
-@@ -2,6 +2,12 @@
- %%%               ejabberd configuration file
- %%%
-+%%% This is a setup for working "localhost" server.
-+%%% To make fully functional world-accessible Jabber server you will need to:
-+%%% - change 'localhost' everywhere below to your desired Jabber server domain name
-+%%% - provide SSL certificates and uncomment ssl settings
-+%%% - modify everything else according to your needs
-+
- %%% The parameters used in this configuration file are explained in more detail
- %%% in the ejabberd Installation and Operation Guide.
- %%% Please consult the Guide in case of doubts, it is included in 
-@@ -155,6 +155,17 @@
-   %%                      }
-   %%                     ]},
-+  %%To enable more than one you _must_ change port numbers (here and in service's config)
-+  %% {5347, ejabberd_service, [{access, all},
-+  %%                   {hosts, ["icq.localhost", "sms.localhost"],
-+  %%                   [{password, ">secret<"}]}]},
-+  %% {5347, ejabberd_service, [{access, all},
-+  %%                   {host, "gg.localhost",
-+  %%                   [{password, ">secret<"}]}]},
-+  %% {5347, ejabberd_service, [{access, all},
-+  %%                   {hosts, ["ircnet.localhost", "freenode.localhost"],
-+  %%                    [{password, ">secret<"}]}]},
-+
-   {5280, ejabberd_http, [
-                        %%{request_handlers,
-                        %% [
-@@ -391,9 +391,9 @@
- %% All users are allowed to use MUC service:
- {access, muc, [{allow, all}]}.
--%% In-band registration allows registration of any possible username.
--%% To disable in-band registration, replace 'allow' with 'deny'.
--{access, register, [{allow, all}]}.
-+%% In-band registration disabled.
-+%% To enable  in-band registration, replace 'deny' with 'allow'.
-+{access, register, [{deny, all}]}.
- %% Everybody can create pubsub nodes
- {access, pubsub_createnode, [{allow, all}]}.
index 2e540e2b9179204f83c81b849e52c13c652bfcbd..e651140c5337bb29a305d113ddab606d06611ed6 100644 (file)
@@ -1,6 +1,7 @@
---- ejabberd-2.0.0/src/Makefile.in.orig        2008-02-21 11:02:12.000000000 +0100
-+++ ejabberd-2.0.0/src/Makefile.in     2008-02-22 14:52:47.000000000 +0100
-@@ -74,7 +74,7 @@
+diff -dur ejabberd-13.10.orig/Makefile.in ejabberd-13.10/Makefile.in
+--- ejabberd-13.10.orig/Makefile.in    2013-09-27 11:19:22.000000000 +0200
++++ ejabberd-13.10/Makefile.in 2013-11-14 09:23:06.000000000 +0100
+@@ -9,7 +9,7 @@
  DESTDIR =
  
  # /etc/ejabberd/
@@ -9,3 +10,4 @@
  
  # /sbin/
  SBINDIR = $(DESTDIR)@sbindir@
+Only in ejabberd-13.10: Makefile.in~
diff --git a/ejabberd-mod_muc.patch b/ejabberd-mod_muc.patch
deleted file mode 100644 (file)
index 79e6071..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur o-ejabberd-0.7.5/src/mod_muc/mod_muc_room.erl ejabberd-0.7.5/src/mod_muc/mod_muc_room.erl
---- o-ejabberd-0.7.5/src/mod_muc/mod_muc_room.erl      2004-10-08 14:40:28.000000000 -0600
-+++ ejabberd-0.7.5/src/mod_muc/mod_muc_room.erl        2005-02-17 10:29:25.316538420 -0700
-@@ -300,7 +300,7 @@
-                   {result, Res, SD} ->
-                       {IQ#iq{type = result,
-                              sub_el = [{xmlelement, "query",
--                                        [{"xmlns", XMLNS}],
-+                                        [{"xmlns", XMLNS}, {"type", "form"}],
-                                         Res
-                                        }]},
-                        SD};
diff --git a/ejabberd-pack_deps.sh b/ejabberd-pack_deps.sh
new file mode 100755 (executable)
index 0000000..3b165ac
--- /dev/null
@@ -0,0 +1,28 @@
+#!/bin/sh -ex
+
+current_dir=$(readlink -f .)
+if [ "$(basename $current_dir)" != "deps" ] \
+               || ! grep -q 'AC_INIT(ejabberd' ../configure.ac  ; then
+
+       echo "This script should be run in the ejabberd 'deps' directory"
+       exit 1
+fi
+
+rm -f .got || :
+for dir in * ; do
+       [ -d "$dir" ] || continue
+       rm -rf "$dir"
+done
+
+cd ..
+./rebar get-deps
+cd deps
+
+for dir in * ; do
+       [ -d "$dir" ] || continue
+       cd $dir
+       date=$(git log --format='%cd' --date=short -1 | tr -d '-')
+       git archive --format=tar --prefix="deps/$dir/" HEAD \
+               | gzip -9 > "../ejabberd-$dir-$date.tar.gz"
+       cd ..
+done
index fef8831100a60cfce7824fe85b6a7dd26de7f823..b1f32729ba12415ac6d0d785ee35a4c60e0933ee 100644 (file)
@@ -1,36 +1,68 @@
 #
+# TODO:
+#      - config migration from old versions
+#      - check/udpate the init script
+#      - add systemd unit
+
 # Conditional build:
 %bcond_with    pam             # PAM authentication support
-%bcond_without logdb           # enable mod_logdb (server-side message logging)
+%bcond_with    logdb           # enable mod_logdb (server-side message logging)
 #
 
 %define        realname        ejabberd
 
-%define        pgsql_module_rev 1105
-
 Summary:       Fault-tolerant distributed Jabber/XMPP server
 Summary(pl.UTF-8):     Odporny na awarie rozproszony serwer Jabbera/XMPP
 Name:          %{realname}
-Version:       2.1.13
-Release:       1
+Version:       13.10
+Release:       0.1
 License:       GPL
 Group:         Applications/Communications
 Source0:       http://www.process-one.net/downloads/ejabberd/%{version}/%{realname}-%{version}.tgz
-# Source0-md5: 00f8f28752e6728870cb4c8ad0339984
+# Source0-md5: 94ce4fe244ee72771eeafe27209d6d3c
 Source1:       %{realname}.init
 Source2:       %{realname}.sysconfig
 Source3:       %{realname}.sh
 Source4:       %{realname}ctl.sh
 Source5:       %{realname}-inetrc
-# svn export -r %{pgsql_module_rev} https://svn.process-one.net/ejabberd-modules/pgsql/trunk/src ejabberd-module-pgsql-%{pgsql_module_rev}
-Source6:       ejabberd-module-pgsql-%{pgsql_module_rev}.tar.bz2
-# Source6-md5: 7a8ba920a508f5180284699610789c14
+#
+# Archives created with the ejabberd-pack_deps.sh script (in this repo)
+Source10:      ejabberd-goldrush-20131108.tar.gz
+# Source10-md5:        3f61708d20fcee2e7d47036cc470f4e9
+Source11:      ejabberd-lager-20131111.tar.gz
+# Source11-md5:        e0933da9d0462b045f6b9c4bbd320d3e
+Source12:      ejabberd-p1_cache_tab-20130515.tar.gz
+# Source12-md5:        f2500cffdaff434b354d01eeb24d136d
+Source13:      ejabberd-p1_iconv-20130602.tar.gz
+# Source13-md5:        ab0118d4097ee756f65fd087265c88ae
+Source14:      ejabberd-p1_stringprep-20131113.tar.gz
+# Source14-md5:        282d70c792a78ea9a7415b0b4e65e157
+Source15:      ejabberd-p1_tls-20130717.tar.gz
+# Source15-md5:        1211c5d8f0a95b58dfc5fb5bf4e13ded
+Source16:      ejabberd-p1_xml-20131017.tar.gz
+# Source16-md5:        dc7ebd7ed1ed6340ff0e7739173d4438
+Source17:      ejabberd-p1_yaml-20131031.tar.gz
+# Source17-md5:        82d4bb5c5d56ab93a60f5d1c6e583dc1
+Source18:      ejabberd-p1_zlib-20130515.tar.gz
+# Source18-md5:        a203d9359122ead64966eeb0bd1c8cf7
+Source19:      ejabberd-xmlrpc-20130116.tar.gz
+# Source19-md5:        22e02ff7ca174b4ac225005f63da10ad
+Source20:      ejabberd-jiffy-20130702.tar.gz
+# Source20-md5:        01b156e97005f07ce8bb46ecf27471ff
+Source21:      ejabberd-p1_mysql-20131024.tar.gz
+# Source21-md5:        c02921f21ba030357d2cbbbf182af54a
+Source22:      ejabberd-p1_pam-20130515.tar.gz
+# Source22-md5:        0ca31094d93dfb047f05c7539136433a
+Source23:      ejabberd-p1_pgsql-20130515.tar.gz
+# Source23-md5:        1958be8e59d1b472499ef1bdf8edc1db
+Source24:      ejabberd-p1_stun-20130624.tar.gz
+# Source24-md5:        9a1c5ad9b3b95364d3f76446fcf58dc3
+#
 Patch0:                %{realname}-makefile.patch
-Patch1:                %{realname}-config.patch
-Patch2:                %{realname}-mod_muc.patch
+# not available for 13.10
+#Patch1:               %{realname}-vcard-access-get.patch
 # http://www.dp.uz.gov.ua/o.palij/mod_logdb/patch-mod_logdb-2.1.12.diff
-Patch3:                %{realname}-mod_logdb.patch
-Patch4:                %{realname}-vcard-access-get.patch
+Patch2:                %{realname}-mod_logdb.patch
 URL:           http://www.ejabberd.im/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -69,36 +101,60 @@ Requires:  %{name} = %{version}-%{release}
 Server-side logging module.
 
 %prep
-%setup -q -a 6
+%setup -q -a 10 -a 11 -a 12 -a 13 -a 14 -a 15 -a 16 -a 17 -a 18 -a 19 -a 20 -a 21 -a 22 -a 23 -a 24
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch4 -p1
+#%%patch1 -p1
 %if %{with logdb}
-%patch3 -p0
+%patch2 -p0
 %endif
 
 %build
-cd src
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %configure \
        %{?with_pam --enable-pam} \
        --with-openssl=%{_prefix} \
-       --enable-odbc
+       --enable-full-xml \
+       --enable-nif \
+       --enable-odbc \
+       --enable-mysql \
+       --enable-pgsql \
+       %{?with_pam:--enable-pam} \
+       --enable-zlib \
+       --enable-stun \
+       --enable-json \
+       --enable-iconv \
+       --enable-lager
+touch deps/.got
+
+cd deps/p1_iconv
+%configure
+cd ../..
+cd deps/p1_stringprep
+%configure
+cd ../..
+cd deps/p1_tls
+%configure
+cd ../..
+cd deps/p1_xml
+%configure \
+       --enable-nif \
+       --enable-full-xml
+cd ../..
+cd deps/p1_yaml
+%configure
+cd ../..
+cd deps/p1_zlib
+%configure
+cd ../..
+
 %{__make} -j1
-cd ..
-cd ejabberd-module-pgsql-%{pgsql_module_rev}
-for f in *.erl ; do
-       erlc $f
-done
-cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/var/lib/%{realname},/etc/{sysconfig,rc.d/init.d},%{_sbindir}}
 
-%{__make} -C src install -j1 \
+%{__make} install -j1 \
        DESTDIR=$RPM_BUILD_ROOT
 
 sed -e's,@libdir@,%{_libdir},g' -e 's,@EJABBERD_DOC_PATH@,%{_docdir}/%{name}-%{version}/doc,g' %{SOURCE1} > $RPM_BUILD_ROOT/etc/rc.d/init.d/%{realname}
@@ -111,15 +167,21 @@ install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/jabber
 
 chmod 755 $RPM_BUILD_ROOT%{_libdir}/ejabberd/priv/lib/*.so
 
-cd ejabberd-module-pgsql-%{pgsql_module_rev}
-for f in *.beam ; do
-       install $f $RPM_BUILD_ROOT%{_libdir}/ejabberd/ebin
-done
-cd ..
+rm -rf _doc 2>/dev/null || :
+mv $RPM_BUILD_ROOT%{_docdir}/%{name} _doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+if [ -e /etc/jabber/ejabberd.cfg ] ; then
+       if grep -Eq '^[^#]*access_get' ; then
+               echo "Your 'ejabberd.cfg' config file seems to use 'access_get' option of mod_vcard" >&2
+               echo "this is not supported by this ejabberd version in PLD" >&2
+               exit 1
+       fi
+fi
+
 %post
 if [ -f %{_sysconfdir}/jabber/secret ] ; then
        SECRET=`cat %{_sysconfdir}/jabber/secret`
@@ -147,7 +209,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc src/odbc/pg.sql src/odbc/mysql.sql
+%doc sql _doc/*
 %attr(755,root,root) %{_sbindir}/*
 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/*
 %attr(770,root,jabber) /var/log/ejabberd
This page took 0.056425 seconds and 4 git commands to generate.