]> git.pld-linux.org Git - packages/eina.git/blob - eina.spec
1d1cfc03189a919014137c4541eab74188083d75
[packages/eina.git] / eina.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
9 %undefine       with_mmx
10 %endif
11 %ifnarch i686 pentium3 pentium4 athlon %{x8664}
12 %undefine       with_sse
13 %endif
14 %ifnarch ppc
15 %undefine       with_altivec
16 %endif
17
18 Summary:        Data types library (list, hash, etc.)
19 Summary(pl.UTF-8):      Biblioteka struktur danych (lista, hasz, itp.)
20 Name:           eina
21 %define subver  beta3
22 Version:        1.0.0
23 Release:        0.%{subver}.1
24 License:        LGPL v2.1
25 Group:          Libraries
26 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
27 # Source0-md5:  004454c013e53ad97aab72c22328da40
28 URL:            http://trac.enlightenment.org/e/wiki/Eina
29 BuildRequires:  pkgconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Data types library (list, hash, etc.)
34
35 %description -l pl.UTF-8
36 Bilblioteka struktur danych (lista, hasz, itp.).
37
38 %package devel
39 Summary:        Eina header files
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eina
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for Eina.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki Eina.
49
50 %package static
51 Summary:        Static Eina library
52 Summary(pl.UTF-8):      Statyczna biblioteka Eina
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static Eina library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka Eina.
61
62 %prep
63 %setup -q -n %{name}-%{version}.%{subver}
64
65 %build
66 %configure \
67         --disable-silent-rules \
68         %{?with_static_libs:--enable-static} \
69         --enable-cpu-mmx%{!?with_mmx:=no} \
70         --enable-cpu-sse%{!?with_sse:=no} \
71         --enable-cpu-altivec%{!?with_altives:=no} 
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS README
90 %attr(755,root,root) %{_libdir}/libeina.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libeina.so.1
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libeina.so
96 %{_libdir}/libeina.la
97 %{_includedir}/eina-1
98 %{_pkgconfigdir}/eina.pc
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libeina.a
104 %endif
This page took 1.015972 seconds and 2 git commands to generate.