]> git.pld-linux.org Git - packages/eigen3.git/blame - eigen3.spec
- updated to 3.1.3
[packages/eigen3.git] / eigen3.spec
CommitLineData
86cdc95d
JB
1Summary: C++ template library for linear algebra
2Summary(pl.UTF-8): Biblioteka szablonów C++ do algebry liniowej
3Name: eigen3
77ecc5c9 4Version: 3.1.3
86cdc95d
JB
5Release: 1
6License: LGPL v3+ or GPL v2+
7Group: Development/Libraries
3859e214 8#Source0Download: http://eigen.tuxfamily.org/index.php?title=Main_Page
86cdc95d 9Source0: http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
77ecc5c9 10# Source0-md5: 43eee0e9252a77149d6b65e93e73b79d
86cdc95d
JB
11Patch0: %{name}-buildtype.patch
12URL: http://eigen.tuxfamily.org/
13BuildRequires: cmake >= 2.6.2
14BuildRequires: rpmbuild(macros) >= 1.605
15Requires: libstdc++-devel
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19Eigen is a C++ template library for linear algebra: vectors, matrices,
20and related algorithms. It is versatile, fast, elegant and
21compiler-friendly.
22
23Eigen handles, without code duplication and in a completely integrated
24way:
25 - both fixed-size and dynamic-size matrices and vectors
26 - both dense and sparse (the latter is still experimental) matrices
27 and vectors
28 - both plain matrices/vectors and abstract expressions
29 - both column-major (the default) and row-major matrix storage
30 - both basic matrix/vector manipulation and many more advanced,
31 specialized modules providing algorithms for linear algebra,
32 geometry, quaternions, or advanced array manipulation.
33
34%description -l pl.UTF-8
35Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
36macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
37elegancka i przyjazna dla kompilatorów.
38
39Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
40 - macierze i wektory o stałym i dynamicznym rozmiarze
41 - macierze i wektory gęste i rzadkie (te drugie jeszcze
42 eksperymentalnie)
43 - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
44 - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
45 - podstawowe operacje na macierzach/wektorach, jak i wiele
46 bardziej zaawansowanych, specjalizowanych modułów z algorytmami
47 algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
48 na tablicach.
49
50%prep
77ecc5c9 51%setup -q -n eigen-eigen-2249f9c22fe8
86cdc95d
JB
52%patch0 -p1
53
54%build
55install -d build
56cd build
57%cmake .. \
58 -DCMAKE_CXX_COMPILER_WORKS=1 \
59 -DCMAKE_CXX_COMPILER="%{__cc}"
60
61%{__make}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%{__make} -C build install \
67 DESTDIR=$RPM_BUILD_ROOT
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(644,root,root,755)
74%{_includedir}/eigen3
75%{_npkgconfigdir}/eigen3.pc
This page took 0.181784 seconds and 4 git commands to generate.