]> git.pld-linux.org Git - packages/eic.git/blob - eic.spec
- tabs in preamble
[packages/eic.git] / eic.spec
1 Summary:        C language interpreter
2 Summary(pl.UTF-8):      Interpreter języka C
3 Name:           eic
4 Version:        4.3.0
5 %define dir     4_3_0
6 Release:        1
7 License:        Artistic (generally free)
8 Group:          Development/Languages
9 Source0:        http://www.kd-dev.com/~eic/download/eicdist/%{dir}/EiCsrc_%{version}.tgz
10 # Source0-md5:  4d026568a86f7672bc1417e391c14488
11 Source1:        %{name}.h
12 Patch0:         %{name}-make.patch
13 URL:            http://www.kd-dev.com/~eic/
14 BuildRequires:  tetex-latex
15 BuildRequires:  tetex-dvips
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 EiC is a freely available C language interpreter in both source and
20 binary form. EiC allows you to write C programs, and then "execute"
21 them as if they were a script (like a Perl script or a shell script).
22 You can even embed EiC in your own programs, allowing your application
23 to have a "scripting" language that is syntactically equivalent to C.
24 It is also possible to let an EiC "script" call compiled library code
25 and for compiled code to make callbacks to EiC user defined functions.
26
27 %description -l pl.UTF-8
28 EiC jest darmowym, ogólnodostępnym interpreterem języka C zarówno w
29 formie źródłowej jak i binarnej. EiC pozwala na pisanie programów w C,
30 a następnie ich "wykonywanie" tak jakby były skryptami (takimi samymi
31 jak skrypty Perla czy powłoki). Możesz nawet włączyć obsługę języka
32 skryptowego syntaktycznie zgodnego z C do swoich programów.
33
34 %package lib
35 Summary:        Static eic library for embedding
36 Summary(pl.UTF-8):      Biblioteka statyczna eic
37 Group:          Development/Libraries
38
39 %description lib
40 Static library that allows to embed EiC in your own programs, allowing
41 your application to have a "scripting" language that is syntactically
42 equivalent to C.
43
44 %description lib -l pl.UTF-8
45 Statyczne biblioteki pozwalające włączyć EiC do swoich własnych
46 programów dodając tym samym obsługę "języka skryptowego" syntaktycznie
47 zgodnego z C.
48
49 %prep
50 %setup -q -n EiC
51 %patch0 -p1
52 touch module/link.libs
53
54 %build
55 ./config/makeconfig
56 OPT="%{rpmcflags}" %{__make}
57 cd doc && %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}}
63
64 %{__make} install \
65         INSTALL_DIR="$RPM_BUILD_ROOT%{_bindir}"
66
67 install lib/*.a         $RPM_BUILD_ROOT%{_libdir}
68 install %{SOURCE1}      $RPM_BUILD_ROOT%{_includedir}
69
70 cd doc
71 %{__make} install
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc *.html doc/EiC.ps
79 %attr(755,root,root) %{_bindir}/*
80
81 %files lib
82 %defattr(644,root,root,755)
83 %doc main/README main/examples/embedEiC.c
84 %{_includedir}/*.h
85 %{_libdir}/*.a
This page took 0.094776 seconds and 3 git commands to generate.