]> git.pld-linux.org Git - packages/eic.git/blob - eic.spec
- updates
[packages/eic.git] / eic.spec
1 Summary:        C language interpreter
2 Summary(pl):    Interpreter jêzyka C
3 Name:           eic
4 Version:        4.3.0
5 %define dir     4_3_0
6 Release:        1
7 License:        Artistic License (generally free)
8 Group:          Development/Languages
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        http://www.kd-dev.com/~eic/download/eicdist/%{dir}/EiCsrc_%{version}.tgz
11 Source1:        eic.h
12 Patch0:         eic-make.patch
13 URL:            http://www.kd-dev.com/~eic
14 BuildRequires:  tetex-latex
15 BuildRequires:  tetex-dvips
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 EiC is a freely available C language interpreter in both source and
20 binary form. EiC allows you to write C programs, and then "execute"
21 them as if they were a script (like a Perl script or a shell script). You
22 can even embed EiC in your own programs, allowing your
23 application to have a "scripting" language that is syntactically
24 equivalent to C. It is also possible to let an EiC "script" call compiled
25 library code and for compiled code to make callbacks to EiC user
26 defined functions. 
27
28 %description -l pl
29 EiC jest darmowym, ogólnodostêpnym interpreterem jêzyka C zarówno
30 w formie ¼ród³owej jak i binarnej. EiC pozwala na pisanie programów
31 w C, a nastêpnie ich "wykonywanie" tak jakby by³y skryptami (takimi
32 samymi jak skrypty Perla czy pow³oki). Mo¿esz nawet w³±czyæ obs³ugê
33 jêzyka skryptowego syntaktycznie zgodnego z C do swoich programów.
34
35 %package lib
36 Summary:        Static eic library for embedding
37 Summary(pl):    Biblioteka statyczna eic
38 Group:          Development/Libraries
39 Group(fr):      Development/Librairies
40 Group(pl):      Programowanie/Biblioteki
41
42 %description lib
43 Static library that allows to embed EiC in your own programs,
44 allowing your application to have a "scripting" language that
45 is syntactically equivalent to C.
46
47 %description -l pl lib
48 Statyczne biblioteki pozwalaj±ce w³±czyæ EiC do swoich
49 w³asnych programów dodaj±c tym samym obs³ugê "jêzyka
50 skryptowego" syntaktycznie zgodnego z C.
51
52 %prep
53 %setup -q -n EiC
54 %patch0 -p1
55 touch module/link.libs
56
57 %build
58 ./config/makeconfig
59 OPT="$RPM_OPT_FLAGS" %{__make}
60 cd doc && %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}}
66
67 %{__make} install \
68         INSTALL_DIR="$RPM_BUILD_ROOT%{_bindir}"
69         
70 install lib/*.a         $RPM_BUILD_ROOT%{_libdir}
71 install %{SOURCE1}      $RPM_BUILD_ROOT%{_includedir}
72
73 cd doc
74 %{__make} install
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc *.html doc/EiC.ps
82 %attr(755,root,root) %{_bindir}/*
83
84 %files lib
85 %defattr(644,root,root,755)
86 %doc main/README main/examples/embedEiC.c
87 %{_includedir}/*.h
88 %{_libdir}/*.a
This page took 0.091632 seconds and 3 git commands to generate.