]> git.pld-linux.org Git - packages/egroupware.git/blob - egroupware.spec
- apply changes inspired from spec for suse
[packages/egroupware.git] / egroupware.spec
1 # TODO
2 # - subpackages for applications
3 # - separate htdocs and includedirs
4 # - list of bundled software (to use pld packages instead):
5 # - everything
6
7 %define _rel 0.3
8 Summary:        eGroupWare - a web-based groupware suite written in PHP
9 Summary(pl):    eGroupWAre - oparte na WWW oprogramowanie do pracy grupowej napisane w PHP
10 Name:           egroupware
11 Version:        1.2
12 Release:        2.%{_rel}
13 License:        GPL
14 Group:          Applications/WWW
15 Source0:        http://dl.sourceforge.net/egroupware/eGroupWare-%{version}-2.tar.bz2
16 # Source0-md5:  2758792188125086f815e0e412a30904
17 Source1:        %{name}.conf
18 Source2:        %{name}.cron
19 Patch0:         %{name}-setup.patch
20 Patch1:         %{name}-ttfdir.patch
21 URL:            http://www.egroupware.org/
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 BuildRequires:  sed >= 4.0
24 Requires:       %{name}(DB_Driver) = %{version}-%{release}
25 Requires:       /usr/bin/php
26 Requires:       crondaemon
27 Requires:       fonts-TTF-bitstream-vera
28 Requires:       php >= 3:4.3
29 Requires:       php-cli
30 Requires:       php-gd
31 Requires:       php-imap
32 Requires:       php-mbstring
33 Requires:       php-pcre
34 Requires:       webapps
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _webapps        /etc/webapps
39 %define         _webapp         %{name}
40 %define         _sysconfdir     %{_webapps}/%{_webapp}
41 %define         _appdir         %{_datadir}/%{_webapp}
42
43 %description
44 eGroupWare is a multi-user, web-based groupware suite developed on a
45 custom set of PHP-based APIs. Currently available modules include:
46 email, addressbook, calendar, infolog (notes, to-do's, phone calls),
47 content management, forum, bookmarks, wiki.
48
49 %description -l pl
50 eGroupWare to wielou¿ytkownikowe, oparte na WWW oprogramowanie do
51 pracy grupowej stworzone na w³asnym zestawie API opartych na PHP.
52 Aktualnie dostêpne modu³y obejmuj±: pocztê elektroniczn±, ksi±¿kê
53 adresow±, kalendarz, infolog (notatki, rzeczy do zrobienia, rozmowy
54 telefoniczne), zarz±dzanie tre¶ci±, forum, zak³adki, wiki.
55
56 %package setup
57 Summary:        eGroupware setup package
58 Summary(pl):    Pakiet do wstêpnej konfiguracji eGroupware
59 Group:          Applications/WWW
60 Requires:       %{name} = %{version}-%{release}
61
62 %description setup
63 Install this package to configure initial eGroupware installation. You
64 should uninstall this package when you're done, as it considered
65 insecure to keep the setup files in place.
66
67 %description setup -l pl
68 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji eGroupware
69 po pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
70 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
71
72 %package db-mysql
73 Summary:        eGroupware DB Driver for MySQL
74 Summary(pl):    Sterownik bazy danych eGroupware dla MySQL-a
75 Group:          Applications/WWW
76 Requires:       php-mysql
77 Provides:       %{name}(DB_Driver) = %{version}-%{release}
78
79 %description db-mysql
80 This virtual package provides MySQL database backend for eGroupware.
81
82 %description db-mysql -l pl
83 Ten wirtualny pakiet dostarcza backend bazy danych MySQL dla
84 eGroupware.
85
86 %package db-pgsql
87 Summary:        eGroupware DB Driver for PostgreSQL
88 Summary(pl):    Sterownik bazy danych eGroupware dla PostgreSQL-a
89 Group:          Applications/WWW
90 Requires:       php-pgsql
91 Provides:       %{name}(DB_Driver) = %{version}-%{release}
92
93 %description db-pgsql
94 This virtual package provides PostgreSQL database backend for
95 eGroupware.
96
97 %description db-pgsql -l pl
98 Ten wirtualny pakiet dostarcza backend bazy danych PostgreSQL dla
99 eGroupware.
100
101 %package db-mssql
102 Summary:        eGroupware DB Driver for MS SQL
103 Summary(pl):    Sterownik bazy danych eGroupware dla MS SQL-a
104 Group:          Applications/WWW
105 Requires:       php-mssql
106 Provides:       %{name}(DB_Driver) = %{version}-%{release}
107
108 %description db-mssql
109 This virtual package provides MS SQL database backend for eGroupware.
110
111 %description db-mssql -l pl
112 Ten wirtualny pakiet dostarcza backend bazy danych MS SQL dla
113 eGroupware.
114
115 %prep
116 %setup -q -n %{name}
117
118 # remove CVS control files
119 find -name .svn -print0 | xargs -0 rm -rf
120 # undos the sources
121 find -regex '.*\.\(php\|inc\|html\|txt\|js\)$' -print0 | xargs -0 sed -i -e 's,\r$,,'
122
123 %patch0 -p1
124 %patch1 -p1
125
126 # GPL
127 rm doc/LICENSE
128
129 # no need.
130 rm -r doc/rpm-build
131
132 # using PLD package
133 rm -r projectmanager/inc/ttf-bitstream-vera-1.10
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir},/var/lib/%{name}/{default/{files,backup},sessions}}
138
139 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
140 cp -a */ $RPM_BUILD_ROOT%{_appdir}
141
142 > $RPM_BUILD_ROOT%{_sysconfdir}/header.php
143 ln -s %{_sysconfdir}/header.php $RPM_BUILD_ROOT%{_appdir}/header.inc.php
144
145 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
146 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
147 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}
148
149 # needed by setup script
150 install header.inc.php.template $RPM_BUILD_ROOT%{_appdir}
151
152 rm -rf $RPM_BUILD_ROOT%{_appdir}/doc
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %triggerin -- apache1
158 %webapp_register apache %{_webapp}
159
160 %triggerun -- apache1
161 %webapp_unregister apache %{_webapp}
162
163 %triggerin -- apache < 2.2.0, apache-base
164 %webapp_register httpd %{_webapp}
165
166 %triggerun -- apache < 2.2.0, apache-base
167 %webapp_unregister httpd %{_webapp}
168
169 %files
170 %defattr(644,root,root,755)
171 %doc doc/*
172 %dir %attr(750,root,http) %{_sysconfdir}
173 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
174 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
175 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/header.php
176 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
177 %dir %{_appdir}
178 %{_appdir}/*.php
179 %{_appdir}/addressbook
180 %{_appdir}/admin
181 %{_appdir}/bookmarks
182 %{_appdir}/calendar
183 %{_appdir}/developer_tools
184 %{_appdir}/emailadmin
185 %{_appdir}/etemplate
186 %{_appdir}/felamimail
187 %{_appdir}/filemanager
188 %{_appdir}/infolog
189 %{_appdir}/manual
190 %{_appdir}/news_admin
191 %{_appdir}/phpbrain
192 %{_appdir}/polls
193 %{_appdir}/phpsysinfo
194 %{_appdir}/preferences
195 %{_appdir}/registration
196 %{_appdir}/sitemgr
197 %{_appdir}/wiki
198 %{_appdir}/home
199 %{_appdir}/mydms
200 %{_appdir}/projectmanager
201 %{_appdir}/resources
202 %{_appdir}/sambaadmin
203 %{_appdir}/syncml
204 %{_appdir}/timesheet
205 %{_appdir}/workflow
206
207 %dir %{_appdir}/phpgwapi
208 %{_appdir}/phpgwapi/*.php
209 %{_appdir}/phpgwapi/cron
210 %{_appdir}/phpgwapi/doc
211 %{_appdir}/phpgwapi/inc
212 %{_appdir}/phpgwapi/js
213 %{_appdir}/phpgwapi/setup
214 %{_appdir}/phpgwapi/templates
215 %{_appdir}/phpgwapi/themes
216 %{_appdir}/phpgwapi/tests
217 %dir %attr(775,root,http) %{_appdir}/phpgwapi/images
218 %{_appdir}/phpgwapi/images/*
219
220 %dir /var/lib/%{name}/default
221 %dir %attr(775,root,http) /var/lib/%{name}/default/backup
222 %dir %attr(775,root,http) /var/lib/%{name}/default/files
223 %dir %attr(775,root,http) /var/lib/%{name}/sessions
224
225 %files setup
226 %defattr(644,root,root,755)
227 %{_appdir}/header.inc.php.template
228 %{_appdir}/setup
229
230 %files db-mysql
231 %defattr(644,root,root,755)
232
233 %files db-pgsql
234 %defattr(644,root,root,755)
235
236 %files db-mssql
237 %defattr(644,root,root,755)
This page took 0.270976 seconds and 3 git commands to generate.