]> git.pld-linux.org Git - packages/eggdrop.git/commitdiff
- use md5 from openssl
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 31 Mar 2012 18:56:10 +0000 (18:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    eggdrop.spec -> 1.123
    ssl-md5.patch -> 1.1

eggdrop.spec
ssl-md5.patch [new file with mode: 0644]

index 00e133eab51b4c0c85a59ee1c6610dc71dbf9d67..87f9ab050259fccfb2d5934c757711ea82ad1f80 100644 (file)
@@ -67,6 +67,7 @@ Patch7:               %{name}-nolibs.patch
 Patch8:                %{name}-nohostwhowhom.patch
 Patch9:                %{name}-nmu.patch
 Patch10:       %{name}-ipv6-ssl.patch
 Patch8:                %{name}-nohostwhowhom.patch
 Patch9:                %{name}-nmu.patch
 Patch10:       %{name}-ipv6-ssl.patch
+Patch11:       ssl-md5.patch
 URL:           http://www.eggheads.org/
 BuildRequires: autoconf
 BuildRequires: automake
 URL:           http://www.eggheads.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -172,6 +173,7 @@ patch -p1 < eggdrop1.6.19-sp.0009.diff || exit 1
 
 #%patch9 -p0 - wtf is this?
 #%{?with_ssl:%patch10 -p1}
 
 #%patch9 -p0 - wtf is this?
 #%{?with_ssl:%patch10 -p1}
+%patch11 -p1
 
 # detect threaded tcl version
 sed -i -e 's#TclpFinalizeThreadData#Tcl_FinalizeThread#g' acinclude.m4
 
 # detect threaded tcl version
 sed -i -e 's#TclpFinalizeThreadData#Tcl_FinalizeThread#g' acinclude.m4
diff --git a/ssl-md5.patch b/ssl-md5.patch
new file mode 100644 (file)
index 0000000..e0c9f54
--- /dev/null
@@ -0,0 +1,34 @@
+--- eggdrop1.6.21/src/Makefile.in      2012-03-31 21:43:01.365906412 +0300
++++ eggdrop1.6.21/src/Makefile.in      2012-03-31 21:51:20.130394596 +0300
+@@ -35,11 +35,11 @@
+       @echo ""
+       @cd .. && $(MAKE)
+-../$(EGGEXEC): build_msg $(eggdrop_objs) $(XREQS) compile_md5 compatability
++../$(EGGEXEC): build_msg $(eggdrop_objs) $(XREQS) compatability
+       @echo "Linking eggdrop $(EGGBUILD)."
+       @echo ""
+       @touch mod/mod.xlibs
+-      $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs` $(XSSL_LIBS) $(XSSL_INCLUDE)
++      $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLIBS) compat/*.o `cat mod/mod.xlibs` $(XSSL_LIBS) $(XSSL_INCLUDE)
+       $(STRIP) ../$(EGGEXEC)
+       @echo ""
+       @echo "Successful compile: $(EGGEXEC)"
+--- eggdrop1.6.21/src/mod/idea.mod/idea.c~     2003-07-01 03:36:24.000000000 +0300
++++ eggdrop1.6.21/src/mod/idea.mod/idea.c      2012-03-31 21:52:35.356441426 +0300
+@@ -29,6 +29,7 @@
+ #define MAKING_ENCRYPTION
+ #include "src/mod/module.h"
++#ifndef EGG_SSL_EXT
+ /*
+ #include "../../md5/md5c.c"
+ #include "../../md5/md5.h"
+@@ -45,6 +46,7 @@
+ #undef MD5_Init
+ #define MD5_Init ((void (*)(MD5_CTX *))global[277])
+ #undef global
++#endif
+ static Function *global = NULL;
+ /********************************************/
This page took 0.043722 seconds and 4 git commands to generate.