]> git.pld-linux.org Git - packages/eggdrop.git/commitdiff
- fixed usage of macros
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Jul 1999 11:04:33 +0000 (11:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added/removed neccesary/obsolete patches
- FHS 2.0 compliance where needed
- gzipping docs where needed

Changed files:
    eggdrop.spec -> 1.15

eggdrop.spec

index cc9d6cecdc0a41d84a5219c5e97fa2ff54eacccf..fa3dd147211e3fe556a3594175708bac9e4b3b0a 100644 (file)
@@ -1,19 +1,17 @@
-Summary:     Eggdrop is an IRC bot, written in C
-Name:        eggdrop
-%define versionmajor 2.0.0
-%define versionminor -ALPHA
-Version:     %{versionmajor}%{versionminor}
-Release:     1
-Copyright:   GPL
-Group:       Applications/Communications
-Group(pl):   Aplikacje/Komunikacja
-Source0:     %{name}%{version}.tar.gz
-Source1:     eggdrop.sh
-Patch:       eggdrop-pld.patch
-URL:         http://www.eggdrop.net/
-Requires:    tcl
+Summary:       Eggdrop is an IRC bot, written in C
+Summary(pl):   Eggdrop jest botem IRC napisanym w C
+Name:          eggdrop
+Version:       2.0.0
+Release:       1.ALPHA
+Copyright:     GPL
+Group:         Applications/Communications
+Group(pl):     Aplikacje/Komunikacja
+Source0:       %{name}%{version}-ALPHA.tar.gz
+Source1:       eggdrop.sh
+Patch:         eggdrop-pld.patch
+URL:           http://www.eggdrop.net/
+Requires:      tcl
 BuildRoot:     /tmp/%{name}-%{version}-root
-Summary(pl): Eggdrop jest botem IRC napisanym w C
 
 %description
 Eggdrop is an IRC bot, written in C.  If you don't know what IRC is,
@@ -34,48 +32,54 @@ Eggdrop poza tymi funkcjami posiada tak
 przesy³anie plików czy inne skrypty dla rozrywki.
 
 %prep
-%setup -q -n %{name}%{version}
+%setup -q -n %{name}%{version}-ALPHA
 %patch -p1
 
 %build
 CFLAGS="$RPM_OPT_FLAGS" \
 ./configure %{_target_platform} \
        --prefix=%{_bindir}
+
 # Dziwny problem z -ldir w module filesys
 cd src/mod/filesys.mod
 rm -f config.cache config.log
+
 CFLAGS="$RPM_OPT_FLAGS" \
 ./configure %{_target_platform}
+
 cd ../../..
 CFLAGS="$RPM_OPT_FLAGS" make
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/usr/{bin,lib/eggdrop,man/man1}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/eggdrop,%{_mandir}/man1}
+
 make install DEST=$RPM_BUILD_ROOT%{_libdir}/eggdrop
+
 rm -rf `find $RPM_BUILD_ROOT%{_libdir}/eggdrop -name CVS`
-rm -rf $RPM_SOURCE_DIR/doc/CVS
-mv $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
+rm -rf `find $RPM_BUILD_DIR/%{name}%{version}-ALPHA/doc -name CVS`
+mv -f $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
 rm -rf $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/*
 install $RPM_SOURCE_DIR/eggdrop.sh $RPM_BUILD_ROOT%{_bindir}/eggdrop
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/*
+gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
+       FEATURES README doc/{patch.howto,tricks,[A-Z]*,*.doc}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files 
 %defattr(644,root,root,755)
-%doc CONTENTS COPYING FEATURES INSTALL README doc/*
+%doc FEATURES.gz README.gz doc/*.gz doc/html
 %attr(755,root,root) %{_bindir}/*
 %{_libdir}/eggdrop/filesys
 %{_libdir}/eggdrop/help
 %{_libdir}/eggdrop/language
 %ghost %{_libdir}/eggdrop/modules
-%{_libdir}/eggdrop/modules-%{versionmajor}
+%{_libdir}/eggdrop/modules-%{version}
 %{_libdir}/eggdrop/scripts
-%attr(755,root,root) %{_libdir}/eggdrop/eggdrop2-%{versionmajor}
+%attr(755,root,root) %{_libdir}/eggdrop/eggdrop2-%{version}
 %ghost %{_libdir}/eggdrop/eggdrop2
 %{_libdir}/eggdrop/eggdrop2.conf.*
 %{_libdir}/eggdrop/motd
This page took 0.035869 seconds and 4 git commands to generate.