]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- added some docs
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        1.6.13
5 Release:        4
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/%{name}%{version}.tar.gz
9 # PLD docs - information about changes.
10 Source1:        http://pld.mysza.eu.org/sources/%{name}-README.PLD.en
11 Source2:        http://pld.mysza.eu.org/sources/%{name}-README.PLD.pl
12 # In order to unify filenames, following language packs and third-party modules were 
13 # repackaged. Some files were renamed, but none modified. Original archives can be 
14 # found by looking at http://www.egghelp.org/
15 Source10:       %{name}-language-danish.tar.gz
16 Source11:       %{name}-language-finnish.tar.gz
17 Source12:       %{name}-language-italian.tar.gz
18 Source13:       %{name}-language-norwegian.tar.gz
19 Source14:       %{name}-language-portuguese.tar.gz
20 Source15:       %{name}-language-portuguese_br.tar.gz
21 Source16:       %{name}-language-romanian.tar.gz
22 # Additional modules taken from various places
23 Source20:       %{name}-module-away-1.0.tar.gz
24 Source21:       %{name}-module-botnetop-1.0.1.tar.gz
25 Source22:       %{name}-module-fakebotnet-1.3.tar.gz
26 Source23:       %{name}-module-gseen-1.1.0.tar.gz
27 Source24:       %{name}-module-irctree-1.1.tar.gz
28 Source25:       %{name}-module-megahal-2.5.tar.gz
29 Source26:       %{name}-module-stats-1.3.3dev1.tar.gz
30 Patch0:         %{name}-FHS.patch
31 # Unofficial IPv6 patch
32 Patch1:         http://www.egghelp.org/files/patches/%{name}%{version}+ipv6.patch.gz
33 # Adds IPv6 variables to config file
34 Patch2:         %{name}%{version}+ipv6_config.patch
35 # Adds additional docs
36 Patch3:         %{name}-doc_makefile.patch
37 # Multilevel sharing patch - now it is possible to create *secure* multilevel
38 # botnets, each bot will only accept changes to userlist from bot that acts as 
39 # hub to him, and rejects changes from leaves
40 Patch4:         %{name}%{version}-multilevel_sharing.patch.gz
41 # Unlinkedby patch - when unlinking bot from botnet, adds nickname of a person
42 # that issues .unlink command to a broadcasted message
43 Patch5:         %{name}%{version}-unlinkedby.patch
44 URL:            http://www.eggheads.org/
45 BuildRequires:  tcl-devel
46 Requires:       tcl
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
51 this is probably not whatever you're looking for! Eggdrop, being a
52 bot, sits on a channel and takes protective measures: to keep the
53 channel from being taken over (in the few ways that anything CAN), to
54 recognize banished users or sites and reject them, to recognize
55 privileged users and let them gain ops, etc. Eggdrop also contains
56 many modules and scripts, for example for sending files.
57
58 %description -l pl
59 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem jest na
60 kanale i zajmuje siê jego ochron±: zabezpieczeniem przed przejêciem,
61 nadawaniem odpowiednich przywilejów zarejestrowanym u¿ytkownikom,
62 pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami posiada tak¿e
63 wiele dodatków, jak przesy³anie plików czy inne skrypty dla rozrywki.
64
65 %prep
66 %setup -q -n %{name}%{version} -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a20 -a21 -a22 -a23 -a24 -a25 -a26
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p0
70 %patch3 -p0
71 %patch4 -p1
72 %patch5 -p1
73
74 %build
75 CFLAGS="%{rpmcflags}"; export CFLAGS
76 ./configure
77 %{__make} config
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/modules,%{_datadir}/%{name},%{_mandir}/man1,%{_datadir}/%{name}/{help,scripts,language},%{_datadir}/doc/%{name}-%{version}}
83
84 %{__make} DESTDIR="$RPM_BUILD_ROOT" install
85
86 cp $RPM_BUILD_ROOT/%{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
87
88 cp %{SOURCE1} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}/README.PLD.en
89 cp %{SOURCE2} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}/README.PLD.pl
90
91 find $RPM_BUILD_ROOT/doc -type f | egrep -v "(\.html$|\.htm$)" | xargs gzip -9nf
92 gzip -9nf $RPM_BUILD_ROOT/README $RPM_BUILD_ROOT/%{name}.conf 
93
94 cp $RPM_BUILD_ROOT/doc/man1/%{name}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1.gz
95 rm -r $RPM_BUILD_ROOT/doc/man1
96
97 cp -a $RPM_BUILD_ROOT/*.gz \
98         $RPM_BUILD_ROOT/doc/* \
99         $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}/
100
101 cp -a $RPM_BUILD_ROOT/doc/modules $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
102
103 cp -a $RPM_BUILD_ROOT/text/* \
104         $RPM_BUILD_ROOT/help/ \
105         $RPM_BUILD_ROOT/scripts/ \
106         $RPM_BUILD_ROOT/language/ \
107         $RPM_BUILD_ROOT%{_datadir}/%{name}/
108
109 cp -a $RPM_BUILD_ROOT/modules/* \
110         $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc %{_datadir}/doc/%{name}-%{version}
118 %attr(755,root,root) %{_bindir}/%{name}
119 %dir %{_libdir}/%{name}
120 %dir %{_libdir}/%{name}/modules
121 %attr(755,root,root) %{_libdir}/%{name}/modules/*.so
122 %{_datadir}/%{name}
123 %{_mandir}/man1/%{name}.1*
This page took 0.135287 seconds and 4 git commands to generate.