]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- added multilevel_sharing and unlinkedby patches
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        1.6.13
5 Release:        4
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/%{name}%{version}.tar.gz
9 # In order to unify filenames, following language packs and third-party modules were 
10 # repackaged. Some files were renamed, but none modified. Original archives can be 
11 # found by looking at http://www.egghelp.org/
12 Source10:       %{name}-language-danish.tar.gz
13 Source11:       %{name}-language-finnish.tar.gz
14 Source12:       %{name}-language-italian.tar.gz
15 Source13:       %{name}-language-norwegian.tar.gz
16 Source14:       %{name}-language-portuguese.tar.gz
17 Source15:       %{name}-language-portuguese_br.tar.gz
18 Source16:       %{name}-language-romanian.tar.gz
19 # Additional modules taken from various places
20 Source20:       %{name}-module-away-1.0.tar.gz
21 Source21:       %{name}-module-botnetop-1.0.1.tar.gz
22 Source22:       %{name}-module-fakebotnet-1.3.tar.gz
23 Source23:       %{name}-module-gseen-1.1.0.tar.gz
24 Source24:       %{name}-module-irctree-1.1.tar.gz
25 Source25:       %{name}-module-megahal-2.5.tar.gz
26 Source26:       %{name}-module-stats-1.3.3dev1.tar.gz
27 Patch0:         %{name}-FHS.patch
28 # Unofficial IPv6 patch
29 Patch1:         http://www.egghelp.org/files/patches/%{name}%{version}+ipv6.patch.gz
30 # Adds IPv6 variables to config file
31 Patch2:         %{name}%{version}+ipv6_config.patch
32 # Adds additional docs
33 Patch3:         %{name}-doc_makefile.patch
34 # Multilevel sharing patch - now it is possible to create *secure* multilevel
35 # botnets, each bot will only accept changes to userlist from bot that acts as 
36 # hub to him, and rejects changes from leaves
37 Patch4:         %{name}%{version}-multilevel_sharing.patch.gz
38 # Unlinkedby patch - when unlinking bot from botnet, adds nickname of a person
39 # that issues .unlink command to a broadcasted message
40 Patch5:         %{name}%{version}-unlinkedby.patch
41 URL:            http://www.eggheads.org/
42 BuildRequires:  tcl-devel
43 Requires:       tcl
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
48 this is probably not whatever you're looking for! Eggdrop, being a
49 bot, sits on a channel and takes protective measures: to keep the
50 channel from being taken over (in the few ways that anything CAN), to
51 recognize banished users or sites and reject them, to recognize
52 privileged users and let them gain ops, etc. Eggdrop also contains
53 many modules and scripts, for example for sending files.
54
55 %description -l pl
56 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem jest na
57 kanale i zajmuje siê jego ochron±: zabezpieczeniem przed przejêciem,
58 nadawaniem odpowiednich przywilejów zarejestrowanym u¿ytkownikom,
59 pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami posiada tak¿e
60 wiele dodatków, jak przesy³anie plików czy inne skrypty dla rozrywki.
61
62 %prep
63 %setup -q -n %{name}%{version} -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a20 -a21 -a22 -a23 -a24 -a25 -a26
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p0
67 %patch3 -p0
68 %patch4 -p1
69 %patch5 -p1
70
71 %build
72 CFLAGS="%{rpmcflags}"; export CFLAGS
73 ./configure
74 %{__make} config
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/modules,%{_datadir}/%{name},%{_mandir}/man1,%{_datadir}/%{name}/{help,scripts,language},%{_datadir}/doc/%{name}-%{version}}
80
81 %{__make} DESTDIR="$RPM_BUILD_ROOT" install
82
83 cp $RPM_BUILD_ROOT/%{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
84
85 find $RPM_BUILD_ROOT/doc -type f | egrep -v "(\.html$|\.htm$)" | xargs gzip -9nf
86 gzip -9nf $RPM_BUILD_ROOT/README $RPM_BUILD_ROOT/%{name}.conf 
87
88 cp $RPM_BUILD_ROOT/doc/man1/%{name}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1.gz
89 rm -r $RPM_BUILD_ROOT/doc/man1
90
91 cp -a $RPM_BUILD_ROOT/*.gz \
92         $RPM_BUILD_ROOT/doc/* \
93         $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}/
94
95 cp -a $RPM_BUILD_ROOT/doc/modules $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
96
97 cp -a $RPM_BUILD_ROOT/text/* \
98         $RPM_BUILD_ROOT/help/ \
99         $RPM_BUILD_ROOT/scripts/ \
100         $RPM_BUILD_ROOT/language/ \
101         $RPM_BUILD_ROOT%{_datadir}/%{name}/
102
103 cp -a $RPM_BUILD_ROOT/modules/* \
104         $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc %{_datadir}/doc/%{name}-%{version}
112 %attr(755,root,root) %{_bindir}/%{name}
113 %dir %{_libdir}/%{name}
114 %dir %{_libdir}/%{name}/modules
115 %attr(755,root,root) %{_libdir}/%{name}/modules/*.so
116 %{_datadir}/%{name}
117 %{_mandir}/man1/%{name}.1*
This page took 0.108583 seconds and 4 git commands to generate.