]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- changed directory structure to FHS-compatible
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        2.0.0
5 Release:        1.ALPHA
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        http://www.eggdropsrus.co.uk/downloads/%{name}%{version}-ALPHA.tar.gz
9 Source1:        %{name}.sh
10 Patch0:         %{name}-pld.patch
11 URL:            http://www.eggdrop.net/
12 Requires:       tcl
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
17 this is probably not whatever you're looking for! Eggdrop, being a
18 bot, sits on a channel and takes protective measures: to keep the
19 channel from being taken over (in the few ways that anything CAN), to
20 recognize banished users or sites and reject them, to recognize
21 privileged users and let them gain ops, etc. Eggdrop also contains
22 many modules and scripts, for example for sending files.
23
24 %description -l pl
25 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem jest na
26 kanale i zajmuje siê jego ochron±: zabezpieczeniem przed przejêciem,
27 nadawaniem odpowiednich przywilejów zarejestrowanym u¿ytkownikom,
28 pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami posiada tak¿e
29 wiele dodatków, jak przesy³anie plików czy inne skrypty dla rozrywki.
30
31 %prep
32 %setup -q -n %{name}%{version}-ALPHA
33 %patch -p1
34
35 %build
36 CFLAGS="%{rpmcflags}" \
37 ./configure %{_target_platform} \
38         --prefix=%{_bindir}
39
40 # Dziwny problem z -ldir w module filesys
41 cd src/mod/filesys.mod
42 rm -f config.cache config.log
43
44 CFLAGS="%{rpmcflags}" \
45 ./configure %{_target_platform}
46
47 cd ../../..
48 CFLAGS="%{rpmcflags}" %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/eggdrop,%{_mandir}/man1}
54
55 %{__make} install DEST=$RPM_BUILD_ROOT%{_libdir}/eggdrop
56
57 rm -rf `find $RPM_BUILD_ROOT%{_libdir}/eggdrop -name CVS`
58 rm -rf `find $RPM_BUILD_DIR/%{name}%{version}-ALPHA/doc -name CVS`
59 mv -f $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
60 rm -rf $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/*
61 install $RPM_SOURCE_DIR/eggdrop.sh $RPM_BUILD_ROOT%{_bindir}/eggdrop
62
63 gzip -9nf FEATURES README doc/{patch.howto,tricks,[A-Z]*,*.doc}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc FEATURES.gz README.gz doc/*.gz doc/html
71 %attr(755,root,root) %{_bindir}/*
72 %{_libdir}/eggdrop/filesys
73 %{_libdir}/eggdrop/help
74 %{_libdir}/eggdrop/language
75 %ghost %{_libdir}/eggdrop/modules
76 %{_libdir}/eggdrop/modules-%{version}
77 %{_libdir}/eggdrop/scripts
78 %attr(755,root,root) %{_libdir}/eggdrop/eggdrop2-%{version}
79 %ghost %{_libdir}/eggdrop/eggdrop2
80 %{_libdir}/eggdrop/eggdrop2.conf.*
81 %{_libdir}/eggdrop/motd
82 %{_mandir}/man*/*
This page took 0.091223 seconds and 3 git commands to generate.