]> git.pld-linux.org Git - packages/eggdrop-vanilla.git/blob - eggdrop-vanilla.spec
-adapterized
[packages/eggdrop-vanilla.git] / eggdrop-vanilla.spec
1 %define         _name   eggdrop
2 Summary:        Eggdrop is an IRC bot, written in C
3 Summary(pl.UTF-8):      Eggdrop jest botem IRC napisanym w C
4 Name:           eggdrop-vanilla
5 Version:        1.6.19
6 Release:        1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/%{_name}%{version}.tar.bz2
10 # Source0-md5:  b706bbe4fdd05964e0ea0cd920f28539
11 Patch0:         %{name}-FHS.patch
12 Patch1:         %{name}-topicprot.patch
13 Patch2:         %{name}-autobotchk.patch
14 Patch3:         %{name}-nolibs.patch
15 Patch4:         %{name}-ssl.patch
16 Patch5:         %{name}-nohostwhowhom.patch
17 Patch6:         %{name}-bz-463.patch
18 URL:            http://www.eggheads.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  tcl-devel
23 Requires:       tcl
24 Obsoletes:      eggdrop
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
29 this is probably not whatever you're looking for! Eggdrop, being a
30 bot, sits on a channel and takes protective measures: to keep the
31 channel from being taken over (in the few ways that anything CAN), to
32 recognize banished users or sites and reject them, to recognize
33 privileged users and let them gain ops, etc. Eggdrop also contains
34 many modules and scripts, for example for sending files.
35
36 %description -l pl.UTF-8
37 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, będąc botem jest
38 na kanale i zajmuje się jego ochroną: zabezpieczeniem przed
39 przejęciem, nadawaniem odpowiednich przywilejów zarejestrowanym
40 użytkownikom, pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami
41 posiada także wiele dodatków, jak przesyłanie plików czy inne
42 skrypty dla rozrywki.
43
44 %prep
45 %setup -q -n %{_name}%{version}
46 %patch0 -p1
47 %patch1 -p1
48 %patch2 -p1
49 %patch3 -p1
50 %patch4 -p1
51 %patch5 -p1
52 %patch6 -p1
53
54 %build
55 mv aclocal.m4 acinclude.m4
56 cp -f /usr/share/automake/config.sub misc/
57 cp -f %{_name}.conf doc/
58 %{__aclocal}
59 %{__autoheader}
60 %{__autoconf}
61 cd src/mod/compress.mod
62 %{__autoconf}
63 %configure
64 cd ../dns.mod
65 %{__autoconf}
66 %configure
67 cd ../../..
68 %configure
69 %{__make} config
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{_name}/modules,%{_mandir}/man1,%{_datadir}/%{_name}}
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 mv $RPM_BUILD_ROOT/%{_name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{_name}
80 mv -f $RPM_BUILD_ROOT{/{text/*,help,scripts,language},%{_datadir}/%{_name}/}
81 mv -f $RPM_BUILD_ROOT/modules/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/modules/
82 mv -f $RPM_BUILD_ROOT{/doc,%{_mandir}}/man1/%{_name}.1
83 rm -rf $RPM_BUILD_ROOT/{doc,README,logs}
84
85 rm -rf docs
86 cp -a doc docs
87 rm -rf docs/{man1,Makefile*}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc docs/*
95 %attr(755,root,root) %{_bindir}/%{_name}
96 %dir %{_libdir}/%{_name}
97 %dir %{_libdir}/%{_name}/modules
98 %attr(755,root,root) %{_libdir}/%{_name}/modules/*.so
99 %{_datadir}/%{_name}
100 %{_mandir}/man1/%{_name}.1*
This page took 0.051886 seconds and 3 git commands to generate.