]> git.pld-linux.org Git - packages/efreet.git/blame - efreet.spec
- added am patch (fixes build with automake 1.13)
[packages/efreet.git] / efreet.spec
CommitLineData
d470277b
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
ab7bb780
JB
5%define ecore_ver 1.7.5
6%define eina_ver 1.7.5
7%define eet_ver 1.7.5
07e33737 8
d470277b
JB
9Summary: freedesktop.org standards implementation for the EFL
10Summary(pl.UTF-8): Implementacja standardów freedesktop.org dla EFL
11Name: efreet
ab7bb780 12Version: 1.7.5
27a5fa0f 13Release: 1
04827781 14License: BSD
d470277b 15Group: X11/Libraries
863f344e 16Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
ab7bb780
JB
17# Source0-md5: d21e59631022d6fbdfa0e19b6b2ff93a
18Patch0: %{name}-am.patch
9bd7b500 19URL: http://trac.enlightenment.org/e/wiki/Efreet
93cc5570
JB
20BuildRequires: autoconf >= 2.52
21BuildRequires: automake >= 1.6
07e33737 22BuildRequires: ecore-devel >= %{ecore_ver}
04827781
JB
23BuildRequires: ecore-file-devel >= %{ecore_ver}
24BuildRequires: eet-devel >= %{eet_ver}
173d24b3 25BuildRequires: eina-devel >= %{eina_ver}
ee7b66d9 26BuildRequires: gettext-devel >= 0.17
d470277b 27BuildRequires: libtool
04827781 28BuildRequires: pkgconfig >= 1:0.22
04827781 29Requires: ecore >= %{ecore_ver}
07e33737 30Requires: ecore-file >= %{ecore_ver}
173d24b3 31Requires: eet >= %{eet_ver}
8e8b1b65 32Requires: eina >= %{eina_ver}
d470277b
JB
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Efreet is an implementation of the following specifications from
37freedesktop.org:
38 - Base Directory - Locations for system and user specific desktop
39 configuration files,
40 - Desktop Entries - The metadata associated with the applications
41 installed on a system,
42 - Application Menus - The arrangement of available applications into
43 a hierarchical menu,
44 - Icon Themes - A means of associating icons with various objects on
45 the desktop in a themable fashion.
46
47By following these specifications, Enlightenment 0.17 uses the same
48format for describing application launchers, menus and icon themes as
49the GNOME, KDE and XFCE Desktop Environments. A system must only
50provide a single set of this data for use with any of these desktops.
51
52%description -l pl.UTF-8
53Efreet to implementacja następujących specyfikacji z freedesktop.org:
54 - Base Directory - położenie plików konfiguracyjnych środowiska dla
55 systemu i użytkownika,
56 - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
57 systemie,
58 - Application Menus - uporządkowanie dostępnych aplikacji w menu
59 hierarchiczne,
60 - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
61 w sposób pozwalający na ustawianie motywów.
62
63%package devel
64Summary: Efreet header files
65Summary(pl.UTF-8): Pliki nagłówkowe Efreet
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
04827781
JB
68Requires: ecore-devel >= %{ecore_ver}
69Requires: ecore-file-devel >= %{ecore_ver}
70Requires: eet-devel >= %{eet_ver}
173d24b3 71Requires: eina-devel >= %{eina_ver}
d470277b
JB
72
73%description devel
74Header files for Efreet.
75
76%description devel -l pl.UTF-8
77Pliki nagłówkowe Efreet.
78
79%package static
80Summary: Static Efreet library
81Summary(pl.UTF-8): Statyczna biblioteka Efreet
82Group: Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
84
85%description static
86Static Efreet library.
87
88%description static -l pl.UTF-8
89Statyczna biblioteka Efreet.
90
91%prep
863f344e 92%setup -q
ab7bb780 93%patch0 -p1
d470277b 94
d470277b 95%build
ee7b66d9 96%{__gettextize}
d470277b
JB
97%{__libtoolize}
98%{__aclocal} -I m4
99%{__autoconf}
100%{__autoheader}
101%{__automake}
102%configure \
04827781 103 --disable-silent-rules \
d470277b 104 %{!?with_static_libs:--disable-static}
04827781 105%{__make}
d470277b
JB
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113# just tests
04827781
JB
114%{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
115%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
d470277b 116
ee7b66d9
JB
117%find_lang %{name}
118
d470277b
JB
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
ee7b66d9 125%files -f %{name}.lang
d470277b 126%defattr(644,root,root,755)
173d24b3
JB
127%doc AUTHORS COPYING ChangeLog NEWS README TODO
128%attr(755,root,root) %{_bindir}/efreet_icon_cache_dump
04827781
JB
129%attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
130%attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
131%attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
132%attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
133%attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
134%attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
135%dir %{_libdir}/efreet
136%attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
173d24b3 137%attr(755,root,root) %{_libdir}/efreet/efreet_icon_cache_create
d470277b
JB
138
139%files devel
140%defattr(644,root,root,755)
93cc5570
JB
141%attr(755,root,root) %{_libdir}/libefreet.so
142%attr(755,root,root) %{_libdir}/libefreet_mime.so
adf62b9b 143%attr(755,root,root) %{_libdir}/libefreet_trash.so
93cc5570
JB
144%{_libdir}/libefreet.la
145%{_libdir}/libefreet_mime.la
adf62b9b 146%{_libdir}/libefreet_trash.la
04827781 147%{_includedir}/efreet-1
93cc5570
JB
148%{_pkgconfigdir}/efreet.pc
149%{_pkgconfigdir}/efreet-mime.pc
adf62b9b 150%{_pkgconfigdir}/efreet-trash.pc
d470277b
JB
151
152%if %{with static_libs}
153%files static
154%defattr(644,root,root,755)
93cc5570
JB
155%{_libdir}/libefreet.a
156%{_libdir}/libefreet_mime.a
adf62b9b 157%{_libdir}/libefreet_trash.a
d470277b 158%endif
This page took 0.082934 seconds and 4 git commands to generate.