]> git.pld-linux.org Git - packages/efreet.git/blame - efreet.spec
- rel 2
[packages/efreet.git] / efreet.spec
CommitLineData
d470277b
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
8223c02f 5%define ecore_ver 1.0.0
04827781 6%define eet_ver 1.4.0
07e33737 7
d470277b
JB
8Summary: freedesktop.org standards implementation for the EFL
9Summary(pl.UTF-8): Implementacja standardów freedesktop.org dla EFL
10Name: efreet
8223c02f 11Version: 1.0.0
c90c4f85 12Release: 2
04827781 13License: BSD
d470277b 14Group: X11/Libraries
863f344e 15Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
16# Source0-md5: e0ac8c2598003fea833a85de8a3efe26
d470277b 17URL: http://enlightenment.org/p.php?p=about/libs/efreet
93cc5570
JB
18BuildRequires: autoconf >= 2.52
19BuildRequires: automake >= 1.6
07e33737 20BuildRequires: ecore-devel >= %{ecore_ver}
04827781
JB
21BuildRequires: ecore-file-devel >= %{ecore_ver}
22BuildRequires: eet-devel >= %{eet_ver}
d470277b 23BuildRequires: libtool
04827781
JB
24BuildRequires: pkgconfig >= 1:0.22
25Requires: eet >= %{eet_ver}
26Requires: ecore >= %{ecore_ver}
07e33737 27Requires: ecore-file >= %{ecore_ver}
d470277b
JB
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Efreet is an implementation of the following specifications from
32freedesktop.org:
33 - Base Directory - Locations for system and user specific desktop
34 configuration files,
35 - Desktop Entries - The metadata associated with the applications
36 installed on a system,
37 - Application Menus - The arrangement of available applications into
38 a hierarchical menu,
39 - Icon Themes - A means of associating icons with various objects on
40 the desktop in a themable fashion.
41
42By following these specifications, Enlightenment 0.17 uses the same
43format for describing application launchers, menus and icon themes as
44the GNOME, KDE and XFCE Desktop Environments. A system must only
45provide a single set of this data for use with any of these desktops.
46
47%description -l pl.UTF-8
48Efreet to implementacja następujących specyfikacji z freedesktop.org:
49 - Base Directory - położenie plików konfiguracyjnych środowiska dla
50 systemu i użytkownika,
51 - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
52 systemie,
53 - Application Menus - uporządkowanie dostępnych aplikacji w menu
54 hierarchiczne,
55 - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
56 w sposób pozwalający na ustawianie motywów.
57
58%package devel
59Summary: Efreet header files
60Summary(pl.UTF-8): Pliki nagłówkowe Efreet
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
04827781
JB
63Requires: ecore-devel >= %{ecore_ver}
64Requires: ecore-file-devel >= %{ecore_ver}
65Requires: eet-devel >= %{eet_ver}
d470277b
JB
66
67%description devel
68Header files for Efreet.
69
70%description devel -l pl.UTF-8
71Pliki nagłówkowe Efreet.
72
73%package static
74Summary: Static Efreet library
75Summary(pl.UTF-8): Statyczna biblioteka Efreet
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
80Static Efreet library.
81
82%description static -l pl.UTF-8
83Statyczna biblioteka Efreet.
84
85%prep
863f344e 86%setup -q
d470277b 87
d470277b
JB
88%build
89%{__libtoolize}
90%{__aclocal} -I m4
91%{__autoconf}
92%{__autoheader}
93%{__automake}
94%configure \
04827781 95 --disable-silent-rules \
d470277b 96 %{!?with_static_libs:--disable-static}
04827781 97%{__make}
d470277b
JB
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105# just tests
04827781
JB
106%{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
107%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
d470277b
JB
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
115%files
116%defattr(644,root,root,755)
117%doc AUTHORS COPYING README TODO
04827781
JB
118%attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
120%attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
122%attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
124%dir %{_libdir}/efreet
125%attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
d470277b
JB
126
127%files devel
128%defattr(644,root,root,755)
93cc5570
JB
129%attr(755,root,root) %{_libdir}/libefreet.so
130%attr(755,root,root) %{_libdir}/libefreet_mime.so
adf62b9b 131%attr(755,root,root) %{_libdir}/libefreet_trash.so
93cc5570
JB
132%{_libdir}/libefreet.la
133%{_libdir}/libefreet_mime.la
adf62b9b 134%{_libdir}/libefreet_trash.la
04827781 135%{_includedir}/efreet-1
93cc5570
JB
136%{_pkgconfigdir}/efreet.pc
137%{_pkgconfigdir}/efreet-mime.pc
adf62b9b 138%{_pkgconfigdir}/efreet-trash.pc
d470277b
JB
139
140%if %{with static_libs}
141%files static
142%defattr(644,root,root,755)
93cc5570
JB
143%{_libdir}/libefreet.a
144%{_libdir}/libefreet_mime.a
adf62b9b 145%{_libdir}/libefreet_trash.a
d470277b 146%endif
This page took 0.059382 seconds and 4 git commands to generate.