]> git.pld-linux.org Git - packages/efl.git/commitdiff
- added wayland patch (allows to build with wayland, might be not correct)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 7 Dec 2013 17:10:47 +0000 (18:10 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 7 Dec 2013 17:10:47 +0000 (18:10 +0100)
- wayland-related spec updates

efl-wayland.patch [new file with mode: 0644]
efl.spec

diff --git a/efl-wayland.patch b/efl-wayland.patch
new file mode 100644 (file)
index 0000000..1026217
--- /dev/null
@@ -0,0 +1,58 @@
+--- efl-1.8.1/src/modules/evas/engines/wayland_egl/evas_engine.c.orig  2013-11-24 05:18:45.000000000 +0100
++++ efl-1.8.1/src/modules/evas/engines/wayland_egl/evas_engine.c       2013-12-07 12:52:11.209362982 +0100
+@@ -128,8 +128,6 @@
+ /* external variables */
+ int _evas_engine_wl_egl_log_dom = -1;
+-#ifdef GL_GLES
+-
+ # ifndef EGL_NATIVE_PIXMAP_KHR
+ #  define EGL_NATIVE_PIXMAP_KHR 0x30b0
+ # endif
+@@ -146,8 +144,6 @@
+ unsigned int (*glsym_eglUnmapImageSEC) (void *a, void *b, int c) = NULL;
+ unsigned int (*glsym_eglSwapBuffersWithDamage) (EGLDisplay a, void *b, const EGLint *d, EGLint c) = NULL;
+-#endif
+-
+ /* local functions */
+ static Eina_Bool 
+ evgl_init(Render_Engine *re)
+--- efl-1.8.1/src/modules/evas/engines/wayland_egl/evas_engine.h.orig  2013-11-04 12:58:09.000000000 +0100
++++ efl-1.8.1/src/modules/evas/engines/wayland_egl/evas_engine.h       2013-12-07 15:04:14.622363802 +0100
+@@ -6,8 +6,8 @@
+ /* NB: This already includes wayland-client.h */
+ # include <wayland-egl.h>
++# include <EGL/egl.h>
+ # ifdef GL_GLES
+-#  include <EGL/egl.h>
+ /* NB: These are already included from gl_common */
+ /* #  include <GLES2/gl2.h> */
+ /* #  include <GLES2/gl2ext.h> */
+@@ -65,12 +65,10 @@
+         Eina_Bool drew : 1;
+      } draw;
+-#ifdef GL_GLES
+    EGLContext egl_context[1];
+    EGLSurface egl_surface[1];
+    EGLConfig egl_config;
+    EGLDisplay egl_disp;
+-#endif
+    Eina_Bool surf : 1;
+ };
+--- efl-1.8.1/src/modules/evas/engines/wayland_egl/evas_wl_main.c.orig 2013-11-04 12:58:09.000000000 +0100
++++ efl-1.8.1/src/modules/evas/engines/wayland_egl/evas_wl_main.c      2013-12-07 16:55:11.888751090 +0100
+@@ -170,8 +170,10 @@
+         return NULL;
+      }
++#ifdef GL_GLES
+    gw->gl_context->egldisp = gw->egl_disp;
+    gw->gl_context->eglctxt = gw->egl_context[0];
++#endif
+    eng_window_use(gw);
+    evas_gl_common_context_resize(gw->gl_context, w, h, rot);
index 5ca234d06157c60e0cec253777f2774d4e7393e0..f685fcd6e1db8bb36343204c0cdec748c78adc2f 100644 (file)
--- a/efl.spec
+++ b/efl.spec
@@ -31,6 +31,7 @@ Group:                Libraries
 Source0:       http://download.enlightenment.org/rel/libs/efl/%{name}-%{version}.tar.bz2
 # Source0-md5: 2289689fb6439eec251156f10ee0a203
 Patch0:                %{name}-pc.patch
+Patch1:                %{name}-wayland.patch
 URL:           https://trac.enlightenment.org/e/wiki/EFL
 %{?with_egl:BuildRequires:     EGL-devel}
 BuildRequires: OpenGL-GLX-devel
@@ -313,16 +314,6 @@ Requires:  ecore = %{version}-%{release}
 Requires:      ecore-input = %{version}-%{release}
 Requires:      ecore-input-evas = %{version}-%{release}
 Requires:      evas = %{version}-%{release}
-# for individual modules now
-##Requires:    ecore-fb = %{version}-%{release}
-##Requires:    ecore-ipc = %{version}-%{release}
-##Requires:    ecore-sdl = %{version}-%{release}
-%if %{with wayland}
-##Requires:    ecore-wayland = %{version}-%{release}
-#Requires:     Mesa-libwayland-egl >= 9.2.0
-#Requires:     Mesa-libEGL >= 7.10
-%endif
-##Requires:    ecore-x = %{version}-%{release}
 
 %description -n ecore-evas
 Ecore Evas library.
@@ -631,6 +622,22 @@ Ecore IMF SCIM input method module.
 %description -n ecore-imf-module-scim -l pl.UTF-8
 Ecore IMF - moduł metody wprowadzania znaków SCIM.
 
+%package -n ecore-imf-module-wayland
+Summary:       Ecore IMF Wayland input method module
+Summary(pl.UTF-8):     Ecore IMF - moduł metody wprowadzania znaków Wayland
+License:       BSD
+Group:         Libraries
+URL:           http://trac.enlightenment.org/e/wiki/Ecore
+Requires:      ecore-evas = %{version}-%{release}
+Requires:      ecore-imf = %{version}-%{release}
+Requires:      ecore-wayland = %{version}-%{release}
+
+%description -n ecore-imf-module-wayland
+Ecore IMF Wayland input method module.
+
+%description -n ecore-imf-module-wayland -l pl.UTF-8
+Ecore IMF - moduł metody wprowadzania znaków Wayland.
+
 %package -n ecore-imf-module-xim
 Summary:       Ecore IMF XIM input method module
 Summary(pl.UTF-8):     Ecore IMF - moduł metody wprowadzania znaków XIM
@@ -875,6 +882,7 @@ Group:              Libraries
 Requires:      ecore = %{version}-%{release}
 Requires:      ecore-input = %{version}-%{release}
 Requires:      wayland >= 1.3.0
+Requires:      xorg-lib-libxkbcommon >= 0.3.0
 
 %description -n ecore-wayland
 Ecore Wayland library.
@@ -889,6 +897,7 @@ Group:              Development/Libraries
 Requires:      ecore-devel = %{version}-%{release}
 Requires:      ecore-input-devel = %{version}-%{release}
 Requires:      wayland-devel >= 1.3.0
+Requires:      xorg-lib-libxkbcommon-devel >= 0.3.0
 
 %description -n ecore-wayland-devel
 Header file for Ecore Wayland library.
@@ -1947,6 +1956,8 @@ Summary(pl.UTF-8):        Moduł silnika renderującego Wayland EGL dla Evas
 License:       BSD
 Group:         Libraries
 URL:           http://trac.enlightenment.org/e/wiki/Evas
+Requires:      Mesa-libEGL-devel >= 7.10
+Requires:      Mesa-libwayland-egl-devel >= 9.2.0
 Requires:      evas = %{version}-%{release}
 
 %description -n evas-engine-wayland_egl
@@ -2129,6 +2140,7 @@ Obsługa składni EDC dla Vima.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -2450,7 +2462,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/ecore_imf/modules
 %{_datadir}/ecore_imf
 
-
 %files -n ecore-imf-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libecore_imf.so
@@ -2479,6 +2490,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/ecore_imf/modules/scim/linux-gnu-*/module.so
 %endif
 
+%if %{with wayland}
+%files -n ecore-imf-module-wayland
+%defattr(644,root,root,755)
+%dir %{_libdir}/ecore_imf/modules/wayland
+%dir %{_libdir}/ecore_imf/modules/wayland/linux-gnu-*
+%attr(755,root,root) %{_libdir}/ecore_imf/modules/wayland/linux-gnu-*/module.so
+%endif
+
 %if %{without xcb_api}
 %files -n ecore-imf-module-xim
 %defattr(644,root,root,755)
This page took 0.080437 seconds and 4 git commands to generate.