]> git.pld-linux.org Git - packages/efivar.git/commitdiff
- updated to 38
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 30 Jun 2022 20:15:21 +0000 (22:15 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 30 Jun 2022 20:15:21 +0000 (22:15 +0200)
- updated static patch
- added link patch (fix libefisec linking)

efivar-link.patch [new file with mode: 0644]
efivar-static.patch
efivar.spec

diff --git a/efivar-link.patch b/efivar-link.patch
new file mode 100644 (file)
index 0000000..353b1c4
--- /dev/null
@@ -0,0 +1,10 @@
+--- efivar-38/src/Makefile.orig        2022-06-30 19:48:47.290249983 +0200
++++ efivar-38/src/Makefile     2022-06-30 21:20:10.960542390 +0200
+@@ -114,6 +114,7 @@ libefisec.a : $(patsubst %.o,%.static.o,
+ libefisec.so : $(LIBEFISEC_OBJECTS)
+ libefisec.so : | libefisec.map
++libefisec.so : LIBS=efivar
+ libefisec.so : MAP=libefisec.map
+ efisecdb : $(EFISECDB_OBJECTS) | libefisec.so
index 13000dedbb2c3f23de285153d4e38ebb3b9c502d..68cc23ba0264ea92fe1c6b603fa56b3ca20d24d5 100644 (file)
@@ -1,6 +1,6 @@
---- efivar-36/src/Makefile.orig        2018-10-16 20:54:52.522433949 +0200
-+++ efivar-36/src/Makefile     2018-10-16 20:57:31.875765467 +0200
-@@ -100,12 +100,14 @@
+--- efivar-38/src/Makefile.orig        2018-10-16 20:54:52.522433949 +0200
++++ efivar-38/src/Makefile     2018-10-16 20:57:31.875765467 +0200
+@@ -146,12 +146,14 @@ install : all
                ln -fs $(x).1.$(VERSION) $(DESTDIR)$(LIBDIR)/$(x).1 ;\
                ln -fs $(x).1.$(VERSION) $(DESTDIR)$(LIBDIR)/$(x) ;\
                )
@@ -8,9 +8,9 @@
        $(INSTALL) -d -m 755 $(DESTDIR)$(PCDIR)
        $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(x) $(DESTDIR)$(PCDIR) ;)
        $(INSTALL) -d -m 755 $(DESTDIR)$(INCLUDEDIR)/efivar
-       $(foreach x, $(wildcard $(TOPDIR)/src/include/efivar/*.h), $(INSTALL) -m 644 $(x) $(DESTDIR)$(INCLUDEDIR)/efivar/$(notdir $(x));)
+       $(foreach x, $(sort $(wildcard $(TOPDIR)/src/include/efivar/*.h)), $(INSTALL) -m 644 $(x) $(DESTDIR)$(INCLUDEDIR)/efivar/$(notdir $(x));)
        $(INSTALL) -d -m 755 $(DESTDIR)$(BINDIR)
-       $(foreach x, $(BINTARGETS), $(INSTALL) -m 755 $(x) $(DESTDIR)$(BINDIR);)
+       $(foreach x, $(filter-out %-test,$(BINTARGETS)), $(INSTALL) -m 755 $(x) $(DESTDIR)$(BINDIR);)
 +      $(foreach x, $(STATICBINTARGETS), $(INSTALL) -m 755 $(x) $(DESTDIR)$(BINDIR);)
  
  test : all
index 49a14d6b2f668788304d02e8f59695380c0baa34..7a4e0a85397cb4be340354a5776137b64b220050 100644 (file)
@@ -6,16 +6,18 @@
 Summary:       Tools to manage UEFI variables
 Summary(pl.UTF-8):     Narzędzia do zarządzania zmiennymi UEFI
 Name:          efivar
-Version:       37
+Version:       38
 Release:       1
 License:       LGPL v2.1
 Group:         Applications/System
 #Source0Download: https://github.com/rhinstaller/efivar/releases
 Source0:       https://github.com/rhinstaller/efivar/releases/download/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 9f067275c5f7aafdd75bfb364280ac9c
+# Source0-md5: 243fdbc48440212695cb9c6e6fd0f44f
 Patch0:                %{name}-static.patch
+Patch1:                %{name}-link.patch
 URL:           https://github.com/rhinstaller/efivar
 BuildRequires: linux-libc-headers >= 7:3.3
+BuildRequires: mandoc
 BuildRequires: popt-devel
 %if %{with static}
 BuildRequires: glibc-static
@@ -71,6 +73,7 @@ Statyczna biblioteka efivar.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %if "%{cc_version}" >= "9"
@@ -104,25 +107,31 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md TODO
+%attr(755,root,root) %{_bindir}/efisecdb
 %attr(755,root,root) %{_bindir}/efivar
 %if %{with static}
 %attr(755,root,root) %{_bindir}/efivar-static
 %endif
+%{_mandir}/man1/efisecdb.1*
 %{_mandir}/man1/efivar.1*
 
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libefiboot.so.1.*
 %attr(755,root,root) %ghost %{_libdir}/libefiboot.so.1
+%attr(755,root,root) %{_libdir}/libefisec.so.1.*
+%attr(755,root,root) %ghost %{_libdir}/libefisec.so.1
 %attr(755,root,root) %{_libdir}/libefivar.so.1.*
 %attr(755,root,root) %ghost %{_libdir}/libefivar.so.1
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libefiboot.so
+%attr(755,root,root) %{_libdir}/libefisec.so
 %attr(755,root,root) %{_libdir}/libefivar.so
 %{_includedir}/efivar
 %{_pkgconfigdir}/efiboot.pc
+%{_pkgconfigdir}/efisec.pc
 %{_pkgconfigdir}/efivar.pc
 %{_mandir}/man3/efi_*.3*
 
@@ -130,5 +139,6 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libefiboot.a
+%{_libdir}/libefisec.a
 %{_libdir}/libefivar.a
 %endif
This page took 0.258232 seconds and 4 git commands to generate.