]> git.pld-linux.org Git - packages/efi-boot-update.git/blame - efi-boot-update.spec
Fix boot order setup when efibootmgr is unavail
[packages/efi-boot-update.git] / efi-boot-update.spec
CommitLineData
7a63766a
JK
1# $Revision: 1.81 $, $Date: 2012/04/20 10:52:52 $
2#
3Summary: EFI bootloader updater
4Name: efi-boot-update
5Version: 0.1
6Release: 0.1
7License: GPL v2
8Group: Applications
9Source0: %{name}
10Source1: update.conf
11Source2: shellx64.conf
12Source3: shellx32.conf
13Source4: grub.conf
14Source10: README
15Source11: TODO
16URL: http://www.pld-linux.org/
17BuildRequires: help2man
18Suggests: efibootmgr
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _sbindir /sbin
22
23%description
24Script to update EFI bootloaders.
25
26%prep
27%setup -qcT
28cp %{SOURCE0} .
29cp %{SOURCE10} %{SOURCE11} .
30
31%build
32chmod a+x %{name}
33help2man --no-info ./%{name} > %{name}.8
34
35%install
36rm -rf $RPM_BUILD_ROOT
37install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
38install -d $RPM_BUILD_ROOT{%{_prefix}/lib{,64}/efi,%{_sbindir},%{_mandir}/man8}
39
40install %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
41install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
42install %{SOURCE1} $RPM_BUILD_ROOT/etc/efi-boot
43install %{SOURCE2} %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/efi-boot/update.d
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48# Most efi-boot-update-managed loaders will use kernel files
49# even if the kernel itself is not build as EFI
50%triggerin -- kernel
51/sbin/efi-boot-update
52%triggerin -- kernel-longterm
53/sbin/efi-boot-update
54
55%files
56%defattr(644,root,root,755)
57%doc README TODO
58%attr(755,root,root) %{_sbindir}/%{name}
59%dir /etc/efi-boot
60%config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.conf
61%config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/*.conf
62%dir /etc/efi-boot/update.d
63%dir %{_libdir}/efi
64%if "%{_libdir}" != "%{_prefix}/lib"
65%dir %{_prefix}/lib/efi
66%endif
67%{_mandir}/man8/%{name}.8*
This page took 0.13247 seconds and 4 git commands to generate.