]> git.pld-linux.org Git - packages/eet.git/blobdiff - eet.spec
- release 2 (by relup.sh)
[packages/eet.git] / eet.spec
index c3323f2d7fd58b29027dc1830cd3f5f7361fb9cd..628b3b8170cfc424c497c379128546cdd84582b1 100644 (file)
--- a/eet.spec
+++ b/eet.spec
@@ -1,26 +1,33 @@
+# NOTE: for versions >= 1.8 see efl.spec
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
 #
+%define        eina_ver        1.7.10
 Summary:       Library for speedy data storage, retrieval, and compression
 Summary(pl.UTF-8):     Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
 Name:          eet
-Version:       1.0.1
-Release:       1
+Version:       1.7.10
+Release:       2
 License:       BSD
 Group:         Libraries
-Source0:       http://download.enlightenment.org/snapshots/2008-05-19/%{name}-%{version}.tar.bz2 
-# Source0-md5: d217fe8b657b283ab82aeaa880355f0c
-URL:           http://enlightenment.org/p.php?p=about/libs/eet
-BuildRequires: autoconf
-BuildRequires: automake >= 1.4
+Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
+# Source0-md5: 396ccb7094518cb9ce6939e7d2c6ef8c
+URL:           http://trac.enlightenment.org/e/wiki/Eet
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake >= 1.6
+BuildRequires: eina-devel >= %{eina_ver}
+BuildRequires: gnutls-devel >= 1.7.6
+BuildRequires: libgcrypt-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libtool
+BuildRequires: pkgconfig >= 1:0.22
+BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
+Requires:      eina >= %{eina_ver}
+Requires:      gnutls >= 1.7.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%undefine      __cxx
-
 %description
 Eet is a tiny library designed to write an arbitary set of chunks of
 data to a file and optionally compress each chunk (very much like a
@@ -53,6 +60,9 @@ Summary:      Header files for Eet library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Eet
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      eina-devel >= %{eina_ver}
+Requires:      gnutls-devel >= 1.7.6
+Requires:      libgcrypt-devel
 Requires:      libjpeg-devel
 Requires:      zlib-devel
 
@@ -79,11 +89,12 @@ Statyczna biblioteka Eet.
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
+       --disable-silent-rules \
        %{!?with_static_libs:--disable-static}
 %{__make}
 
@@ -93,6 +104,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+install -d $RPM_BUILD_ROOT%{_examplesdir}
+mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -101,16 +115,18 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING COPYING-PLAIN README
+%doc AUTHORS COPYING NEWS README
 %attr(755,root,root) %{_bindir}/eet
-%attr(755,root,root) %{_libdir}/libeet.so.*
+%attr(755,root,root) %{_libdir}/libeet.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libeet.so.1
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libeet.so
 %{_libdir}/libeet.la
+%{_includedir}/eet-1
 %{_pkgconfigdir}/eet.pc
-%{_includedir}/Eet.h
+%{_examplesdir}/%{name}-%{version}
 
 %if %{with static_libs}
 %files static
This page took 0.057902 seconds and 4 git commands to generate.