]> git.pld-linux.org Git - packages/eet.git/blame - eet.spec
- updated to 1.7.6
[packages/eet.git] / eet.spec
CommitLineData
2fb44219
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
146ac757 5Summary: Library for speedy data storage, retrieval, and compression
9dd89ee4 6Summary(pl.UTF-8): Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
231027b5 7Name: eet
35d78ab2 8Version: 1.7.6
86bfc941 9Release: 1
146ac757 10License: BSD
11Group: Libraries
22cba8c0 12Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
35d78ab2 13# Source0-md5: 24cb0f2c33bfcc403bd0ce2860bd3633
2893dd8f 14URL: http://trac.enlightenment.org/e/wiki/Eet
98181c2d
JB
15BuildRequires: autoconf >= 2.52
16BuildRequires: automake >= 1.6
86bfc941 17BuildRequires: eina-devel >= 1.2.0
0c57ecba 18BuildRequires: gnutls-devel >= 1.7.6
a6e34d2e 19BuildRequires: libgcrypt-devel
146ac757 20BuildRequires: libjpeg-devel
21BuildRequires: libtool
0c57ecba
JB
22BuildRequires: pkgconfig >= 1:0.22
23BuildRequires: sed >= 4.0
146ac757 24BuildRequires: zlib-devel
86bfc941 25Requires: eina >= 1.2.0
0c57ecba 26Requires: gnutls >= 1.7.6
146ac757 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Eet is a tiny library designed to write an arbitary set of chunks of
31data to a file and optionally compress each chunk (very much like a
32zip file) and allow fast random-access reading of the file later on.
33It does not do zip as a zip itself has more complexity than is needed,
34and it was much simpler to implement this once here.
35
36It also can encode and decode data structures in memory, as well as
37image data for saving to eet files or sending across the network to
38other machines, or just writing to arbitary files on the system. All
39data is encoded in a platform independant way and can be written and
40read by any architecture.
41
347bfef3
JR
42%description -l pl.UTF-8
43Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
44porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
45do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
46swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
47złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
2760e594
JB
48jest.
49
347bfef3
JR
50Biblioteka może także kodować i dekodować struktury danych w pamięci,
51a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
52inne maszyny, lub po prostu zapisywania do dowolnych plików w
53systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
54i mogą być zapisywane i odczytywane na dowolnej architekturze.
2760e594 55
146ac757 56%package devel
2760e594 57Summary: Header files for Eet library
9dd89ee4 58Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Eet
146ac757 59Group: Development/Libraries
2760e594 60Requires: %{name} = %{version}-%{release}
86bfc941 61Requires: eina-devel >= 1.2.0
0c57ecba
JB
62Requires: gnutls-devel >= 1.7.6
63Requires: libgcrypt-devel
f6dec708
KK
64Requires: libjpeg-devel
65Requires: zlib-devel
146ac757 66
67%description devel
2760e594
JB
68Header files for Eet library.
69
347bfef3
JR
70%description devel -l pl.UTF-8
71Pliki nagłówkowe biblioteki Eet.
146ac757 72
73%package static
2760e594 74Summary: Static Eet library
9dd89ee4 75Summary(pl.UTF-8): Statyczna biblioteka Eet
146ac757 76Group: Development/Libraries
2760e594 77Requires: %{name}-devel = %{version}-%{release}
146ac757 78
79%description static
2760e594
JB
80Static Eet library.
81
347bfef3 82%description static -l pl.UTF-8
2760e594 83Statyczna biblioteka Eet.
146ac757 84
85%prep
22cba8c0 86%setup -q
146ac757 87
88%build
f2726464 89%{__libtoolize}
a6e34d2e 90%{__aclocal} -I m4
f2726464 91%{__autoconf}
92%{__autoheader}
93%{__automake}
2fb44219 94%configure \
0c57ecba 95 --disable-silent-rules \
2fb44219 96 %{!?with_static_libs:--disable-static}
0c57ecba 97%{__make}
146ac757 98
99%install
100rm -rf $RPM_BUILD_ROOT
2760e594 101
146ac757 102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
e41fe325
JB
105install -d $RPM_BUILD_ROOT%{_examplesdir}
106mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
107
146ac757 108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112%postun -p /sbin/ldconfig
113
114%files
115%defattr(644,root,root,755)
231027b5 116%doc AUTHORS COPYING NEWS README
c3e75f65 117%attr(755,root,root) %{_bindir}/eet
4a540096
JB
118%attr(755,root,root) %{_libdir}/libeet.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libeet.so.1
146ac757 120
121%files devel
122%defattr(644,root,root,755)
146ac757 123%attr(755,root,root) %{_libdir}/libeet.so
124%{_libdir}/libeet.la
2ff37400 125%{_includedir}/eet-1
146ac757 126%{_pkgconfigdir}/eet.pc
e41fe325 127%{_examplesdir}/%{name}-%{version}
146ac757 128
2fb44219 129%if %{with static_libs}
146ac757 130%files static
131%defattr(644,root,root,755)
132%{_libdir}/libeet.a
2fb44219 133%endif
This page took 0.08235 seconds and 4 git commands to generate.