]> git.pld-linux.org Git - packages/edna.git/blob - edna.spec
- added PreReq: rc-scripts and Requires(): /sbin/chkconfig for daemon
[packages/edna.git] / edna.spec
1 #
2 # TODO: 
3 #       - init script should be fixed
4 #
5 Summary:        Edna - streaming server
6 Summary(pl):    Edna - serwer strumieni
7 Name:           edna
8 Version:        0.5
9 Release:        1
10 License:        GPL
11 Group:          Applications/Sound
12 Source0:        http://edna.sourceforge.net/%{name}-%{version}.tar.gz
13 # Source0-md5:  ec3d46b25fa582b78db7c32acf78da47
14 Source1:        %{name}.init
15 URL:            http://edna.sourceforge.net/
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Edna allows you to access your MP3 collection from any networked
23 computer. This software streams your MP3s via HTTP to any MP3 player
24 that supports playing off a remote connection (e.g. Winamp, FreeAmp,
25 Sonique, XMMS). Edna supports Ogg files either.
26
27 %description -l pl
28 Edna umo¿liwia dostêp do kolekcji MP3 z dowolnego komputera maj±cego
29 dostêp do sieci. Ten program wysy³a strumieñ MP3 po HTTP do dowolnego
30 odtwarzacza MP3 obs³uguj±cego odtwarzanie przez po³±czenie sieciowe
31 (jak Winamp, FreeAmp, Sonique, XMMS). Edna obs³uguje tak¿e pliki Ogg.
32
33 %prep
34 %setup -q
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
39 install -d $RPM_BUILD_ROOT%{_sysconfdir}/edna
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/edna
45 install edna.conf $RPM_BUILD_ROOT%{_sysconfdir}/edna
46 ln -sf /usr/lib/edna/templates $RPM_BUILD_ROOT%{_sysconfdir}/edna/templates
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 /sbin/chkconfig --add edna
53 if [ -f /var/lock/subsys/edna ]; then
54         /etc/rc.d/init.d/edna restart >&2
55 else
56         echo "Run '/etc/rc.d/init.d/edna start' to start edna daemon." >&2
57 fi
58
59 %preun
60 if [ "$1" = "0" ] ; then
61         if [ -f /var/lock/subsys/edna ]; then
62                 /etc/rc.d/init.d/edna stop >&2
63         fi
64         /sbin/chkconfig --del edna >&2
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog README
70 %attr(755,root,root) %{_bindir}/edna
71 %attr(754,root,root) /etc/rc.d/init.d/edna
72 %dir %{_sysconfdir}/edna
73 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/edna/edna.conf
74 %{_sysconfdir}/edna/templates
75 %dir %{_libdir}/%{name}
76 %attr(755,root,root) %{_libdir}/%{name}/*.py
77 %{_libdir}/%{name}/templates
This page took 0.066616 seconds and 4 git commands to generate.