]> git.pld-linux.org Git - packages/edna.git/blob - edna.spec
- initial release
[packages/edna.git] / edna.spec
1 #
2 # TODO: 
3 #       - init script should be fixed
4 #
5 Summary:        Edna - streaming server.
6 Name:           edna
7 Version:        0.5
8 Release:        1
9 License:        GPL
10 Group:          Applications/Sound
11 Source0:        http://edna.sourceforge.net/%{name}-%{version}.tar.gz
12 # Source0-md5:  ec3d46b25fa582b78db7c32acf78da47
13 Source1:        %{name}.init
14 URL:            http://edna.sourceforge.net/
15 Requires:       python
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Edna allows you to access your MP3 collection from any networked computer.
20 This software streams your MP3s via HTTP to any MP3 player that supports
21 playing off a remote connection (e.g. Winamp, FreeAmp, Sonique, XMMS).
22 Edna supports ogg files either.
23
24 %prep
25 %setup -q
26
27 %build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT
32
33 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
34 install -d $RPM_BUILD_ROOT/%{_sysconfdir}/edna
35
36 %{__make} install \
37         DESTDIR=$RPM_BUILD_ROOT
38
39 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/edna
40 install edna.conf $RPM_BUILD_ROOT/%{_sysconfdir}/edna
41 ln -sf /usr/lib/edna/templates $RPM_BUILD_ROOT/%{_sysconfdir}/edna/templates
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 /sbin/chkconfig --add edna
48 if [ -f /var/lock/subsys/edna ]; then
49         /etc/rc.d/init.d/edna restart >&2
50 else
51         echo "Run '/etc/rc.d/init.d/edna start' to start edna daemon." >&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ] ; then
56         if [ -f /var/lock/subsys/edna ]; then
57                 /etc/rc.d/init.d/edna stop >&2
58         fi
59         /sbin/chkconfig --del edna >&2
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog README
65 %attr(755,root,root) %{_bindir}/edna
66 %attr(755,root,root) %{_libdir}/%{name}/*.py
67 %attr(754,root,root) /etc/rc.d/init.d/edna
68 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/edna/edna.conf
69 %{_sysconfdir}/edna/templates
70 %{_libdir}/%{name}/templates/*
This page took 0.064293 seconds and 4 git commands to generate.